Dashboard Theming (Custom CSS) and Mounting Hardware Ideas

It magically started working again so all is good. I am curious as to what was the issue.

Resolved without intervention required by us at ActionTiles, so we’ll review the SmartThings post mortem once available.

###Our official Topic is at:

I seem to be having an issue with SmartTiles getting the Launcher URL and Preview Browse for all of my panels from the app. It appears to be oauth invalid_token error. I can get to the dashboards from previously recorded URLs, just can’t get them from the app.

I haven’t tried doing much with SmartTiles in awhile (since AT release) so I can’t say it was related to the recent hub update or the other issue experienced yesterday.

I am having the same error on all current and a new dash board I created with smart tiles(to test) this all started on Thursday 4-6-2017. using a first gen Fire for display(actiontiles struggles on old browser) so I am waiting on budget for new tablet to migrate. would love to keep Smarttiles working for about another month. @tgauchat any thoughts?

Can you please describe this problem in more detail? Step-by-step, screen shots, etc?

I’m not having any problems with my quick test of SmartTiles.

###Actually, would you please respond on our main SmartTiles Topic (bullet below), instead of here “Theming (Custom CSS) & Mounting” Topic, please?


###Please note; SmartTiles is about to reach end-of-life for support.
Please sign-up for ActionTiles as soon as possible so that you can begin moving over to it.


This is just seriously brilliant. Sugru, who make a rubbery adhesive have instructions for how to make a custom tablet mount just using three blobs of Sugru and, yes, you can take the tablet out and put it back whenever you want. I mean, seriously brilliant. :sunglasses:


And, it comes in different colors including black and white.

I was first introduced to this product for use sticking the Naran Microbots to various devices. I’ve only had mine up for two months, so I can’t speak to how well it lasts longterm, but it molds and holds very well so far. :sunglasses:


@tgauchat @bamarayne @johnconstantelo @Sbdobrescu @NWTony @MichaelS @michaelahess @slagle @Navat604 @TheSmartestHouse


So is SmartTiles no longer working?
Mine hasn’t been working for about a week now…

What do you mean, exactly by “is no longer working”?

I’m betting:

  • (a) You have not been using a Launcher URL, as has been the official requirement for 11 months.
  • and (b) You missed this KB post:


Looks like it I can’t control the switches or buttons.
I can see the dashboard and it updates when lights/doors change but I can’t control anything.

Checking to be sure: You’re using SmartTiles, right, not ActionTiles?

In either case, could you check out your Live Logging (SmartThings graph/api/ide page…) please?

SmartTiles - yes.
Sorry, this might not be a Smart Tiles issue.
Turns out I can control virtual switches and switches

I just can’t control z-wave lights lol
Even manually going through the ST app, I can’t control any z-wave lights switches.

I keep getting this in my live log under my Smart Tiles:
I put XXXX in some places, not sure I should share certain things?

cdXXXXed-94cd-4175-XXXXXXX ‎6‎:‎36‎:‎03‎ ‎PM: debug params: [ts:XXXXXXX, stateID:XXXXXX, _:XXXXXXXX, access_token:XXX-XXX, appId:cXX622ed-94cd-4175-b1f5-XXXXXXXX, param1:ping, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi]

We already mask “accesstoken” in the debug log (right?), so it’s safe to share the log entry.

Well… the above explains the problem; it’s outside the scope of SmartTiles (& ActionTiles) to “fix” SmartThings. :confounded:

OR, I’m sure that anybody that plays with ST in this fashion will have at least 2-3 old routers running DDWRT on them in a closet collecting dust, well you can put the old units to good use and use them for a HTTP proxy server that ST will find acceptable.

I have a quick question for the users that are leaving their mounted tablets on at all times or with motion detection through fully kiosk. Are you powering your tablets through a usb cable to a usb outlet? Or a regular wall outlet with a power adapter? And is your tablet always staying fully charged?

I have a mounted tablet running actiontiles that is plugged into a recessed outlet shown below with just a usb cable. The tablet still continuously drains battery and is VERY slow charging even when off. I would think it should stay at 100% charge at all times? I’m just not sure if I should get a different outlet or if the usb cable/connection is not enough power and I need to use the power adapter.

1 Like

Have you tested both USB ports on the outlet? Charging other devices with that outlet? Type of Tablet?

Hi all

I have a dashboard running SmartTiles in Kiosk browser.
On that I have a Momentary button, with the purpose to open an app on my tablet.
When after clicking the button, the “signal” goes to the cloud, seconds later SharpTools finds out it has been clicked, which triggers Tasker to open the app.

It works, BUT it takes several seconds for that to work. My wife is not patient.

Is there any way to speed up opening a local app, by pushing a button on SmartTiles?

We have a couple Topics / discussions open on this on ActionTiles’s forum…, but need to add to the research

And please explore the Forum for more… thanks.

I have my iPad always on and my USB power is plugged into a Lowes Iris zigbee plug with energy reporting. The plug is turning on/off and duration depending on the time of the day because of the auto brightness option in the iPad setting which varies the power reporting.
Leaving the iPad permanently with 100% = bulge battery.

1 Like

@Toasty I did try both USB ports on the outlet and there was no difference. This was happening with multiple tablets since I was testing a few to see which one I liked the best (7" Fire, 8" Fire and Insignia tablets). The tablets would sometime even lose battery when the screen was off. I finally got around to trying a different USB cable and it seems to now charge and hold well. I will continue to monitor to see if I have any more issues.

@Navat604 Thanks for the tip on the battery always being at 100%. I wouldn’t be able to fit one of those iris plug in my recessed outlet though. I could get a GE Z-wave outlet and have it turn on and off through various schedules. Issue with that is I don’t want use the USB power adapter since it sticks out too much and impacts the tablet placement. I wonder if anyone makes a Z-wave USB outlet.

1 Like

@franctel Sounds like you could use this:

I use these behind GFCI outlets in my exterior walls to control Christmas lights and the like. The boxes for these outlets are quite small and there is plenty room in there for this relay, the GFCI outlet, and an inline 10A fuse. I would definitely recommend them.

1 Like