Danalock v3 smart lock

As far as I know, the only model which is currently available is the Bluetooth version, and that one will not work with SmartThings.

http://shop.danalock.com/products/6-poly-lock-cylinder/31-danalock-v3-bt--fittings/

The V2 version which worked with SmartThings was the Z wave one. I would expect the V3 zwave version to also work, but again, as far as I know that model has not yet been released. Also, it will have to be on the same frequency as your SmartThings hub, as the UK and US frequencies are different.

The V3 is intended to be released in 4 models:

Bluetooth only
US zwave and bluetooth
UK zwave and bluetooth
Zigbee

So which exact model did you get? And which version of the SmartThings hub do you have?

Dang. You’re completely right. In my hurriedness I ended up getting the BT version. For some reason I thought the device had z-wave and BT. Too good to be true.

Guess, I’m stuck with it then. :frowning:

1 Like

So far, I believe all of the Danalock models that have Z wave also have Bluetooth, but not the other way around.

I reached out to Danalock and we can expect the Bluetooth and Zwave version of the V3 lock by ‘mid August’.

I’ll be investing in one.

I might well wait for Teodoor lock. It’s listed on Indiegogo right now. Trouble with Danalock is you need to replace your Euro cylinder with one that’s not secure!

I purchased and installed the new danalock v3 with zwave eu support today but there is no way to make it pair with smartthings… i literally tried everything but nothing, I emailed danalock support and actually waiting for their answer to understand if it’s just unluck and i have a faulty unit or if there’s a specific problem with pairing on smartthings.

I did the same as you, and it works flawless. Very satisfied so far. :sunglasses:
Do not use the Danalock app for ST setup. Place the Danalock within 1 meters of ST. Set ST in detection mode and push the button once at the DanaLock. Hope it helps. (This is on the last page of my user manual)

1 Like

Thanks tore it worked! I didnt notice that damn last page and that tiny hole… :sweat_smile:

BTW what DH do you use for it? With the defaul Z Wave Lock or the Danalock DH integrated in ST i can just check its status, open or close lock doesn’t work

I did not add any DH. The default is working for me. Lock, Unlock and status is working without any changes/adding.

Hmm… Looks like i have to re-pair it because the Lock/Unlock buttons do nothing for me, i will try today hoping it’s not faulty and i just somehow got a bad pairing with it

Wait a moment… does it need the hub to be ALWAYS at 1 meter from it? Because i re-paired it and everything was working now then i moved the hub back to my usual location ( 4-5 meters from it ) and it doesnt work anymore. I’ve tons of zwave peripherals in the house so the coverage should be total everywhere.

No, it does not need to be 1 meter away. Just during pairing. Mine is about 5 meters away (through a wall) and working well.

After i succesfully pair the danalock to my smartthings v2 eu hub, tried both bringing the hub to the lock and bringing the lock to the hub but in both scenarios the same issue occurs, once i put back the hub and the lock to their respective places ( approx 4-5 meters ) i can no longer control the lock through my zwave network. This is weird because i got a lot of zwave devices in my house that build up the zwave mesh and one of them ( a fibaro door contact sensor ) is very near the danalock location, i even tried doing several z wave network repairs but it doesnt seems to fix the issue, once i even got an error about danalock not being able to build a new path in the network. Is there anything i can do to make it work?

update i tried a zwave network repair again and this is the error i get:

Network repair for Universal Z-Wave Lock With Alarms [15]: Failed to update route

1 Like

You may need to have a “beaming” repeater Close to the lock. Beaming is a feature required by zwave locks but not by any other devices. What zwave repeater is closest to the lock right now? ( you probably already know this, but battery powered devices do not repeat, only mains powered ones.)

http://thingsthataresmart.wiki/index.php?title=Beaming

1 Like

Thanks for the knowledge about beaming JD i didn’t know about it! The closest repeater to the lock are some fibaro roller shutter 2 relays that i use for my blinds but they are about 4-5 meters away… i’m just trying to figure out which beaming repeater is convenient for me to put near the danalock to try this out now… or maybe i could just try to move the hub more near the lock?

The Fibaro roller shutter does support beaming, but I think it’s just too far away.

https://products.z-wavealliance.org/products/38/embedpics

If it’s convenient for you to move the hub closer, you can certainly do that. The hub itself is a beaming device.

Otherwise you can check the conformance statements for any other devices you’re considering to see if they support beaming. You’ll have to look them up one at a time, though.

https://products.z-wavealliance.org/regions/1/categories/16/products

I tried to move the hub near the danalock and even at half meter it doesnt work if the hub is not facing the lock directly… this is incredible, i point it to the lock with the front and the lock works, i turn it around same distance no obstacles and nothing, what the hell…

1 Like

I’ve seen and heard this from many folks before. It’s likely the position of the lock, hub and the environment, walls etc. It affects how the signals reflect and finally work.

Best solution is to buy a repeater or two (active Z-Wave mains powered devices like a switch) and that makes for a stronger mesh and tends to overcome these issues.

1 Like

Any update on a device handler for this?
I installed the Zwave Version of the Danalock V3 and the standard zwave lock code works fine for unlocking & locking.
However, its wrong for Battery (always showing 0%) and is polling the device every hour (which is not required for Danalock).

In the manual for Danalock there are some codes highlighted for the battery conversion, but i have no idea how to include them in a custom device handler:

12 V - 0x62 (98%)
9V - 0x26 (38%)
7,5 V - 0x0B (11%) (Battery warning will be sent)

Ok then, i’ve now an aeotec zwave siren which supports beaming at less then a meter from the danalock but still nothing. After i pair it with the smartthings hub near it everything works fine, but when i move the hub back to its original location the lock stops responding to zwave commands so i try to do a zwave network repair and i always get this error message:

Network repair for Universal Z-Wave Lock With Alarms [16]: Failed to update route

I really have no idea what else to do, danalock’s support seems to be out of ideas as well. Also with this device handlers from rboy batteries are draining like crazy, i had to change them already after 10 days when they are supposed to last 1 year…

This is a photo of my situation where you clearly can see how near are the danalock and the siren on bottom left…