Custom Device Types and Android?


(Shreddin Pb) #1

Has anyone gotten this to work?
I have been writing a custom device type and whenever I click on it, it crashes the app. I figured it was my sloppy programming that was doing it so I ran a test.

I added a arduino shield device type to my app thru the web interface. This seems to work as expected, it does nothing, but can click on it and get into the tiles.
I then make my own device type, thru the examples I use the arduino shield code from the examples and save and publish. I then add that device to the app thru the web interface, it crashes the app.

Is the example up to date with the app? Cause if so, then there is nothing that can be done with Android and device types right now?

I would really like to make my own device type, but as it stands right now I dont even think its possible with Android.

thanks!


(Shreddin Pb) #2

Solved… I was going to delete this but I decided to leave it up in case anyone else runs into it… here is what was wrong.

My SmartThings App was out of date.
Seems simple… but the first thing I did was go to the Google Play store and check to see if my app was current. The App store was reporting that my version was the current version, it just had Open and Uninstall as the options.
I went to the about in my app and it reported it was version .9 build 399, then I see on the website here that the current version is 1.27.

I had to uninstall the app completely, then reinstall it… that got it to the current version and it no longer crashes.