Custom colors for Smart Lightning


(Dani) #1



Hello. As you can see, on the Smart Lightning app, we have only default colors presets: different whites, red, green, yellow, blue, orange, purple, pink). And that’s all. How we can add custom colors to the Smart Lightning?!

Thank you.


(Robin) #2

You can’t… look into using webCoRE instead.


(Dani) #3

From what I can see I can manage to import a piston, but not to create a custom one to replace the Smart Lightning app functionalities. Too hard for me for the moment. :sob:
Other solution?


(Robin) #4

What exactly are you doing with smartlighting and I’ll send you a piston that does it better :slight_smile:


(Dani) #5

I have a NodON button switch. With Smart Lightning app, I assigned to Button 1 to Turn ON selected lights at 30% dimmer level with color RED. I want the same functionality but with the possibility to assign any custom color to it, not only one of the presets.
That’s all. :slight_smile:

Thank you very much in advance.


(Robin) #6

Here’s an example piston which you can simply import into webCoRE:

I’ve chosen the preset ‘red’ but there are tonnes more presets compared to smart lighting.

You can also change away from presets and enter a specific hex value… so 16777216 colours to choose from.


(Dani) #7

Thank you very much! I will try!
Can I use instead of Red -> #ff0000 code form?


(Robin) #8

Yes… here’s an example that does that:


(Robin) #9

Have you watched my video on the wiki?


(Dani) #10

Just now I am installing the WebCoRE from GitHub…I’ll keep you updated.
Thank you very much for the support!


(Dani) #11

This is my status. The webCoRE is installed, but it is not appearing under SmartApps :frowning: .



(Robin) #12

What country are you in?

You’ve probably installed to the wrong shard of the IDE.

In the IDE, go to the ‘my locations’ tab and click on your home location (under the ‘name’ column.

This will probably change the URL your viewing and when you go back to ‘My SmartApps’ you’ll see webCoRE has disappeared.

Re-install it and you’ll then see it in ‘myaps’


(Robin) #13

If your in the EU shard, you won’t have GitHub anymore but it can be activated via this link:

https://graph-eu01-euwest1.api.smartthings.com/githubAuth/step1


(Robin) #14

And just to be sure… should appear in ‘my apps’:


(Dani) #15

I am in Romania. I’ve done all that you said. Now it appears on My SmartApps. But it do not appears under mobile app. See bellow:


(Robin) #16

Very odd!! Can you try force closing the mobile app and going back in?

When you published the apps, did you click:

Publish > For me


(Dani) #17

Done it!
I hardly wait to get home to test it. I didn’t know how to import the piston but I create one myself.

Question:
Is the bellow expression good ("$status changed to “ON”")?

Thank you.


(Robin) #18

Nah… should be:

Lamp 2’s switch changes to on


(Robin) #19

You import by:

  • Go to ‘add new piston’
  • Choose the orange option - ‘restore a piston using a backup code’
  • Use the code on the example I posted above.

(Dani) #20

I came home. It all works!
Thank you Robin that you have introduced me on the webCoRE world. Now I feel limitless here on the SmartThings. And I am also proud that the webCoRE for SmartThings is invented by a romanian called Adrian Caramaliu. :wink: