Color Fix? (Osram)


(Bobby Thompson) #1

So I’m trying to setup various events to trigger light colors, however it appears the list of colors to choose from don’t match the end result…

The only color that is right is Red, after that everything is shifted, and there ends up being no match for blue (blue = purple, purple = pink, pink = very pink)…

Is there any way to tweak the colors or create new ones???


( I hate Mondays) #2

How are you setting the color? Using a Smart App?


#3

Different bulb models use different color settings. Most likely you just have to select a device type handler that appropriately matches your bulb. This is one reason why you will see different smart apps for creating lighting scenes for Osram and for Hue.

You can quick browse the Smart apps for lighting and see what’s there. :sunglasses:

http://thingsthataresmart.wiki/index.php?title=How_to_Quick_Browse_the_Community-Created_SmartApps_Forum_Section


(Bobby Thompson) #4

I’m using the Smart Lights on an Osram Lightify RGB Strip…

I tried searching but may not have used the right context…


#5

SmartLights uses the Philips Hue colors. You’ll need to find a smartapp that uses the Osram colors.


(Bobby Thompson) #6

Seems easier said than done. The only thing I found suggested Rule Machine… This seemed to lead me to mention that Rule Machine no longer exists…


(Terry) #7

Yes, RM is gone but CoRE has risen to take it’s place. You can use it to change your colors.


(Bobby Thompson) #8

Looks like there will be a bit of a learning curve…

In clicking the option to create my first piston I feel very lost…


( I hate Mondays) #9

What are you trying to do, in plain English? I may be able to help you get stated. Or post in the help thread… Documentation is lagginga bit behind.


#10

Peer assistance for CORE


(Bobby Thompson) #11

I got it figured out UNFORTUNATELY there seems to be a bug in either the device or CoRE I cannot work around…

When I tell it to set the light “Green” or “Blue” (or any other color) it does so without issue…

HOWEVER it ALWAYS sets the brightness to around 60% or so upon doing it NO MATTER WHAT ELSE I DO OR DON’T DO in the rule.

If I define NO brightness in the rule it will set the color, then adjust the brightness to around 60%.

If I define ANY brightness, it will set the color and defined brightness, THEN it will set the brightness to around 60%.

I’ve deleted and re-created pistons several times.
I’ve even created pistons to define brightness on their own with no color change (which actually do set the right brightness).
I’ve created pistons to set the color and then set the brightness countless times…

In all cases any change of color = a final brightness state of ~60%…


( I hate Mondays) #12

How are you changing the color? Are you using the color list and selecting the color name from it? Colors are a mix of hue, saturation and level (brightness). To get shades of the colors, level is used and will vary mostly between 50% and 100%. Try providing the hue, saturation and level instead of picking a color (you can unselect the selected color). Hue for green should be around 150-170, saturation dictates how much color you want (0 means white, 100 means full color - green), and then the level of your choice.


(Bobby Thompson) #13

I initially tried the hue setting but after choosing a value of 50 and seeing no visible change after triggering it I went ahead & set it to 75, and again saw no visible change. It had no impact regardless of what color I manually set the light to before triggering hue…


(Mike Swanson) #14

This is a problem… I’m not a developer, but I would think that Smart Lights should recognize the device type, and then use the correct values for said type, instead of just using the values from the most popular one.

Not even sure if that’s possible? Perhaps I can create an instance of Smart Lights with the Osram values instead of Hue… @slagle - thoughts?


#15

I have mostly Phillips bulbs, but added some Osram over the weekend. What I ended up doing with the Hue Mood App was just altering the Hue and Sat values in the smart (basically creating an Osram version).

I get the Osram Bulb to the color I’m looking for, then through the developers site, I take a look at the Hue and Saturation values, then plug those in to the Color’s in the ‘personalized’ Hue Mood Smart App.


#16

Do you see actual Sat values that make sense with your OSRAM? Mine says “50” all the time, no matter what it’s set to. When I manally set values when writing a SmartApp, sometimes it works, and sometimes the saturation is way off, such that the bulb has little color.
I’m not clear if the OSRAM bulbs (or at least the A19 RGBW) are just not fully compatible, or if I’ve got some kind of defect or firmware issue with my bulb.


#17

Nope, only the hue (guess I shouldn’t have said Sat). Frankly, I’m a bigger fan of the Hue lights simply because of the API (so much easier to work with) and that the hub itself connects to SmartThings instead of each individual bulb. If the Lightify hub can connect, it does a far better job of getting the detailed colors and scenes.

I’m only using Osram for the Gardenspots and not the A19. I’ll keep the indoor lights Hue.


(Gladclef) #18

Having played with these same bulbs a bit, here is what I’ve found:

A. To achieve light or black colors, saturation should be 0.
B. The luminance of the hsl color spectrum is ignored when setting colors (see A).
C. Color is always set with hsl on these bulbs. RGB etc needs to be translated, and then points A and B must be accounted for. It’s probably not the best solution, but I subtract a linear abs(50 - luminance) from the saturation values I get post calculation.
D. The hue values (and saturation values) for these bulbs are on a 0-100 scale. If the Phillips hue bulbs are on a different scale that could account for your colors looking weird. This sounds more like what is happening, as hue starts with red at 0, then cycles through blue, green, and back to red.