Corrupt device DB?


(Megan) #1

so I have had this happen 5 times now. Support has not been helpful. I think mainly I want to see if others may have seen this. This has happened to my GE Outdoor Switches, as well as a leviton switch (twice). It has always been zwave. Anyway, out of the blue I am no longer able to control the device. It reports back if I manually change it, but I cannot change it from ST. the first 3 times it happened about the same time as a known backend update on ST. And the last 2 have been in the last 3 weeks, when I think they are doing stuff in the back end. The fix is do general exclusion and then re add them, but that is a pain because I have to redo all the routines and webcore programming again. Also on the last 2 I can say f9or sure right before they went into this odd mode, the events show the device reported a Lux of {some number}. But switches don’t have lux. I currently have 2 devices in this state, and I am dreading the process and am putting it off.

Anyone else seen this? Maybe have a fix which is not remove and readd?


(MarkTr) #2

Can you check in the IDE and see what device handler they’re using? If they’re reporting a measurement which they don’t have, maybe they somehow got flipped to a device type which lacks the switch capability.


(Megan) #3

Both use Z-Wave Switch Generic,


(Megan) #4

here is the most recent


(Nathan Curtis) #5

I’ve seen it on a number of my GE ZWave devices… (4-5?)

All were the (12xxx) non-plus variety, various device types (dimmers, switches, fan control). Some had custom DTHs some had generic. Same time frame, Support has been no help after seeing custom DTHs on some of the devices. Only way to repair so far has been exclude and re add.


(MarkTr) #6

So changing device types didn’t help? I was about to suggest switching from “Z-wave Switch Generic” to “Z-wave Switch” just to see if that brought back app control.


(Nathan Curtis) #7

Nope. That was my first thought. It’s not the DTH. The only way I was able to bring them back was exclusion. They don’t even respond to ‘replace’ correctly because the hub can still ‘see’ the device.


(Ron Talley) #8

Have you done a Z-Wave Repair? Sounds like something is going on funky with your mesh…


(Megan) #9

yeap tried that too, no dice.


#10

Model numbers?


#11

There’s nothing in the mesh, or zwave itself, that would cause a device that doesn’t have a lux meter to report an illuminance measure. That can only be a problem in the abstraction layer.


(Kianoosh Karami) #12

Let me take a look at your hub and see what I can find. Hang tight.

Kianoosh


(Megan) #13

12720: GE Z-Wave Plug-in Outdoor Smart Switch is the one, I do not recall the leviton, and i don’t feel like pulling it out of the wall to get it. Maybe this one https://www.1000bulbs.com/product/7782/LEV-VPS151LZ.html?gclid=CjwKCAjwoKDXBRAAEiwA4xnqv8Qqlpfz1qbkXNvU6GCl-1DwEUvSHrn4F7k9PEjtto0ksFARyxuXexoCZvwQAvD_BwE or same line at least.


#14

Is that the one that reported illuminance? If so, it’s definitely a backend issue, that device doesn’t have any kind of sensor.


(Megan) #15

yeap that would be one of them.


(Nathan Curtis) #16

Feel free to peek at mine too if you need more sample data Kianoosh.

If you look at the logs, the devices that were having issues in my setup most recently were my master bedroom closet light and my office ceiling fan. Both were excluded and readied Saturday before last.


Inovelli Z-wave switches suddenly unresponsive
(Kianoosh Karami) #17

Can you PM me and let me know which devices on your hub you are having issues with?


(Kianoosh Karami) #18

PM me your Hub ID and the device names or DNI of the devices you are having issues with.


(Megan) #19

Thank You Kianoosh!! you fixed it! :smiley:


(Kianoosh Karami) #20

No problem. Sorry that you had this issue. Hopefully going forward, we can provide the tools to our support to spot issues like this and fix it right away. This issue is very rare, but anyways thanks for being patient.