Core piston stopped working


(Tyler Durden) #1

Anyone else experiencing a problem with CoRE pistons tonight? I have a Ring Door Bell motion sensor that triggers the front porch light (when the piston worked). Both devices seem to be working fine but the piston isn’t.


#2

I had the same problem about 2 nights ago, on the piston I had to change the device and save so it will subscribe, then I changed back to the correct device so it subscribed to the correct device, it’s working fine now. About a few weeks ago I had another problem that it was not recognizing sunset time to trigger my porch light with ring motion, I had to change the sunset part of the piston.

Logs turned on helps a lot.


(Tyler Durden) #3

Thanks for the advice. Before posting I had tried performing a rebuild on the piston and didn’t see an improvement. However, looking at my porch light device logs this morning, it looks like the light was turned on and off throughout the night starting about an hour after I had tried the rebuild. But I don’t think the rebuild did anything because I have two pistons that interact with the porch light. One turns the light on when motion is detected, and the other turns the light off when motion stops and the “off” piston is independent of the “on” piston. Neither Pistons were triggering the light during the “outage” and I only rebuilt one of the pistons in an attempt to recover the functionality. The Ring device logs in ST definitely show motion being detected during the ‘outage’. So this looks like it may have actually been a temporary outage. I’ll keep an eye on it tonight and see if the issue returns.


#4

This is my piston, I see you use 2 pistons to do the same as mine, plus this one if you had the light turned on manually it will not turn off after the motion triggers. Maybe you have it like this but maybe not. Hope it helps.