Community Installer Not Appearing in New SmartThings App

Hi, I’ve had both SmartThings apps (classic and new) installed for a couple of years with everything working. Discovered recently that MyQ Lite was no longer authenticating and a new version was needed.

Since it had been since 2019 since CommunityInstaller and MyQLite were installed, I went to the IDE to update both. After attempting the update (sorry, have forgotten what I did here), but both stopped working so I deleted them in IDE thinking it would be easy to add them again as new.

I tried to start from scratch adding the CommunityInstaller following all of the directions there perfectly, added it as code, save, publish, enable oAuth, save, publish again, then ran the installer in the Simulator and chose the Samsungs account login method and hit install. It seemed to install, and now it appears in my list of SmartApps, and when I go to my locations, it also appears there in the list of installed applications and seems to be running.

BUT, no matter what I do, the CommunityInstaller no longer appears in the actual SmartThings (new version) app. I’ve force killed the app, and even uninstalled it and re-installed it, but no matter what I try, CommunityInstaller won’t appear in the SmartThings app to use.

What step am I missing?

If this app still works… go to the Automations section, click on the + in the upper right of the screen, choose Add Routine, click on the Disocver tab near the top of the screen and scroll down to find custom smartapps to set them up. But I have seen multiple reports from users that they can no longer get it to work.

@jkp that worked! THANK YOU! I was forgetting that step.

Both Community Installer and the latest MyQLite work perfectly now. I just had to go to routines, discover, add and configure them

CommunityInstaller → added, installed, then used it to find and install MyQLite, then went and discovered MyQLite → added, installed, configured devices, and now both garage doors are appearing again in SmartThings and opening and closing on command.

So I can confirm that latest CommunityInstaller and latest MyQLite DO work perfectly in latest SmartThings 2 app, if you remember the above steps.


I vote for renaming the app from Smartthings to just… things, the smart bit seems so 4 years ago now

1 Like

I keep getting a error when trying to install MyQ.

“We are having trouble connecting. Check your network connection and try again.”

Any clue as to why?