Changing the status of an phone presence sensor manually

You may have already tried this, but in situations like this it’s not enough to just reboot the phone: you need to leave it off for at least 10 minutes. That’s because it has to miss a cell tower check-in to force a resynch and, depending on the carrier, those aren’t that frequent.

It’s still no guarantee that things will clear up on the smartthings side, though. :disappointed_relieved:

Just turned my phone off for 20 mins. Says I’m at home and I’m at the side of the country for the past 2 days.

Frustrating. :rage: You may need to contact support.

@Pagemakers : Please forgive: Where in the app are you able to see if you/your phone is home or not?

try disabling “Get location for this iPhone” in the app, sign out of the app, reboot your iPhone, sign back in, enable “Get Location for this iPhone”. Please note this may wipe out or remove this phone’s presence from any Routines so be prepared to redo them.

Just found this. Wonder if this is the problem.

This is where…

Which presence are you specifically referring to? The “use this device’s location” that you set in the app? Or some other integration?

Lots of integrations that people used to use for presence, including IFTTT and Life360, broke this week when they turned off the smartthings hosting cloud. Some will be coming back, some won’t, up to each service if they choose to rewrite the integration for the new architecture. But none of that should affect just the basic “ use this devices location” functionality.

Here are the details on the cloud shutting down:

Why Did My Integration/SmartApp Stop Working in January 2023?

There isn’t any place that displays basic phone presence in the official feature. Which is weird, because it used to be there back in 2015. But it got dropped in one of the many app updates since then, and never came back.

What people do is create a routine based on “member location” that turns on a virtual device if they want to get a presence tile.

1 Like

Ok, that tile is not part of the official presence feature, which is why turning your phone on and off didn’t make any difference. It’s either a virtual device that you created or it’s coming from a third-party integration or it’s a combination of the two.

Can you show us the details from that tile?

And you should definitely take a look at this

Why Did My Integration/SmartApp Stop Working in January 2023?

1 Like

The old MUCH MUCH better version of SmartThings allowed a phone for presence. Now it has to be done with simulated presence sensors.

In the old version it was 100% rock solid. Now it’s down in the 40-50%. However it’s never failed for this long - about a week on both iPhones.

1 Like

This is the 3rd party I’m using. It’s worked for years until a week or so ago.

What are you using to turn on the virtual presence sensor?

And…is this a groovy virtual device you created through the IDE? If so, it’s going away pretty soon, too. And it may go away for different accounts at different times.

Or is it a new edge driver virtual presence sensor created recently? Like the following:

[ST Edge] vEdge Creator: a virtual device generator for end users

If it’s an old one, you might as well go ahead and replace it now with the edge driver, you’ll need to do it eventually.

1 Like

Ok, ALL custom groovy SmartApps were shut down about a week ago. Because the cloud where they ran was shut down.

Again, details in the community FAQ:

Why Did My Integration/SmartApp Stop Working in January 2023?

1 Like

Thank you everybody. My holiday project!


Weird indeed, considering the importance of this status. “Carry coal to Newcastle” = using a routine and a virtual switch to determine the status.

1 Like

I created a virtual presence sensor, 2 routines based on location turn it on/off, although i use my Samsung location and bixby routines to turn it on/off.
Easy enough to go into smartthings and the presence sensors have a on/off button.

Hi. I’m flowing your instructions to create an Edge virtual connector.

When it scans to find a new device it doesn’t find anything. Stupid question…. I’m not at home so is this the reason it can’t find the device? Will I have to wait until I’m home for this to work?

Not being home shouldn’t matter.

The best thing is to ask your question in the author thread for that edge driver: someone there should be able to help you get the device set up.

1 Like

Managed to install the vEdge presence devices.

How do I control it using the presence on my iPhone?