CentraLite Keypads

Has anyone had sight of one of these, apparently Yale have a version of it, for me it is the ideal solution for home acceptance, battery operated, shows state and simple rfid to activate deactivate.


Tried that no difference, I just have to put my hand in front of the two holes in the front for a split second and it lights, but I wanted it to work from a distance.

Looks promising, but since it doesn’t mention if it will work on USA frequencies or UK frequencies and someone would need to create a device type, it is another promising unknown.

Have you ha any luck figuring this out yet? I am having the same EXACT issue. I have tried everything!! I know everything is being done correctly, I have tried lock code, 3400 x etc etc. I even returned the keypad to lowes and bought another one and its doin the SAME EXACT thing. The only thing that I can think of is that somehow it isn’t pairing 100% because that damn light just blinks and blinks even though everything else software wise looks good. I have LITERALLY tried everything in this forum and still no luck. It seems that there are quite a few of us having this same exact issue now.

@mitchp do you have the documentation for the Centralite 3400 keypad? There were a couple links here but expired or no longer exist


Just so you all know, keypads are now officially supported by @ethayer’s lock code manager. He merged in my code this morning. Check this link for the latest:


I returned 2 Lowes keypads (neither would work for me) and bought the Xfinity 3400 version with hopes that I could get this on to pair completely, still no luck. It does the same exact thing and blinks green light. It installs correctly as Keypad, shows connected, shows temp Everything looks right. It even shows correct status on the keypad itself when I set the “armed” routine through SHM app but the keypad itself doesn’t set the alarm or disarm it. Same issue as the video showed in a previous post by Jparchem. I REALLY need a working keypad. I have tried uninstalling and reinstalling 100 times. Tried pushing button on back etc. This shuts the light off but does not fix the issue. I am completely out of ideas at this point. It has to be something unique to my hub or setup. If anyone has any other ideas that haven’t been mentioned in this thread already, please let me know.

what smartapp did you use?

Oh Sorry I have tried every version of Lock code manager. Also tried the 3400-x smart app. Uninstalled all fully before trying the other ones.

android or Iphone or windows?

Using Android. Thanks for the help!!

try these:
SmartApp: https://raw.githubusercontent.com/bridaus/SmartThingsPublic/patch-2/smartapps/mitchpond/3400-x-keypad-manager.src/3400-x-keypad-manager.groovy

Device Type: https://raw.githubusercontent.com/bridaus/SmartThingsPublic/patch-1/devicetypes/mitchpond/centralite-keypad.src/centralite-keypad.groovy

its posted here: CentraLite Keypads
made by @bridaus

I’m using it months with same configuration, android+iris keypad.

Ok So I made sure all other device handlers and apps were gone, installed these. It did the same thing which is, It found the keypad with no issue during setup process and let me configure the new device. Everything installed correctly but the green light is still blinking. I configured the smart app after installing the device and set the routines within the smart app. it shows centralight keypad in the IDE and has all info populated such as zigbee id and device id and status says active. but again it will not send arm or disarm from the keypad…and the light is still blinking.

take battery out of keypad and let it sit for 15 min.
Remove active smartapp and device from cellphone. Keep handler and smartapp in IDE.
put battery back in.
pair keypad
make sure nothing is obstructing keypad proximity sensor.
it will go to sleep in couple minutes
set smartapp in cellphone
then you should be set

Thanks again for the suggestions. I did this again exactly as you outlined. I have tried this step many times before but did it again and its doing the same thing which is, the green light is still blinking and has been for about 15 mins now. Last time I left it overnight it finally must have “timed out” but it isn’t “going to sleep”. From reading all these pages, there are at least 3 other people having this same issue and it doesn’t appear any of them have resolved it yet either. I have tried 6inches away, 5 ft away, 20 ft away…none of it has worked, the blinking just continues.

OK I had a problem setting up my IRIS and I did it twice as I has screwed it up when I switched to V2 hub. I found that my WiFi channel 6 was overpowering the Zigbee channel 15 that my V2 hub was using. I changed my WiFi channel to 11 and then my unit paired from 15 feet away. All I did was remove one battery and held in the tamper switch until lights on front came on waited 2 seconds or less ands released tamper and it paired.

Thanks for the suggestion. I had high hopes that this may work for me also and have tried changing channel on wifi router from 1 to 6 and then tried 11. Upon each change I completely removed keypad and repaired as new. None of the changes worked so I then completely turned off wifi just in case and tried fresh repair. Still no luck. I read the manual that came with keypad and it states “may have to manually pair by pressing tab on back if light is blinking so that device pairs”. “Light will turn solid when paired”. Mine never fully pairs and just blinks. I think in the next few days I will start removing devices one by one and try pairing keypad again each time and see if one of my cameras or something is causing interference.

I did one other thing I have a V2 hub so I moved the hub with battery power far away from WiFi and other devices and it paired first time.

The keypad is successfully added to SmartThings each time though? It shows up as “Centralite Keypad”, not a “Thing”?

Also, have you checked your live log to see if the system is getting any information when the keypad is used (for the Xfinity version you need to hit a mode before putting in a 4-digit PIN).

Correct it is successfully added as Centralite Keypad not “thing”. Live Log shows NOTHING when entering Mode then 4 digit pin on keypad. Live log for the device does show the following IF I set status through app to Arm Stay:

58573f3a-605c-4b46-8640-06fed98532b4 ‎7‎:‎42‎:‎24‎ ‎PM: debug Keypad manager caught alarm status change: stay

d381f0a3-fb89-45e0-b3cc-a2e0b6880ee4 ‎7‎:‎42‎:‎25‎ ‎PM: trace Method: refresh(): [st rattr 0xFDBC 1 1 0x20, delay 100, st rattr 0xFDBC 1 0x402 0, delay 100, raw 0x501 {09 01 04 0100}, send 0xFDBC 1 1, delay 100]

d381f0a3-fb89-45e0-b3cc-a2e0b6880ee4 ‎7‎:‎42‎:‎25‎ ‎PM: trace Method: sendStatusToDevice(): [raw 0x501 {09 01 04 0100}, send 0xFDBC 1 1, delay 100]

d381f0a3-fb89-45e0-b3cc-a2e0b6880ee4 ‎7‎:‎42‎:‎25‎ ‎PM: trace Arm mode: armedStay

d381f0a3-fb89-45e0-b3cc-a2e0b6880ee4 ‎7‎:‎42‎:‎25‎ ‎PM: debug Sending status to device…