Can't Remove Home Assistant smartapp

@Javier_Dst Please open an issue in the repo for the utility. Please include the output from when you run the utility. I’ll be happy to work with you there to figure out a solution.

Done! Thanks!

I’m using Smarthings v2 an v3 and it is exactly the same.

Hello. I removed Smartthings on HA v 0.89 and now I’m on 0.90.2 and try to install Smartthings again and have got this exact problem.
I run HA on Hassio on a Raspberry Pi 3. When I log in to terminal and try to install the removal utility it only runs Python 2,7 and the aiohttp fails to install. Can I install like Raspbian on another SD-card and run the Removal utility on that without having Home Assistant installed? Can I get this removal utility to run on HassIO? Can I manually write some commands and remove the orphaned apps? I’m new to Linux but experienced in computers in general and can’t fix this. PLEASE guide me.

I got it! Installed Python on my windows computer. Went into command prompt and into the python scripts folder. Executed “pip install hass_smartthings_remove” Package installed successfully. I then used hass_smartthings_remove most_recent_smartthings_token but got 401 Unauthorized. I then opened Chrome, logged in to and executed the hass_smartthings_remove again and it worked! I could then run the integration again and it worked.

Awesome, the utility fixed everything after upgrading to 0.90.

Getting this error message
No matching distribution found for aiohttp==3.5.4

Ubuntu 18.04.

What to do?

EDIT: Ran it on Windows. Works great.

Running the utility on Windows and getting the No matching distribution for aiohttp==3.5.4. Any thoughts?

Edit: JK, had an older version of python as default, using the latest resolved.

never mind I solved it… : )

Hi Andrewsayre and everybody.
After unsuccesfully trying to integrate my 2 samsung winfree 2018 ACs into HA (it looks like they have no opened ports) I chose to try the smarthings integration.
It worked at first try and both TVs and ACs were shown.
But there’a a quite big problem… the main climate entity for one of the ACs is not created.
They are identical, and one is working flawlessy.
I tried to remove integration remove smartapp, clean smartapp, generate new token… I don’t know what else I can try. i need some help to find the problem, it’s preventing me to manage the unit in the bedroom :frowning:
Any advice?

On Smarthings website everything looks ok, so I think the problem must be in the integration or somewhere on my hassio…

Uhm… i just noticed something strange on the device on smartthings website.
It does not detect room temperature, so maybe it’s not communicating correctly with smartthings cloud and because of this also with hassio integration.
Strange, because on smartthings app it’s working…

Removing and re-adding the unit in smartthings app did the trick!
Strange problem, onlt smartthings classic was reporting the same wrong temperature, the “new” smartthings was working normally.
If this happens to someone else… just delete and re-add the device in smartthings v2 app!

Key bit of advice there! I was struggling to get the SmartApp removed and realised even though I saved the API Key I had deleted it from my SmartThings account - created a new one and presto!

Hello, is there a way to get the same results from that of the removal tool when using on a RPi? I made the same mistake, now have 2 stubborn instances of HA smartapps in ST. Technically challenged and not even close to the geekery level on the forum, help please!

Hi Andre
I know this is an old thread, but my smarthings integration is not working and can’t find a solution
Basically I had to rebuild my linux server and restored from a snapshot
The first thing I noticed was multiple devices ( smartthings) that were failing
I then decided to delete the smartthings integration and re-enroll the app, but to no avail
I have even rolled back and tried to delete the smartapp on the phone, but again I can’t find a way
I’ve seen the python scripts you created, but can’t figure out how to use them
Can you provide some instructions?
Do I need to install the script on the host ( linux) or the hassio docker

Thanks, you help is greatly appreciated

It’s a pypi package that you can run anywhere you have python3 installed. Installing and running the utility is documented here:

Just make sure you run it with python3.

1 Like

Thanks Andrew

I will try a bit later



Works like a treat!

Thank you very very much!


Thanks for the script @andrewsayre. I am trying to run it locally as I have constant “unregistered webhook” warnings in home assistant.

The error I’m getting in terminal: “SSL handshake failed on verifying the certificate”

I am using the only token I have created and have verified it has not been deleted.

I had the ST integration set up on a hassio instance that died. I ended starting from scratch and am now receiving these unregistered webhook warnings. Any tips on what I might try next? I am unable to directly delete the HA smart app from the ST app.

aiohttp.client_exceptions.ClientConnectorCertificateError: Cannot connect to host ssl:True [SSLCertVerificationError: (1, '[SSL:
CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer 
certificate (_ssl.c:1056)')]

@andrewsayre Hi, i’m an Hassio user and i’ve tried to delete home assistant app in smartthings classic app without lucky.

I’ve tried also your script but i’ve an error during the process (image attached).
I would also delete smartthings folder but i don’t know where this folder is on Hassio.
Could you help me, please?
Thank you so much,


© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.