Can't add TP-Link Kasa devices from different locations

I have a TP-Link Kasa account that I use to access devices in two locations. Previously, with the Kasa account linked to SmartThings, all devices would appear at the two locations that were set up in SmartThings. For example, the den lights are at Home and the porch lights are at Bungalow, but in SmartThings, both of those lights would show up as devices in both locations. If I deleted a device from the wrong location, it would reappear eventually.
Frustrated with the duplicate entries, I unlinked the Kasa account from ST and then re-added it to start fresh. Now, ST has decided that the Kasa account only exists for my Home location, and I can’t assign the porch lights to the Bungalow. If I go to Bungalow and go through Add Device, scroll to TP-Link | Kasa Smart, I’m told this partner service is already connected because my account has been linked. Great. So I tap View linked service. It shows the den lights (assigned to Home - Family room) and porch lights (No room assigned). Tap the porch lights, it brings up the controls, showing its location as Home. Tap Edit, and Location is Home, greyed out. So I can’t reassign it to the Bungalow from here. Going through the rooms in Home (“No room assigned”) takes me to the same place, control of the light but no way to assign it to the other location.
So it seems that ST assigned the entire TP-Link account to one location this time. Any ideas how to get ST to let me assign devices to both locations from one Kasa account? It’s insane to me that ST allows multiple locations and yet can’t do this simple thing.

1 Like

There are 2 possible solutions.

  1. Set up 2 separate Kasa accounts, 1 for each location, and integrate each location with the proper ST location. This will also fix your duplicates problem.

  2. If you have a ST hub the better option is to use the Kasa Edge driver for your Kasa devices. Then there is no need to link your Kasa and ST accounts. If you leave the Kasa and ST accounts linked you will get duplicates.

1 Like

I have this same exact issue with lifx and smartthings. No fix. Can only add one lifx link to either home or work. But not both. Originally worked with both until i unlinked. Now im screwed.

I have the same problem. I have purchased products (Mysa, Enbrighten, (SmartLife), TP Link/Kasa, etc, and the linked services were added to both locations. Yes in many cases it did add devices to BOTH locations; however, I was at least able to group the devices at the “wrong location” into a group. However, because it now only adds ALL devices to ONE location, you cannot include those devices into ROUTINES if they are in the wrong location!!! I did try to do the TP driver above, but not sure what I am suppose to do next or what will work for my devices from other providers. Would appreciate any help as I have just purchased many of these devices to replace obsolete ones (i.e, wemo)

My solution for Tuya/Smart Life is to use the Tuya App for 1 location and the Smart Life app for the 2nd location. Then integrate the right app with the corresponding ST location.

Another option for any app would be to have 2 accounts, 1 for each location. Then integrate the right account with the corresponding ST location.

There are also two apps for my tp-link devices. Tp-link Kasa and Tapo. I tried adding the TP-link Kasa to one location and Tapo to the other one. Doesn’t work! Not sure if it is because both use the same login. I also tried setting up different accounts for each location. Although that may have worked at one time that’s not working now either.

Originally I had four linked accounts that appeared in both location. TP Link/Kasa, Smart Life, Mysa and IFTTT. Both the TP-link Kasa and Smart Life caused duplicate entries because it downloaded all devices from all locations into each location. That was at least a workable solution because I grouped devices at the wrong location into a specific group. Then the new Tapo app came out which also supports tp-link devices so I tried to add it to one of my locations. When I did, it showed “no devices were added” . So I deleted the TP Kasa app aassociated to that location. Still no devices would add to the Topo linked service. So now I lost access in to my tp-link devices devices at that location in SmartThings. I can still access them through the wrong location but cannot write routines for the devices Associated to the wrong location. Clearly I don’t want to test deleting any other of the linked services that are working like smart life and Mysa

I tried setting up and associating my TP-link devices at each location to a different account in the linked services. But when I tred to re-link TP Kasa service to the second location with the new account login it would not let me re-add the linked service to the new location. Recieived a message the linked service ialready existed in my SmartThings account. That was a lot of work to do and a lot of wasted times spent because there have been changes that don’t seem to support multiple locations anymore.

I spent a lot of time and money getting new devices that would work primarily with Smartthings to keep things as simple as possible. In the interim I’m building my routines in Alexa however it doesn’t have quite the same functionality that I used to use in Smartthings… This new partnership design doesn’t seem to be working too well.

While you can add your Kasa devices to the Tapo app, the Tapo integration does NOT bring your Kasa devices into SmartThings.

After contacting Samsung Support, I received a response they were working on the issue. There was an app update on 10/23. I went to the app and was able to re-add the TP Link Kasa Service back to my second location. While it still duplicates all the TP Link devices at both locations, at least the ones I added at 2nd home now appear in that location again so I can now include in Routines!

While it is a bit inconvenient to have items duplicated in the app, I created a “room” labled "Error-Devices at location XX (name of wrong location). I also prefaced the name of all the devicdes in that room with “E-XXXX” (original device name)… I appreciate the effort to address the issue promptly

Thanks for this update. I was able to easily add a second instance of TP-Link Kasa and get all devices at both locations, the original stupid problem. I like your idea for a workaround, so I added a room at each location called False and moved the errant device there.
It’s nice that they’re working on it, but this will do for now.