Can't add guest codes

Migrated to new app. I can lock and unlock my lock but when I try to add guest codes it says lock is not connected.

If you are using smart lock guest access in the new app —> remove the app and reinstall. Then see if you can manage codes.

1 Like

Alternatively try Lock User Management, it’s much hardier and has more features than the guest lock app:

Bandaid to the issue- set them up using the classic app. They will sync over to the new app

Thanks but did not work. Keeps saying no locks online.

I had been using the classic and the lock is listed in new app. I can see history and can lock And unlock…just cant add codes

Just following up since I may not have been clear… you removed/reinstalled the smart lock guest access smartapp withIn the ST app and didn’t remove/reinstall the SmartThings app?

Looks great but all I need to do is add a guest now and again. Seems silly to have to buy an add on to do what the app is supposed to do. I make apps myself and if my apps worked like these apps from multi million $ companies I would be out of business.

I uninstalled smart things and reinstalled smart things and the guest add on

Go to the menu (3 bars in the upper left of the screen) open Smartapps, then click on the 3 dots in the user right of the screen and choose delete, then choose the smart lock guest access smartapp.

It worked. You are the best. Thanks so much!