Blue Iris motion detection to activate smart app

Still working for me.

Thanks Jimmy - @slagle Do access tokens for newly installed smartapps still work?

Sorted with [Solved] (in a round-about way), Turn on/off outlet or switch from Blue Iris in the end.

cheers
matt

Any ideas on why copy will not work on the URL screen in the app? I have tried on android 7.1.1 and ios 10.2

Hi Shaun - I could not get it to copy in iOS - ended up taking a screen shot and copying from there initially - however I have found that [Solved] (in a round-about way), Turn on/off outlet or switch from Blue Iris works perfectly and is reliable and quick (less than 2 seconds detection delay from BI to ST).

Cheers
Matt

Kubicki’s Smart App do not work for me I got this “Error - bad state. Unable to Complete page configuration”

I’m sorry to ask but this smartapps just runs the http request right? You still need to run a routine or core to envoke a switch or sensor, right?

I can generate the link and test it succesfully from browser, seems like smartapp its working, the issue im stuck its that Blue iris seems to not send the alert for the webservice, everytime i try to test it, i got error 12007, and no idea how to fix it, any idea?

hi shaun not sure if you got it working but I had the same problem i could not coping it with my IOS So you can take a screen shot before it changes or you can just create it then go back in the app and click next and it shows you the code and you have all the time to type it out. I know i ran into problems at first because i didn’t realize how fast it changes.

Hi BBoy as far as i know i had to use core after and use the http motion as a sensor in the core app then you can tell the core to turn on the light or any other thing you want it to acctivate. hope that helps you out

I have this setup correctly with the SmartApp and simulated motion sensor. I know this because I can post the link in the web browser to successfully trigger the motion sensor. I can even invoke it when using the “Test” button in Blue Iris. My problem comes in where Blue Iris does not appear to be triggering the web alert automatically even though it triggers the “send push notification” to my phone.

I have adjusted the motion sensitivity settings, reduced timeout timers, and everything else I can think of. As a means of troubleshooting I setup a mobile app alert every time it triggers in blue iris, as well as, a push notification within ST if the simulated motion triggers. Again, I can see both push notifications come in when I use the “test” button and post the link into a browser but I only get the Blue Iris push notification when allowing the system to operate, no motion.

Any ideas? I’m getting the feeling I need to reach out to Blue Iris on this one.

Same issue here, and your suggestion worked - thank you!

I contacted Blue Iris and they helped me solve this by updating the services to your own Windows login for the service instead of LocalService. I can now push the HTTP request.

All, I think you may be interested in my BI Fusion app now that it includes motion sensing too. It creates a Server Device and Camera Devices (for each of your cameras), and enables profile syncing to SmartThings (and on-demand switching). It also has Blue Iris health monitoring, camera triggering, and obviously now motion sensing.

Right now it uses OAuth just like this thread’s app uses, but I’ve improved it a bit by letting you “view only” the URLs in settings, so that you can go back to make whatever changes you want in settings without having to redo all the tokens, as well as go back and view the tokens for new cameras without having to redo everything.

It also uses the same token for all the cameras, so you only have to type it all out once, then you can just copy and paste. Plus, it’s a parent/child setup, so you don’t have to have a billion smartapps. Just the one smartapp, and it’ll auto create your camera devices.

I hope you like it, I think it’ll be a really nice upgrade for you!

I have been reading thru the forum to use a Reolink camera to trigger motion. I was just ready to download Blue Iris and realized it is only a windows program. I run a MackBook Pro. Anyone know of Mac-compatible software that will function like Blue Iris…? I also looked at iSpyConnect by same issue, windows only.

Thanks in advance…!

Sighthound is available for Mac

I installed Blue Iris Fusion about a month ago. At that time I was using the latest version of Blue Iris 4 (BI.) I was able to get the basic functional working except for the motion detection. I quit tinkering with Blue Iris Fusion until recently due to other demands on my time. Then I upgraded to the latest version of Blue Iris 5 which was a major upgrade. I subsequently spent several hours trying to configure the motion detection. I still have not been able to make the motion detection in Blue Iris Fusion to work. I checked my keys carefully, etc. Has anyone been able to use the motion detection in Blue Iris Fusion successfully. Since the project seems somewhat stale I was curious if it was my install and config or that the motion detection does not work. Thanks.

Yup! Motion continues to work without issue for me, and a lot of other folks. The directions for setup have moved to github because these forums only allow so many edits to a post, and BI Fusion continues to be updated as needed/requested. I’ve helped several folks navigate their problems, but usually do it via PMs so the forum is easier to read for others. Feel free to PM me your debug logs and we’ll get things rolling for you. Does the “record” button on the camera device pages work (clicking in in Smartthings should cause the camera to start recording in BLue Iris)? It’s a good way to make sure the basic settings are correct first.

We can get it working for you!