Blue Iris motion detection to activate smart app

I’m getting the same:
{“error”:true,“type”:“java.lang.IllegalArgumentException”,“message”:“An unexpected error occurred.”}

I’ve uninstalled and reinstalled the “HTTP Motion Endpoint” app. I’m copying the activate/deactivate addresses into an email and sending them to myself to open up on my computer…

any ideas?

@Kristopher you are the MAN! I was gearing up to try and figure out how to do exactly this thing and have been searching for this capability for weeks before stumbling on this thread. I created a Simulated Motion Sensor, created the app, enabled oAuth, and everything worked exactly as I wanted. I’m using Sighthound which currently doesn’t support motion inactive, so the addition of the 15 second timer is brilliant as well. It does every last thing I needed, no hacking necessary.

You’ve saved me a bunch of time dude, thank you so much.

1 Like

Hi Everybody

I’ve created a ST Simulated Motion Sensor device, as well as successfully installed the SmartApp as well as configured it. OAuth has been enabled as well, and via the SmartApp the required Activate / Deactivate URL’s generated. Said URL’s were then added to Blue Iris in the appropriate spots, using the formatting requirements as mentioned in earlier posts…

I am getting this error message on Blue Iris when testing:

I see this in the IDE Live Log:

Just to confirm my OAuth SmartApp settings:

Any suggestions folks?

Thanks in advance

I installed and received the same error. I then clicked on the “OK” button on the Blue Iris screen and ran the test again and the error went away.

Nope, retried again, and the same issue. Actually redid the entire setup.


Hi Kristopher,

Can you point me to something that explains what I need to do with your code that turns devices on/off?

We have installed the Android version of the Smartthings App, but not sure what to do with this code, to get it working with Blue Iris.

Thanks in advance.

I’ve gotten most of this set up, but I cannot get it to work to turn on/off a ST switch or even trigger the Motion Sensor switch.

Even trying the commands from a browser, I get errors.
"{“error”:true,“type”:“AccessDenied”,“message”:“This request is not authorized by the specified access token”}"

Has anyone gotten this working that can share some info with me?

I’ve got one switch, Blue Iris software, trying to trigger the switch to turn on a light when a motion alert is triggered in Blue Iris.

Thanks for any help I can get!

Hi, I would really love to get this to work.
When Blue Iris triggers a record I would like a notification in Smartthings on my mobile.

I have created a Simulated Motion Sensor App in the IDE.
I have created a new SmartApps where I copied everything from Kristophers post Oct '15. I enabled OAuth in App Settings.
Saved, Published for me.

Added the SmartApp on my mobile, took a screenshot off the active/inactive urls that is shown - and then tried to invoke the urls, eg. in Powershell with Invoke-WebRequest {url} but I keep getting a 403 Forbidden.
If I change a letter in the access-token I get a 403 Unauthorized, so it seems I am so close :slight_smile:

I’d like to get this working as well. Anyone have any luck with it lately?

OAuth is true and enabled. I get, “Error requesting page: 403” from Blue Iris.

Throwing the link in chrome results in: {“error”:true,“type”:“AccessDenied”,“message”:“This request is not authorized by the specified access token”}

I’ve tried multiple times without any luck.

Just got mine working. Issue fo me was that the web address is less generic. I had to adjust to then it works like a champ. Thought I would share in case some other users were getting the 403 thing.


Yes thank you so very much

That did the trick. Was able to add 2 cameras with no problems. The 3rd gave me some trouble until I removed the associated smartapp and deleted the simulated motion sensor and recreated it and re-added a new smartapp to it. Thanks!

Will this Blue Iris setup work as a motion sensor even if the current BI profile is set to NOT record for that camera?

Yes it does. I was using before I bought motion sensors.

1 Like

This doesn’t seem to be the case for me. The only camera that is updating it’s virtual motion sensor is the one that is set to record on motion 24/7. The other two in my kids rooms only record on motion when we are away and the virtual motion sensor does not update fo them when we are home and cause motion. Is there a special setting in BI for “detect motion, but don’t record”?

Unless someone could get back to you otherwise I won’t be able to check this until next week when I am there. Possible new update on blue Iris. I was using version 3.0 and recently updated to 4.0.

I think I figured it out. I needed to turn on motion under the trigger tab and un-check all the recording options under the video tab.

Has anybody taken the app from @Kristopher and enabled it for Parent/Child? It’s working great, just would be nice to keep my SmartApp list a little cleaner :sunglasses:

1 Like

Thanks for this Kristopher and all those this helpful hints above.

I wanted to document the steps that got this working for me all in one post, as it took a bunch of mistakes to get working.

  1. Create the SmartApp in IDE and enable oauth
  2. Create a Simulated Motion Sensor for each camera
  3. When setting up the SmartApp via Marketplace>My Apps, if you don’t get the URL code copied quickly, it will change and become invalid. Same with if you later reopen the SmartApp instance linked to the simulated sensor. For that reason, quickly copy the URL into a text editor and click ‘Done’. In iOS you can’t copy/paste the text, which is lame. A screenshot might be helpful.
  4. In Blue Iris, right click the camera>Camera Properties>Alerts>Request from a web service>Configure. Change “http:” to “https:” Now enter the URL from the Smart App (minus the https://, of course). But not so fast! Depending on where you live, you will need to change the URL to match how it looks in your IDE page. For me in the USA, that means changing “” to “” If you don’t do this you will get a 403 error.
  5. If you enter anything in the POST Text field you will get a 405 error. Leave it blank.
  6. Click Test. If it worked, you should get “Received 0 bytes”
  7. Don’t go testing your camera yet or you will be disappointed. You must “OK” out of all the dialogs for it to take affect (trust me I wasted about 30 minutes before I closed the last dialog and then it worked).

I hope that saves some of you trouble!


Is this still working for anyone?

Using Postman to test all I get back is:

“error”: “unauthorized”,
“error_description”: “Full authentication is required to access this resource”

OAuth is enabled and instructions followed.

I’ve changed the URL in the smartapp as I’m UK based.
Any help welcome!!