Authorize IFTTT (service) to access Smartthings - Device "Button" missing?

Authorizing access to Smartthings is missing the option to have “buttons” run things for you. I was trying to set up something in IFTTT that required ST to have a Virtual Button. So i created a Virtual button and when I tried to give IFTTT access to it, Buttons weren’t even an option - switches yes - but not buttons (momentary buttons). Seems lacking. How about we add that?

Did you authorize the button? I use virtual momentary buttons with IFTTT and SmartThings.

2 Likes

Buttons are a type of switch and will be listed in the switches category of the IFTTT smart app where you authorize which devices IFTTT has access to.

For example, I have several harmony buttons which are momentary switches. You can tell from the icons on the things list in the screenshot:

When I go into the IFT TT smart app, you can see that they are listed in the switches category.

You authorize them like any other switch, and then they will be available for use in IFT TT recipes.

3 Likes

Your posts are always so much better than mine :smiley:

1 Like

Don’t feel bad, JD’s posts are always so much better than everyone’s! :smile:

2 Likes

Definitely not true. :sunglasses: It’s just a side effect of using voice software; it’s easier to speak in paragraphs.

I knew it was a kind of switch. I added a virtual momentary button, but when I went to IFTTT.com (desktop browser) and “reconnected channel”, my button wasn’t listed under switches. Perhaps because it was a virtual button?

Are you using a custom device handler or the standard virtual momentary? If it’s custom, maybe it’s an issue with the device handler

You have to authorize each device you want IFTTT to have access to from the SmartThings side before you will see it in your IFTTT.com channel.

  1. open the SmartThings mobile app
  2. click on the Rooms icon at the bottom of the screen (4 little squares icon)
  3. choose SmartApps
  4. scroll down the list until you see the
    Ifttt smartapp

  1. open the IFTTT smart app

  2. choose Switches

  3. check your new virtual button, as I did in my harmony button example above

  4. continue through the smartapp to finish authorizing your devices

  5. now you can go to Ifttt.com and you should see the button in your SmartThings channel

1 Like

I tried it with both for that very reason. This is now just food for thought, because I found a work around that works well. I used a “The Big Turn On” and then “Smart lighting” - Power management option of 1 minute to turn off. it was so I could get my Ring Doorbell to tell my Sonos to have the dogs bark.

Yeah, I know about this, problem is, the button just wasn’t there. ST has been acting funky as of late, so maybe when all the bugs get worked out, I’ll try it again for shits and giggles. But for now I figured out a work around. Thanks for the help JD!

Glad you found something that worked! As Kevin said, maybe it was the specific device handler (I use momentary button tile, which is a virtual device). Or maybe, as you say, just ST flakiness, who knows?

1 Like

You actually can do it too via IFTTT if you reauthorize channel. When you click that you go through the OAUTH authorization page and can select them. It’s quicker to do it through the ST app, but it’s still doable directly through IFTTT like @jnhearne did

1 Like

Can someone check their recipes log on IFTTT side? I am seeing multiple (3 or even 4) recipes fired consecutively for same teigger. I know it’s related to ST, because I have other channels and not seeing the same behavior. Anyone else seening the same?

hmmm… I’ve kind of stopped IFTTT from operating anything through ST and only use IFTTT to provide backup commands (for instance IFTTT -> Wemo(directly)) for when ST fails. Until ST can figure out their stability problems, I’d see if you can come up with an alternate method. It sucks, yes. But banging your head against the wall sucks more.

But I did check my IFTTT logs and I’m not getting repeat fires. Normally I’ve seen in the past that this is what IFTTT does before the recipe self-turns-off.