App Endpoint Access problem

Im using Allow Endpoint to Control my switches and lock, but my lock is not showing up after i have authorized it.

If you don’t mind me asking, what are you trying to use the endpoints for?

1 Like

Im using them to open garage door, front door and to lock and unlock apartment door from my iPhone and Pebble smartwatch. Everything was working perfectly but changes my lock so had to create a new URL for my new lock, but its not showing up after authorized.

@kimmi That is EPIC. What would i need to add those widgets?

First you have to have jailbroken iPhone.
Intall from Cydia:
Activate Command

In Activator Command you set up shortcuts from the generated URL from the switches you have autorized in Endpoint Acsess. In front of the URL put: curl -k -s
Eks: curl -k -s

Then in QuickActivator you set up a Quick Launch, add new shortcut and chose your shortcut from Activator Command.

In Pebble i just use HTTP request with the URL from Endpoint Acsess without curl -k -s in front of it.

(Double check that the URL is HTTPS and not HTTP)

Let me know if you have problem setting it up :grinning:

1 Like

You should look at my project: ActiON Dashboard. Works great as a native mobile app, no jailbreaking necessary.


Or just switch to Android where you can do it without Jailbreaking/Rooting! :hankey:

Have you tried completely uninstalling the supporting Endpoint SmartApp and then reauthorizing?


Can you explain how i do that?

  1. Log in to the IDE.
  2. Navigate to My Locations:
  3. Select SmartApps:
  4. Click the Edit link at the top of the screen:
  5. Select Uninstall for the desired SmartApp:

PS. Normally you can just do this through the SmartThings mobile app as well, but if I remember correctly the End Point example is a weird one that doesn’t show up in the phone UI.

I tried to delete and add again, but my lock is till not showing after i have checked the box for my lock.

Update: when only selecting my lock for authorizing i get this message, so the problem seems to be that its not registering my selection of the lock. I have tried a different web browser but no luck.

were you able to get this to work? I’m having the same problem.

@chrisO are you having the problem that the auth page tells you to select at least one device to authorize, even though you have?

If that’s the case, it may be that your SmartApp hasn’t been published. If that’s the case, open the SmartApp in the IDE, and click the Publish button above the code area.

Hi Jim, thanks for replying, I was doing it from this link

how do I publish it from my own?

my solution for this was to remove the lock (from my things in ST app) and add it again.