Android Update 1.6.8 Release Notes (11/12/2014)


#1

SmartThings version 1.6.8 includes several bug fixes and overall performance improvements for enhanced stability. Noteworthy changes include the additional of in-app support chat and quick mode switching via the left menu. Below is a more comprehensive list of the changes.

Bugs

  • Fixed: Installation issue with the Jawbone Sleepy Time SmartApp.
  • Updated: Friendlier error when users create an account with an email address that has already been taken
  • Updated: Change password confirmation message
  • Fixed: In-App video tutorial audio continues to play after navigating away from content
  • Fixed: Tapping on the device back button twice causes the app to crash on select devices

Improvements

  • Mobile presence device is created and added to Home & Family when an invited user creates their account

New Feature

  • In-app support chat
  • Quick mode switching in the left menu

(DLee) #2

Awesome you found time to work on this but it still won’t work for me.

Tried clearing App cache, uninstalling existing button controller workaround. Installed Jawbone Sleepy Time from ST Labs apps. No luck, does not show up in Jawbone devices SmartApps list. Tried installing from +SmartSetup new thing, fitness trackers, Top Alerts and actions. Setup, click Done. No error, but no SmartApp showing on the device. Tested going into and out of Jawbone Up24 Sleep Mode, but no action triggered. Not installing in any way shape or form that I can see.

Each time I fail to install the App, logs only show under the Sleepy Time header:
When I select one Hello home action for Sleep Mode, logs show:
trace [ever single hello home action I have setup is displayed here]
Then select second action for Exit Sleep mode, and THEN done, logs show:
trace Deleting all scheduled jobs for InstalledSmartApp:

That’s it, but no actual app attached to my Jawbone device.


(Justin Wurth) #3

I don’t know if this is coincidence but my rest endpoints all reset.

Oh well broken endpoints and another release without native android widgets.
I guess I will fix and continue on with the app kludge that I have just to automate mode changes.


#4

Make sure you email support@smartthings.com so that we can look into it.


(Chrisb) #5

What mode changes are you trying to automate and are unable to automate?


(Justin Wurth) #6

The point that broke was my endpoints. Endpoints are tied to switches that when turned on kickoff mode changes. Ultimately I use tasker and widgets to fire httpget commands to change mode through the switch. Broken endpoints on all my devices stop this from occurring and meant that last night I had to refresh my endpoints and then copy the enpoints to the tasker jobs on all of my devices.


#7

The mobile app update is completely separate from your endpoints and wouldn’t have been the cause of them no longer working.

I’m not sure what would have caused that.


Frustrations Building ST is So up and Down
(Chrisb) #8

Ah… okay. That makes sense. I thought you were having problems with scheduled changes like others where having when the big change over occurred last month.


(Yves Racine) #9

@Tyler,

I’ve tried the Jawbone Sleepy Time SmartApp. and still it does not work for me (android 4.4 on nexus5).

Should I email support?

Regards.


#10

I think we’ve already figured out what’s happening. Stay tuned.