All automations gone. Cant add new

I am experiencing the same difficulties:
Smartthings app shows only the home and away automations, all the other groups are now gone, ie smart lighting, ring, Google, etc. At times, even the home/away ones appear and disappear if you stand still in the automation page. The first time I tried to add smart lighting manually to see the reaction, I have obtained the list of my previous automations, tapped on done, but still the category did not show up in the main list afterwards. After this, clicking on add throws the error:
Can’t add automations
You need at least 1 location and 1 cloud-connected device before you can add an automation.
All the devices are listed instead, and the hub seems fine.
I have tried to clean any data from the app and re-set it to no extent unfortunately.

I believe there’s an ongoing issue and status shall be reflecting this.

As a temp workaround, it seems the Classic app works correctly and now handles also the newer automations created by the Samsung app!

Adam4, my first thought would be that this must be related to the ST app trouble you’re having. Thermostat Manager has no restrictions whatsoever in regards to thermostat type. If your device has, “thermostat” capability, then you should be able to select it no problem.

Unfortunately Thermostat Manager was not really designed for this purpose (Keep Me Cozy was). While TM does have the ability to control Emergency Heat mode based on an external sensor, that is the only type of external sensor that is supported at this time. This was added in by request in order to support those who live in extremely cold climates. Thermostat Mode Director attempts the feature that you are looking for (although it doesn’t work, for the same reason that I have not implemented it in Thermostat Manager, as I will explain). The thing is, unless you have a Nest or an Ecobee, I can make an app that will allow you to link an external sensor to your thermostat. In other words, we can say, for example, when tempSensorX hits temperature 80F, activate cool mode on the thermostat – and this will work. Let’s say that it is 75F degrees in the thermostat room and 80F in tempSensorX’s room. The problem is that the thermostat doesn’t actually start blowing cold air until its own internal thermometer hits the temperature setpoints that were set on the thermostat itself. Assuming that our thermostat setpoint is also 80F, in this situation, our thermostat will be set into cooling mode – it just won’t blow cold air. In other words, the system doesn’t really work like an Ecobee system in which the thermostat gives up control to the external sensor. This is why we don’t support it; it doesn’t work. Now, as long as you understand that I can bring the horse to water but I can’t make him drink (blow cold air), Thermostat Manager could be made to activate thermostat modes based on an external temp sensor. And I do get occasional requests from people who understand this and still want to add in support for this feature anyway. But as far as I’m concerned it is a feature that will never work well and so is very low on my priority list. I do expect I will add it in eventually but I won’t be adding in some half-baked AI (like Keep Me Cozy) in order to control it. Thermostat Manager is primarily a presence based thermostat mode manager.

My suggestion would be, check out Thermostat Manager anyway. It is pretty refined and I’m sure you noticed the developer is quite active. If you’re looking for something that is Thermostat Mode Director like, we’re probably the best of that type. But if you’re looking for, “Keep Me Cozy”, that is not what Thermostat Manager is designed for.

They’re back!!! All my automations are now accessible through the new SmartThings app.

We’re all back on since earlier today, support confirmed this was escalated to the correct Team, and resolved :wink:

Same here. All back to normal!

So all of my automations are gone. I think I have around 20, and I can’t get to them. I’ve noticed over the last couple of days that sometimes they would be gone, but if I backed out and went back in again, they would magically reappear. Today I can’t get to them at all. Anyone else having this problem? I need to make a change to a new one that I just created that had the unintended consequence of waking my husband up in the middle of the night last night. Yikes! #savemymarriage

I should add that I haven’t tried to create a new one because I’m worried it might replace all the other ones I already have.

Hello #savemymarriage :slight_smile:

  • try force quitting the app and reopen it
  • or last resort, sign out / sign back in but when you do this, you lose any changes you made with the main dashboard… sorting, rearranging of the tiles
1 Like

Well that along with uninstalling and reinstalling the app did it! Yay! Thanks for your help. I’ve already adjusted the automation so hopefully no more waking my husband up late at night to notify him that a garage door has been left open, when it’s only my son saying goodnight to his girlfriend!. :wink: