Alarm.com and Smart Things

Schwark, plz consider recieving payment to fix this app?

No longer working at all,

I’m having same issue with app. Worked last night but this morning nothing. I really hope Schwark will able to look into this issue. Alarm.com must have change something on there end…

1 Like

Unless someone has his cellphone # or twitter?.. he isn’t responding.

Ours is broken too, it sends the command to alarm.com we can see the user logging into the web portal but then nothing happens after that. Hoping there is a fix or update. Yes we’d consider paying to keep it updated in the future.

Same broken here. I’m seeing the login in the activity log just fine, but the commands are no longer cross over. Alarm.com must have changed the web commands portal.

1 Like

FYI EVERYONE: Schwark is aware of the problem:

I am seeing these :slight_smile: Unfortunately I am slammed right now, but my system is broken too, so I will fix this… May take till the weekend before I can get to it though…

4 Likes

I installed the necessary smartapp and device code, was able to set up in smartthings, have entered correct username/password for alarm.com website into the app.

Arm stay, arm away, and disarm were propagated under things, but they do not work. I am using an IQ panel. Does anyone have this working with that panel?

The code that sends the command to Alarm.com is no longer working, based on a change Alarm.com made. Schwark (see post above yours) the originator of this app, is suppose to be looking at it this weekend to try and fix the problem.

1 Like

Gracias. Thought it might be just due to the panel I am utilizing.

Like the rest - mine is down too - I figured it was something done by alarm.com - waiting and hoping for a fix - I really loved this Smartapp. Alexa recognizes and acknlwledges the “arm” and “disarm” commands - but then nothing happens! :frowning_face:

For anyone wondering - login to the alarm.com url in the app (https://www.alarm.com/pda/) via the browser on your mobile device - You could say the interface changed. What used to be a “Links” type interface now appears to be a hybrid experience much more aligned to their desktop site and even mobile app.

Good in one sense, but bad in the sense of ST integration…

This should be back up now. See Below:

Ok - this should be working now. And maybe those that did not have silent work before will have it work now…

It seems that Arm Away / (Arm Away)Disarm works; however, Arm Stay / (Arm Stay)Disarm does not? I see it sends the command but it never happens, no feedback other than sending event on ARMSTAY.

Arm Stay:

2:47:53 PM: debug sending event off to DISARM
2:47:53 PM: debug sending event on to ARMSTAY
2:47:53 PM: debug trying to update status of child device ARMSTAY
2:47:53 PM: debug getCommand got command null with silent true and nodelay of false
2:47:53 PM: debug updating status to null on command ARMSTAY
2:47:53 PM: error something went wrong: java.net.URISyntaxException: Illegal character in path at index 50: https://www.alarm.com/web/api/devices/partitions/${dataunit}${extension}/armStay
2:47:53 PM: debug state variable extension set to null
2:47:53 PM: debug state variable afg set to bgsHDQDoN+nWHeW8f/IMMw==
2:47:52 PM: debug state variable dataunit set to null
2:47:52 PM: trace response status is 200 for idextract and uri:https://www.alarm.com/web/History/EventHistory.aspx

Arm Away (you see it passes the variables after /partitions/ as opposed to above Arm Stay command where they are empty):

2:50:02 PM: debug trying to update status of child device DISARM
2:50:02 PM: debug trying to update status of child device ARMAWAY
2:50:01 PM: debug trying to update status of child device ARMSTAY
2:49:57 PM: debug postbody:https://www.alarm.com/web/api/devices/partitions/92785379-127/armAway::{"forceBypass":false,"noEntryDelay":null,"silentArming":null,"statePollOnly":false}
2:49:57 PM: debug header:https://www.alarm.com/web/api/devices/partitions/92785379-127/armAway::Connection:close
2:49:57 PM: debug navigation:[name:ARMAWAY, requestContentType:application/json; charset=UTF-8, contentType:application/vnd.api+json, uri:https://www.alarm.com/web/api/devices/partitions/92785379-127/armAway, headers:[...REMOVED..], method:post, body:{"forceBypass":false,"noEntryDelay":null,"silentArming":null,"statePollOnly":false}, expect:[content:(?ms)extendedArmingOptions], referer:https://www.alarm.com/web/History/EventHistory.aspx, variables:[:]]
2:49:57 PM: debug header:https://www.alarm.com/web/api/devices/partitions/92785379-127/armAway::ajaxrequestuniquekey:REMOVED  2:49:57 PM: debug navigation::post https://www.alarm.com/web/api/devices/partitions/92785379-127/armAway
2:49:57 PM: debug processing recipe ARMAWAY

Do we need to do anything? We just teied it and it’s not working for us. It logs in as the ST user but does not pass the command through.

Thanks

Mine is working (somewhat) - I use Echo voice commands - Alexa is responding to the Arm and Disarm commands by saying “Smartthings is not responding” but then the command executes anyway (that is, the alarm is arming/disarming from the command) Also, even though I have the “silent arming” option selected, it is not silent arming (that is, it arms but with the series of beeps) All that said, THANKS for the quick work!!

A few observations on the new version:

  1. Delay between smartthings switch and registering with alarm.com - likely because of a lengthier login / UI parsing in the new alarm.com web interface vs. the previously simplistic pda interface. This requires putting some delays in automations (e.g. webcore) to ensure they occur after state change.

  2. Refresh command doesn’t work - if you refresh any of the Arm Stay / Away / Disarm switches, either programmatically or by pulling the switch in the ST app, the code sends a disarm command to alarm.com instead of simply logging in and scraping the status to the switch. I posted this as an issue for Schwark on github.

Let’s hope he is able to address this before the weekend is over as it is key, at least to my integration.

Also a bunch of us posted on several occasions that we are willing to donate for his time and effort - does anyone have any coordinates as to how to actually send him money?

Thanks

Still not working for me either with ST or Alexa.

@ryant80 did you go into the IDE and update the code from the app?

I had to do that before it worked right

No sorry will try it now

My sincere thanks to @schwark for fixing this app so quickly - after replacing the app’s code with your revised code today it is working perfectly again. This also is a great time to thank @schwark for writing this in the first place. Of all the home automation I’ve done this is hand’s down the most useful and life changing for our family. We don’t have to think about the security system any more - it is off when it should be and on when it should be. There is no more stress of worrying about arming or disarming and forgetting. I never would have anticipated how significant this automation is to our every day life. Thank you for writing this app and making our lives easier and better.

2 Likes