Aeotec nano shutter z-wave integration witn Google home app via St v3

Hi everyone,

So I have been trying to make my google home app open/close/stop the “Aeotec nano shutter z-wave” which is installed in my shutter switch.

I did all the “My device handler” which provided by Aeotec:

# Window Shade Device Blinds

|Name|Window Shade|
| — | — |
**|Label|B

And I have encountered a few challenges/problems:

  1. In the google home app I see “blinds” that are connected with dimmer interface but not working (I have tried to bypass it with “scenes/routines” - no success.

  2. From some reason the st app (new one) show me “A network or server…Try again later” message so I Have downloded the Classic app and it works but…Still when i try “scenes/routines” it shows that its a light switch.

My only wish is to say “Hey google open/close blinds…”

I need help.
1 - My 3 way switch does not work.
2 - The device does not work on v3.

https://aeotec.freshdesk.com/support/solutions/articles/6000198855-nano-shutter-smartthings-custom-device-handler-

Follows the my code:
def refresh() {
commands([
zwave.basicV1.basicGet(),
zwave.configurationV1.configurationSet(parameterNumber: 85,size: 1, scaledConfigurationValue: 1), //set operation mode 1 (S1 = UP, S2 = DOWN)
zwave.configurationV1.configurationSet(parameterNumber: 80,size: 1, scaledConfigurationValue: 2), //report Basic Report to update status when controlled via switch
//zwave.configurationV1.configurationSet(parameterNumber: 120,size: 1, scaledConfigurationValue: 2),
//(Sets S1 external switch mode): 1 = reserved, 2 = 3-way switch mode, 3 = Push button mode, 4 = automatic identification mode
//zwave.configurationV1.configurationSet(parameterNumber: 121,size: 1, scaledConfigurationValue: 1),
//(Sets S1 external switch mode): 1 = reserved, 2 = 3-way switch mode, 3 = Push button mode, 4 = automatic identification mode
zwave.configurationV1.configurationSet(parameterNumber: 35,size: 1, scaledConfigurationValue: 30) //sets the total up/down time in seconds, this setting is used to calibrate the total up and down time.
])
}

You solved?
Tks.

Change Nano Shutter device handler to “Z-Wave Generic Switch” which should resolve your issue with SmartThings Connect not appearing.

Then you can use after performing an alexa device re-discovery:

“Alexa…”
“Turn ON Nano Shutter” //Opens Window
“Turn OFF Nano Shutter” //Closes Window

I has 3 aeotec work fine in smartthings classic app,
but not working in alexa
& not working in google assitant
& not working in actiontiles dashboard (mi own tablet for control home devices)
I supousse alexa, google and actiontiles integrate aeotec nano like a switch and send on/off,
but the device handler hope open/close
i going to trate to modify the original device handler to acept on/off and open/close
if you can help me “welcome”

Any news on that? Still need to create “routine” on my google home app to open/close. I searched all over the web - st/github/googl home forums…didnt finde nothing!!!

Alexa and Gh not the same. I try that. didnt work well. thanks and sorry for the ver late response