Aeon Doorbell Type Beta

Well, I got it working. I think. :joy: I tried the double tap method during pairing, and zwave excluding through the IDE, I’m not sure which one it was but it worked.

Everything seems to be working except for the BELL tile, when pressed it does nothing and the live log shows:

245daadb-e584-4f09-ac5a-8294947dc9b0 3:31:07 PM: debug Aeon Doorbell - RV v0.5 has been rung from button.
245daadb-e584-4f09-ac5a-8294947dc9b0 3:31:06 PM: debug Ringing Aeon Doorbell - RV v0.5
245daadb-e584-4f09-ac5a-8294947dc9b0 3:31:06 PM: debug Testing doorbell ring 2 on Aeon Doorbell - RV v0.5

The ALARM tile on the other hand works fine and shows:

245daadb-e584-4f09-ac5a-8294947dc9b0 3:33:35 PM: debug turning off Aeon Doorbell - RV v0.5
245daadb-e584-4f09-ac5a-8294947dc9b0 3:33:31 PM: debug Aeon Doorbell - RV v0.5 has been rung from button.
245daadb-e584-4f09-ac5a-8294947dc9b0 3:33:31 PM: debug Ringing Aeon Doorbell - RV v0.5
245daadb-e584-4f09-ac5a-8294947dc9b0 3:33:30 PM: debug Alarm test command received
245daadb-e584-4f09-ac5a-8294947dc9b0 3:33:30 PM: debug Testing alarm sound 1 on Aeon Doorbell - RV v0.5

Also, I am not sure what the big main ON/OFF tile is supposed to do, as it also doesn’t appear to do anything.

Just wanted to tell all of you thank you for your awesome work with this device. Love getting notified that someone rang my doorbell :slight_smile:

I am getting the same exact problem as @artkrime (Alarm tile is working, but not the Bell). My 1st objective is to have a door chime…When a door opens, a beep sounds. This does not work. I paired the device securely with no issues.

My only solution at this time is to use the original device type by @thoward1234. That seems to work (with a slight 1-2 sec delay), but I cannot control/select any other sound files for other tasks, such as a regular doorbell, alarm or other notification.

I was hoping that @Robert_Vandervoort’s device type would be able to do that, but it is reacting as stated above by @artkrime

Even though that BELL tile doesn’t work from inside the app, I was still able to setup sound files using Rule Machine, which is better because I can have it speak out loud “Garage door was opened” for example, instead of just a bell which doesn’t tell me what is happening exactly.

ok @artkrime ill give it a shot. How did you implement Rule Machine? I create the rule (for example, Front door open), but what do you select for “actions for True”? How do you send a command play the specific track?

How to setup Aeon Doorbell to voice alerts for different actions/triggers

  1. Install the latest code on this thread. (currently v0.5)
  2. Pair your device, make sure when you are pairing it, you double tap the button on the speaker unit itself, as I had some issues initially getting the key/handshake when I pressed the button once.
  3. Go to the IDE and make sure the preferences section of the Aeon Doorbell device has all the values filled out.
  4. Install Rule Machine and Rule from here
  5. Create audio files (mp3) for each of your custom alerts. I used IVONA and simply recorded the audio through Audacity, amplified the sound a little to make it louder and saved it as an mp3. Make sure you save it as: “6 Front door was opened.mp3” for example, and keep naming your audio files with the number in front all the way up to 100, as the number in the beginning will be used as the track number.
  6. Transfer all your mp3 files to the unit through USB.
  7. Go to Rule Machine and scroll down to Expert Features > Tap to create custom commands> Configure Custom Commands and create a new custom command using the Aeon Doorbell as the Test Device, and you will be using playtrack as the command and the parameters will be a number value which you will select for example 6, would play “6 Front door was opened.mp3”
  8. After you added all the different custom commands for each track, go back to Main menu of Rule Machine and now you can create a Rule, name it, setup your trigger, and the action will be Custom command which should be all the way at the bottom. Then it will allow you to see the custom commands you created like playtrack(6)
1 Like

[quote=“artkrime, post:356, topic:28889”]
Transfer all your mp3 files to the unit through USB.
[/quote]Transferring the files isn’t as easy as it sounds because the device assigns track numbers in the order that the files are copied to it. A few of us spent a lot of time fighting with this and the following post explains what we found to be the most reliable method of copying the files that always aligns the track numbers with the file names. Aeon Doorbell Type Beta

This is the exact same situation I had! I ended up having to unpair it from the hub, edit the code to set the default ringtone to 5, and THEN pair it. After that everything just worked…

Thank You! That’s exactly what I was looking for!
I had an early version of the Rule Machine and didn’t know how to use the custom commands…(what a great app).

Now I wish the delay of 2-3 seconds could be fixed. I did trim my mp3 file using audacity, so the mp3 file is not the culprit. This setup (working with rule machine) is a little slower (approx 1-2 sec) than @thoward1234’s with a regular routine.

Thanks again @artkrime

I’ve now fixed the Bell and Alarm tiles on the device page. You should now also see the top part light up orange when you test the Bell or Alarm.

https://github.com/jamesdawson3/SmartThings/blob/patch-1/Aeon%20Doorbell/device_type-aeon-doorbell-v0.4

1 Like

Ha anyone tried this DH yet?

Here is a new one everytime I add a new device the doorbell also shows up as a new device even though it has already been added, using @Robert_Vandervoort v.4, not sure what is going here. Just started with the last update.

Has anyone else gotten weird random instances (not sure if it’s related to this device type or the hardware itself) of the doorbell going off with no user-initiated press of the button on either the doorbell or the siren? It has happened twice over the last two weeks, with no normal interval or reason(s) behind it.

The only things I can think of are:

a) that the cold weather we’ve been experiencing (I live in the Northeast, in CT) has been messing with the doorbell button
b) I have a “notify me when” SmartApp installed that runs when someone pushes (switch turned on) the doorbell, and shoots a push notification out for it - perhaps there’s a bug in that SmartApp code? I’m leaning towards this not being the problem since the audible doorbell sounds also goes off when this happens, and that SmartApp isn’t what initiates the doorbell - it just initiates a notification when the doorbell is pressed…
c) a potential bug in the code somewhere.

Unfortunately I have no debug logs from this happening… not sure I’ll be able to get them, either, unless there’s a way to have logging always running, then I make a note of the next time I notice it happen.

Haven’t seen anything like that (I also live in CT). Though I’ve had issues with the reliability. Sometimes the button just doesn’t register and it takes two or three presses for the speaker to ring.

Any interruption in power will cause it to play Track 1 which is why we recommend replacing Track 1 with an mp3 that’s a couple seconds of silence.

Hmm, interruption in power to the siren or the button? If it’s the button, then that could maybe be it - I know cold messes with batteries… If it’s the siren, not sure that is it - my house is newly renovated and I haven’t noticed anything like dimming of the lights or anything like that when the randomness has occurred.

I suppose I’ll finally go through the process of setting up sounds on the siren - I’ve been putting it off, but I want to set up specific alerts for all my sensors, as well as a louder/better doorbell sound.

I’ll try this, thanks!

Just out of curiosity, how are folks setting up the Notify Me When for the doorbell? It’s something I’d like but can’t get it to work. I only see the device available for Switch Turned On and Switch Turned Off, neither one appears to work.

I’ve set it up as a ‘Switch Turned On’ notification for the doorbell, and then I have it fire me a text/push message with my custom text (‘Someone rang the front-door doorbell.’).

It works great for me - haven’t had any issues with it.

[quote=“Aelstrom, post:367, topic:28889, full:true”]
how are folks setting up the Notify Me When for the doorbell? It’s something I’d like but can’t get it to work. I only see the device available for Switch Turned On and Switch Turned Off, neither one appears to work.
[/quote] I wrote a similar device handler that supports the Button capability.

The switch turns on every time the button is pressed or the alarm goes off so this method won’t work well if you decide you want to use the alarm.