Xiaomi aqara loosing connection every couple hrs


(Anthony Cafazzo) #1

I used a device Handler to pair to SmartThings Hub and I’m having the sensor drop off every 2 hours anybody have any fixes for this or any ideas how to fix it?


(Bob) #2

Have you done a search?
There are lots of threads about this issue that give various methods to try to keep there paired OK.
Personally I’ve never had any issues but I know others have.
The first question to ask I suppose is which/whose DTH are you using?


(Anthony Cafazzo) #3

I am using the most popular one i found…bspranger GitHub. I’m also using a connect home for a hub if that makes a difference.and the sensor is literally super close almost next to the hub.


(Bob) #4

The DTH seems like the one most people are using.
As for Connect Home, can’t really comment as I use the ST hub.
Anyone else using the Connect hub?


(Bob) #5

Did a search and this was top of the list.


(Scott Ainsworth) #6

It highly likely that you have a wifi and zigbee interference. They occupy the same radio space. JD posted a good link at the thread below. You will likely need to change the channel on your wifi. If your neighbor has a strong wifi on the wrong channel you may need to resort to the hub reset.


(Anthony Cafazzo) #7

Thank for the info. I was using a connect home and heard that this was a problem with them. So I have already sold it and have a brand new hub v2 on the way. Since I didn’t really have too many devices set up I figured this was a good choice. (At least I hope it was) of I still have this problem I will try the above. Very useful information thanx a bunch!


(Bill Ho) #8

I have both Connect Home and V2 hub running at home. most of the devices are only connected to the v2 hub only except for the Wemo devices that are on both. All my Xiaomi sensors are still working properly through the v2 hub. I also have one of the Connect Home sitting next to the v2 hub. I don’t see any interference problem in this setting. I am waiting for a new sensor from Xiaomi that I will test on the Connect Home.


(Wasim Ahmad) #9

They’re not compatible with Samsung home Pro you have to have Samsung hub version 2 they work very well with version 2 I’m using more than yes no connection drop no any problem


(Bill Ho) #10

I just tried one Xiaomi temperature/humidity sensor with the Home Connect hub. It works fine. For all Xiaomi devices, it is recommended to keep it close to the hub until it has the battery level updated.