SmartThings Community

Wemo Dimmer Switch

(Persichini) #61

Finally got my switch connected… thank you. I was pulling my hair out.


Wemo skill to Alexa was the solution. No more IFTT. Never could get it to connect using the handler.

(George A Roberts IV) #63

Did you try using my handler?


yes no luck

(Joey) #65

I’m not sure if this is obvious for others but after i cloned the repo in the IDE here are the steps to make the code by SirTwist work. btw thanks for the update SirTwist

  • Clone the repo in the IDE using the instructions above.
  • Make sure to publish it.
  • On android open up the Smart Things CLASSIC application.
  • Go to Marketplace then click on the SmartApps tab at the top of the screen.
  • At the bottom of the list select “My Apps”
  • Now you should be able to run the dimmer app to locate your devices.
  • Wait for the dimmers to be found, select them and then click on save.
  • Now you can close the classic app and use the new app and all the dimmers will show up.

EDIT: I now see the dimmer app in the new smartthings application, but i have no idea how to add it from within that app. is there a way to all of this without the classic app?

(Rahul) #66

@sirtwist: You are a life saver. This has been the New Year’s gift that wasn’t on any wishlist, but tops everything that we received. Happy New Year to you, sir.

It has been frustrating for over 3 months, since the wemo dimmer based automations stopped working. I remember it breaking after the dimmer’s firmware updated to 2.00.11057 (latest version as of this post). I have no words to thank you for restoring these functions that we relied on, using Smartthings. My wife has been annoyed being spoiled with the automations, only for those to cease function one fine day. Thank you very much.

1 Like

It was very easy to get it working again with sirtwist’s handler. It’s important that it works through SmartThings and not just the Alexa WeMo skill. I was using the Alexa WeMo skill while the earlier handlers were not working to get voice commands working. Still, with SmartThings, I can setup routines. For example, I have the tied to my home alarm panel, so now when I open the back door after sunset, several lights outside automatically come on.

Thank you, @sirtwist!

1 Like

Okay, so this may be asking for a lot… would it be possible to get the WeMo long press rule working?

(Shailesh Soliwal) #69

I just tried integrating using the GitHub route and was able to successfully add the app to smart things.

Devices are being discovered, however, I get an unexpected error when I save:

[ Device type ‘Wemo WiFi Smart Dimmer’ in namespace ‘sirtwist’ not found. @line 231 (doCall)


Update: nevermind, got it to work, forgot to add it to device handlers .

(George A Roberts IV) #70

Let me take a look at it.


YES!!! Your repo works! Detected my 2 dimmers! Thank you!

(Wayne) #72

Thank you so so so much.

(George A Roberts IV) #73

Did you copy and paste the smartapp and handler in or did you use Github integration? I’ve seen posts where people have problems with stuff working when they copy/paste in. I’d recommend doing the Github integration if you haven’t tried that.

(George A Roberts IV) #74

I haven’t forgotten about this but haven’t had time to look at it yet, unfortunately. I’ll try to take a look in the next couple weeks.

(George A Roberts IV) #75

For those that haven’t seen it, there’s a thread specifically for my version of the Wemo dimmer smartapp and devicetype handler:


Wonderful, wonderful. Works great!

(Daryl) #77

sir, you are a hero. Not all heros wear capes!
I really appreciate the time you put into this to help the rest of us! thanks so much!!!

(Andres Pena) #78

Hi there!

Getting an error saying “Error saving page” after selecting my dimmer and pressing the save button. Any ideas?? Thanks

(Andres Pena) #79

Sorry I should add more detail. I’ve added the device handler and smart app into smartthings. In the Smartthings Classic app, I have to go to the Automation tab, then the SmartApps tab, click “Add a SmartApp” and scroll and click to “My Apps” before I find the WEMO wifi dimmer app.
Once I load that, it seems the app finds my one dimmer. I select it and press done which takes me back to the previous screen so I press “Save” in the corner and I get “An unexpected error has occurred.”. Sometimes I get “Error saving page”.
When looking at the logs i get this error: Device type ‘Wemo WiFi Smart Dimmer’ in namespace ‘sirtwist’ not found.

Any help would be greatly appreciated.

(Andres Pena) #80


I have no idea what I did differently but it works now!!