"we are back" routine have lights switch on only if light level low?

I currently have my “I’m back” routine switch on a few lights if either me or my wife arrive home first, I use the Fibaro motion sensor in my living room, is there a way to just have that routine switch on lights if its dark?


Do you mean if the sun is down or not?

In Scotland, this doesnt matter haha. It could be 1pm in the afternoon and it could be very very dull so using this solution wont work for me. I’d need it set based on light levels.

Hey John,

You’re supposed to be focused on other things. :slight_smile:
To do what you want rather than Sunset and Sunrise, you can do it based on illuminance being <= xx (equal or lower) to be considered dark. Any device reading lux levels (motion sensors, or weather device). You can do this in the Smart Lighting SmartApp (More options) or WebCoRE that we talked about before. You get to do a search for what lux levels would be considered dark or light, sunny or cloudy for your device that you are reading from.

Read this thread from here and down:

HAHA. You got me :slight_smile:
Technically this is part of my mission for today so I’m allowed. :wink:

I can use the lux levels when setting them on their own but can’t seem to see that option within a routine.
Whilst I’m on The subject Of lux readings. I’m currently looking at my fibaro motion sensor and the lux reading is at 2, even though it’s pretty bright in here. Do I have to adjust this somehow?

I don’t believe you have the ability to do this in a Routine. You can either do it with the Smart Lighting SmartApp (under more options). Turn on light, More options, Illuminance… or WebCoRE.

As for readings I do not have Fibraro, and others report varying numbers, so do a little homework and read threads and perform various searches on fibraro lux, Illuminance, etc
… You can play with it yourself as well. Put a box over it and see what it reads. Shine a flashlight on it as well. Inside and outside will differ as well as sunlight, cloudy, hazy, etc.

Yeah I did think that thanks.
It’s not too big of a deal as it’s generally always dark here anyways haha. I’ll have to re asses come the summer. I’ll try them tests with the Fibaro, thanks.

So I’ve managed to sort out my nest and have it working the way I want. I now see in Alexa that I now have 2 thermostats within my account for some reason and when I ask Alexa to turn the heating up She says ‘ I’ve found more than 1 thermostat in your account ‘
I think this has something to do with nest manager app in smartthings but can’t figure out a way to remove this from Alexa without having to remove it from smartthings, which I don’t want to do for obvious reasons.

For Nest it has to do with you allowing ALL devices in the Amazon Alexa SmartApp to be discovered by Alexa. Turn that setting off and choose all switches that Alexa didn’t natively discover from the 3rd party apps themselves. In other words, if it only exists in SmartThings, then select it to be discovered (do not select any of the Nest devices). Then select to add Routines as well.

Now to remove the SmartThings discovered Alexa devices, you will need to goto https://alexa.amazon.com and do it from the website. You cannot do this from the Alexa App. If you are doing this from your Mobile phone and using the browser, it will try and redirect you to the mobile app. So if on your phone, when you goto the Alexa website, change options to display desktop version (chrome anyway). Or do it from a desktop or laptop. Remove the Nest devices that show SmartThings. Then you will be left with just the Alexa discovered devices she found from Nest directly. My guess as to why it sees multiple is that you have them named differently in ST versus their original name from Nest. Anyway, this will prevent that.

Once you do that you should be able to just say “Alexa, set temperature to xx” without even referring to the thermostat by name if you only have one thermostat in Alexa.

Hmm, my devices are all over the place within the Alexa app. I had Alexa first, then I added smartthings so I think what’s happened is I had it checked to add everything from ST to Alexa app and it’s duplicated a lot of things. I deleted the 2 thermostats from Alexa through the website and tried to re add the nest. It has discovered it but still not responding to my commands.

If you have 2 Nest Thermostats then you need to refer to them by name.

Also in the Alexa app, you can sort by name, not by newest.

You need to set the Amazon Alexa SmartApp first, then delete the SmartThings devices from Alexa that say SmartThings under them and then the next time you run discover devices in Alexa, it won’t pull in the SmartThings devices again, except for the ones you selected to be discovered.

Alexa set temperature to xx.
Her: a few things share that name, which one did you want?
Upstairs thermostat, downstairs thermostat


Alexa set temperature on downstairs thermostat to xx.

Thanks. Again.
What a mess that was. Thanks for the direction on how to do all that. :+1:

I owe you a few beers. :slight_smile:

You owe me a keg or a beer truck :grin:


If you have the same Fibaro as me (FGMS-001 ZW5), it seems it only reports lux levels once per hour and I see no way to configure that.

yeah if that is the newest gen then that will be the one I have.