Voice Command Solution - Discussion

Hi Joshua – Still trying! I authorized some devices, but now this is what I get. Sorry for all these tedious messages…

Chris-
I don’t see anything immediately wrong with your screenshots, but I didn’t see any description of the problem you were having either? I put together a really quick video showing me walk through this on my Nexus 9. I go through the steps fairly quickly, so you may want to use the YouTube controls to slow the playback down or pause/rewind as necessary.

One thing to note is that you need to fully back out of Tasker before the profile becomes active - this has bitten me more than once!

2 Likes

For those using the Apple Watch for voice command, just wanted to mention that both the SmartThings official watch widget and the IFTTT Do Button can be brought to the top with voice, then executed with one tap. Way easier than messing with the app selection screen. So:

  1. wrist turn
  2. “hey siri” (wait for taptic)
  3. “open SmartThings” or “Open Do Button”

The watch will then open that widget

  1. tap to execute

If like me you find the physical buttons hard to use, or you have a lot of watch apps, this uses voice to simplify access.

Note also that for IFTTT you have to say “Do Button.” If you just say “Do” it wants to handoff to the phone.

Josh – Thanks for the instructions. Finally got this working. I’m assuming I can add commands to “lock” on “unlock” [door locks" etc., in addition to "turn"ing on various lights?

On a separate note, any thoughts of using microphone module(s) on a room’s ceiling, connected to a dedicated Android device, to pick up a hot phrase in order to deliver voice commands without use of a phone?

Chris, yes, you can use the commands ‘lock’ and ‘unlock’ for door locks.

I haven’t thought much about using a microphone module paired with an Android device, but it seems like an interesting idea. Amazon Echo has a nice microphone array in their device and it would be nice to use a bluetooth version something like that, but I haven’t seen anything reasonably priced on the market.

1 Like

It’s here! As of August 21, 2015, we have official integration between smartthings and Amazon echo. And it works great! FAQ here:

2 Likes

If this is true, and it works well, I will be buying an echo this weekend… Have a 50$ gift card burning a hole in my pocket!

2 Likes

Hah! Blog article magically disappeared!

SmartThings support told me to look again tomorrow. :wink:

Integration is up - just check your Echo App.

1 Like

@danielccm speaks both English and Spanish, his wife and children speak only Spanish. He’s looking for voice control solution with smartThings. My guess is he’ll need to go with a Spanish-only android set up, but then I’m not sure if sharptools can fit into that. @joshua_lyon ? He could have the set up screens in English, that’s no problem. It’s just the actual voice recognition that would need to accept Spanish.

Any other suggestions?

1 Like

The language requirements for voice integration with [SharpTools] (http://sharptools.boshdirect.com/features) are based on Google Now since its done through the AutoVoice plugin. So as long as Google Now supports your language, then it should work. (Spanish is supported) As @JDRoberts mentioned, the setup will be in English but then you would be able to control in your supported spoken language.

Here’s an example setup for voice control with Tasker + SharpTools +AutoVoice:

2 Likes

I’ve setup a single command in Tasker as per the instructions in sites.google.com/a/boshdirect.com/sharptools/examples/autovoice-control-device?pli=1

I’ve bought the tasker plugin for sharptools.

I say the command, for example “turn the hall on” but nothing will happen…

I’ve also tried to say it without the “the”…

Ideas?

@danielccm I would start by confirming that you can control your devices directly within SharpTools and then check the logs of AutoVoice to see what it’s actually recording. I would also take a look at the video at the bottom of the post you linked to and double check that your settings look the same.

PS. Feel free to tag me @joshua_lyon in future posts or use the Send Feedback option in the app to email me directly if you want a quick response!

1 Like

Is anyone else having a problem where when you use the "OK Google’ command to activate tasker it wll also do a google search and open up a new tab in Chrome everytime you do a voice command?

TIA!!

2 Likes

Are you using AutoVoice for the OK Google integration?

Update: Echo, HomeKit, and voice text to IFTTT options

OK, my home setup now includes all three Voice options used for different things: echo with SmartThings, HomeKit, and voice text to IFTTT with SmartThings and other stuff.

So here’s my experience.

Echo is far and away the best voice technology. Best voice recognition, best far field recognition, most natural language. It’s my preferred method whenever it’s available.

HomeKit Is pretty good. Better on the watch than the phone, at least for me. Misses more stuff than Echo, but I like being able to ask status. Language structures are more formalized then echoes, so you have to kind of get into the rhythm of what you’re using. You also really need to think in terms of scenes rather than groups. It’s definitely convenient for situations where I’m out of range of the echo or for devices which are not available to the echo. Also, Siri is much more conversational then echo, and that’s kind of nice. But I would say even now I have to repeat myself about one in four times, which is not true for echo.

Voice text to IFTTT, using will Poirier’s original method, has proven to be useful for anything that attaches to IFTTT. It’s just that the structure is so clunky because you have to have an exact match to the hashtag. It’s especially good for anything where I want to send text message alerts to multiple people at the same time that I’m doing something else. This is gotten better since watch OS 2.0 since now texts can be sent completely touchfree. :sunglasses:

So pretty much for any use case I start with “can I do this with echo?” If I can’t, it’s “can I do this with HomeKit?” And then if not I’ll see if there’s a way to do it with voice text.

Between the three it’s a good combination for voice coverage of most use cases. The watch lets me do things from out in the yard as well as inside the house as long as I’m in Wi-Fi range. So I do have some use cases set up with multiple voice input options just to handle the times when I’m not in range of the echo.

Choice is good. :sunglasses:

Yeah… I’m was having the same problem. It was just going to the google search screen with the recorded phase. Turning on the following services in the Accessibility settings fixed it.

2 Likes

Working good here with Sharptools and Google Voice Josh did a great job on Sharptools still a little to improve but it’s almost 100% here is a demo

2 Likes

It won’t be released for at least another six months, and we have no idea yet what it will cost, where it will be sold, or how good it will be. Nor what kInd of ST integration will be possible. But for those who want to discuss the new Google Home device which is intended as a competitor to echo, see the following thread:

2 Likes