Virtual Switch and Scenes, please help

Hello, So I’m trying to use my stream deck to control my office lighting. So I have 2 scenes one where it sets a color light to a dim blue and turns off everything else, and another where it set everything on again.
Trying to use IFTTT I wasnt able to see my scenes, so researching it I found a working around creating a Virtual Switch.
My issue now is that to control a scene with a virtual switch would trigger it on and off, where I do not need the off state for the scene. So in my case if I try 1st scene it would turn the color light to blue and the rest off, and trying to set everything on again with 2nd scene will work fine, until I want to set 1st scene again, and here is the issue. If I set the first scene again, it will turn off not doing anything, then after the off state I can turn it back on again.
Reading a bit more I found out about momentary button tile, which is supposed to do what I need, but for some reason is not working right, first that it only show as connected in the new app, and in the classic app I do have a button called push. But when pushing it it will flash about 4-6 times and goes into this loop where my light start to blink as I sent a bunch of commands to it.

How can I get it to work? I need to control 3 lights in different states when gaming and when not gaming. Also that can be carried over to IFTTT to be able to add to Elgato Stream Deck.

Please help thanks

Link to how the smatthing app behaves

Momentary Button tile not working

There are lots of ways to handle this, but I think the easiest in either app is just to use the “power allowance” feature of smart lighting and set your original virtual switch to always turn itself off after one minute. That won’t affect the scene at all, because scenes don’t get turned off. But that way the virtual switch will be ready for the next time you want to turn it on. :sunglasses:

Just create a new automation, choose your virtual switch, and then say you want to turn it off for a particular trigger condition, in this case “power allowance.“

1 Like

Hey thanks JDRoberts, but Im banging my head against a wall already, I have spend all day trying to make it work. I cant find a way to create what you suggested, I’m sure it will work but I just cant find where to set those settings. I found a energy saver in the app section but my lights dont support energy monitoring I guess.

With that idea in mind I got to set a routine on the classic app where I would turn off lights or switches when something turns on or off. So I tried to Turn off my virtual switch when my virtual switch is turned on. So I would trigger the scene and turn off. But something is wrong, it just go into a loop of on and off and then stops on the on position. My lights go crazy turning on and off until it stops. Ill post a video with what I have done so far.

thanks

So here you can see it strange behavior of going on off multiple times.

Things I did:

Created a virtual switch.
Created scenes.
Linked the virtual switch using smart lighting automation.
Created a routine to turn off the switch after it triggered the scene.

Up to scenes everything’s works. After linking the virtual switch to the scenes, I can’t turn them off. Trying to set a routine should fix it, but it doesn’t work.

Any ideias?

The labels aren’t very helpful, but it’s pretty straightforward.

In the new V3 app:

  1. click on the menu in the upper left corner and choose smartapps.

  1. Choose SmartLighting

  1. choose New smart lighting automation

  2. select the switch you want to turn off

  1. now comes the confusing part. There’s going to be an option that says you want to “turn on“ the switch. Pick that, and then on the next page you will be able to say that you actually want to turn off the switch.

Once you save that, it will bring you back to the previous page but now it will say ”turn off” on that same line.

  1. now you get to pick the trigger for turning off by Tapping the line that says “select trigger.“ All the way down at the bottom of the selections on the next page, there will be a choice that says “power allowance.“ That’s the one you want.

7); And after you select that option and tap “done“ you will then get to enter how many minutes you want to wait before turning the switch off. In your case it’s only going to be one.

Finish saving, and you should have an automation that will turn your virtual switch off after one minute every time you turn it on. :sunglasses:

2 Likes

That’s an amazing help, you made it easy to find :), but for some reason it still not working.
I’m probably doing something wrong some where. I did turn it on waited and nothing. Still on.

Im thinking somewhere linking the virtual switch to the scene could be the problem. Im not sure

Thank you it finally worked. OMG! such a relief. What do you want to do? Turn On? NO, it has to be turn off. Changing that setting finally made it work.
Thank you so much JDRoberts for all your help, you are the best S2

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.