Vibration sensor Alexa Routine

Hi, I tried searching for the answer and couldn’t find it so forgive me if this has already been asked… I am after creating an Alexa Routine using the vibration function of the multipurpose sensor as a trigger to get Alexa to announce that someone is knocking on the door. I have created a sensor switch with the device handler instructions which show up in Alexa, I have a automation in ST that says if vibration is detected at the front door then the (virtual sensor switch I created) is on. The issue is that there is no sensor option for open and closed in the ST automation, only on and off but Alexa is showing the sensor as an open and close option and they dont tie up to work. Why cant I see the open close sensor in the ‘then’ on automation? I can see it in the ‘if’

Many thanks for your time.

If you use the code which is linked to in the community FAQ, then you will end up with a virtual device which is both a sensor and a switch.

Turning the switch part on will make the sensor part look like it is open.

Turning the switch part off will make the sensor part look like it is closed.

So you will be able to trigger the echo routine from the sensor part being open by having a smartthings automation turn the switch part on.

But an echo routine cannot set a sensor to closed. So you would have to use the name of the device which is the switch name if you want the echo routine to change it.

That means that when you look at an echo routine, the sensor name should show up As an option under the IF and the switch name should show up as an option under the THAT.

Is that what you were asking? I found it a little bit confusing.

But you have to be using the code from the FAQ or something similar so that your one virtual device looks like two devices, both a sensor and a switch.

FAQ: Can I trigger an Echo Action without Speaking to It?

If you can post a screenshot of your automations, that would help. :sunglasses:

1 Like

That was exactly the answer I was after and with thanks to you my problem is now fixed. Many thanks, and merry christmas.

1 Like