Updates to the SmartThings Platform

Normally that is not necessary; you can just update the device handler in the IDE and the new code will take effect.

1 Like

Hmm, ok. Maybe whatever they changed didn’t fix the issue since I’m still seeing the same problem when trying to create the new Smart Lighting automation. I may still try to uninstall and reinstall one of the switches this evening to see if it changes anything. Thanks!

This would be a top priority to me as well. There are things controlled by smartthings that I would not want alexa to control, mainly because I don’t want my child controlling them with his voice. I also agree with @uberrob that having the echo/google home connect to the devices cloud is most of the time MUCH better then having smartthings do it.

It would be good to know how long this update might take. I think I will hold off on Migrating until this change is complete, as in my house that is a HUGE deal breaker and would complicate my setup that works very well currently.

2 Likes

Honestly, SmartThings without Echo Speak is NOT a solution.
Having the ability to create text in webcore from variables to be spoken by any number of echos is what makes Smartthings useful…this is the key to making it user friendly and why I’m able to inplement Smartthings at my parents who are 84 years old. Take away the voice and its not really anything. They have to know this would make a lot of users VERY unhappy
Why would Samsung kill this without implementing a more efficient replacement. They obviously have smart engineers so they could have done this however they did not.
Don’t expect users to stick w what will be mediocrity.

6 Likes

Yes same issue with the Ge/Jasco DTH and I imagine probably countless other ones. The old DTH does not function with the new Smart LIghting app. I posted over there on this as well [BETA] GE/Jasco Z-Wave Plus Dimmer Switch With Double-Tap. Fortunately Inovelli was on it (I recently purchased some of those and can’t praise them enough) and hopefully Homeseer can help, but as I mentioned in the other thread, Jasco never released their own DTH, and the user that made the initial Nuttytree custom DTH for the Jasco switches is now on Home Assistant. Also as I stated over there and as I continue to read this thread, I now understand why he left. When I got Smarthings I thought it would be easy to use. I didn’t think I’d have to dust off my old college coding textbooks to re-write Groovy DTH’s so I can make my switches work.

2 Likes

If you have either of these GE/Jasco motion-dimmers
GE Motion Switch (26931) and Motion Dimmer (26933)

MichaelS has the DTH that supports those and it works with Smart Lighting just not If…Then automations.

Of course, at some point in the future if ST doesn’t do a native integration, support will go away

https://community.smartthings.com/t/release-ge-motion-switch-26931-and-motion-dimmer-26933/

1 Like

My top priorities are:

  • Fix the Virtual Switch/Sensor not triggering Alexa routines. This worked before I changed to the new Alexa Voice Assistant integration. I use Virtual sensors to trigger people presence for Alexa routines and to turn on Alexa Guard via virtual location mode sensor. Basically without them working, I don’t have full walkaway automation.

  • Take the DTH for the GE Motion Switch (26931) and Motion Dimmer (26933) written by MichaelS and provide native integration for those devices in the ST app. Also make sure you can trigger actions for them from both Automations and the Smart Lighting app. Losing support for those devices will probably force me off ST.

  • Something broken in the notifications chain for one of my smart locks and now the LUM Smartapp won’t trigger actions and notifications when the lock is opened or closed using individual codes. This breaks quite a bit of my home automation since different user codes trigger different location modes enabling/disabling thermostat modes, alarm modes, etc.

  • Get Echo devices working as speakers again for notifications. Telling me to upgrade to the new Voice assistant without this support being ready is an egregious regression of functionality.

  • Make sure 3rd party Smart Apps continue to work before shutting down the old IDE environment. 3rd party Smart Apps bring more value to the ST ecosystem. Without them, I can’t see continuing to use ST for home automation.

So far, these are the things I’ve identified as issues for me, currently, and in the foreseeable future. I can understand minor feature disparities between the new platform and the old. What I’m seeing, however, are major regressions in functionality and features that, if uncorrected, will impair my ability to successfully use home automation based on SmartThings. Please listen to the whole of the ST’s community and work to correct issues and bring feature parity before leaving us high and dry.

Lastly, I’m happy to participate in diagnosing and troubleshooting issues. If you have diagnostics or can provide instrumented versions of the app that can track down problems, contact me.

Thanks!

3 Likes

@blake.arnold, the new app is becoming less stable/functional with each passing day. Things that were working weeks/months ago are no longer working today. Over the past weeks the following things have stopped working in the new app:

  • Component child temperature devices no longer show up (they just disappeared and show up a empty spots on both iOS and Android)
  • Component child button actions plugin stopped working (on both iOS and Android, it either crashes, exits the page or just doesn’t work)
  • Dynamic page refreshes for SmartApps have stopped working on iOS (still working on Android)

These are just some of the issues which have cropped up and been reported by us in the past few weeks. All of these were working on both the new iOS and Android apps, with each passing week more things stop working in the new app. This is making is really hard for us to keep things smooth. The least we can ask is not to have regression bugs which affect things that are already working in the new app or atleast have a quick turnaround time to fix these regressions.

18 Likes

:100: thank you

7 Likes

There were a couple of issues with the HomeSeer switch and dimmer device handlers on the new app. I’ve received a couple of updates for several of the handlers from a user, but haven’t fully tested them. They are available at the links below if you want to give them a try:

200 series:

WS100+:
https://raw.githubusercontent.com/DarwinsDen/SmartThingsPublic/master/devicetypes/darwinsden/ws100-switch.src/ws100-switch.groovy

Good catch on the voiceover issue. I can see how that got confusing. Usability can be a huge legal liability for Samsung. They should fix this (which is very easy to do).

Also, consistent design principles will help with usability for everyone. Circles are commonly used for “radio buttons” (mutually exclusive selections), and squares are usually used for checkboxes (multiple possible selections). It would be wise for Samsung to keep things simple and stick with the standards. You can still make those elements more attractive than the norm without losing the user’s comprehension.

2 Likes

Yep, have noticed the child button action issue as well.

It seems that in the last week my very functional SmartThings based home automation system has lost a massive amount of its prior functionality. Many of my devices that were recently working in the new app no longer work. I can no longer choose which ST connected devices to expose to Alexa or Google. My virtual ST sensors no longer trigger Alexa routines. I haven’t had time to create the virtual switches and webCoRE pistons needed to recreate the functionality I lost by “upgrading” from SHM to STHM, but it seems to me this really shouldn’t be necessary. About 10% of my devices randomly show as not being connected on a regular basis in the new app, and when they show this I often lose the ability to control them through anything other than the classic app. They show as connected when I log into the IDE, and they respond to commands from the classic app just fine, they just don’t respond to the new app or ActionTiles or to the new ST skill for Alexa or to the new Google integration. And more recently I’m seeing devices with this behavior except the new app shows that they’re connected, it just times out if I try to control it. This was previously limited to devices using cloud based DTH’s, but in the past few days I’ve noticed it with two devices using stock DTH’s.

The last straw for me came the other night when I had to get out a ladder to unplug some bistro lights from a zigbee plug. Family was complaining that Alexa commands weren’t working. So I tried the new app, shows as connected, but times out if I try to turn it off. Try ActionTiles, doesn’t work. Log in to the IDE, the device shows as online, everything looks normal, great LQI/RSSI numbers, and I even see regular check-ins from the device during the time I was trying to control it without success.

I’ve been a SmartThings fan for a few years now, and have regularly defended it against its detractors. With these recent changes, I can no longer do that. I’m not sure yet what I will use for my home automation platform going forward, but it doesn’t look like it will be SmartThings. The thought of moving ~150 devices to a new platform is daunting, but I just can’t live with this reduced functionality any more.

Thank you to the amazing community here for the help, support, ideas, and insight over the years. And thanks to the ST staff who regularly post here and offer great assistance and insight. Will be sad to lose all of that.

7 Likes

Thanks for the response @blake.arnold.

Hopefully, yes, that does clear up that issue.

Shall I give you the list of other issues I have been having? I am happy to do that - because I have been keeping a list. I want to be patient, but this has not been a very pleasant transition for quite a few of us.

1 Like

New community FAQ. (The topic title is a clickable link.)

2 Likes

I updated the custom handler yesterday to that code. I didn’t see any difference in the behavior in Smartthings, but I didn’t get a chance to remove any of the devices and reinstall them to see if that made any difference. Sounds like I shouldn’t have to remove them, but I’m not sure if anyone else has had any luck getting it to work.

So I clicked “Migrate this site” in my classic app. It went through 6 out of 11 applications (I’m not a heavy user), and then rendered message saying something like “some applications can’t be migrated, check flagged issues in the classic app”
I’ve re-opened the classic application, now it says “this site has been migrated”. That’s it. No idea what the issues were and where to find it. Are you kidding? What am I suppose to do? Have you even tested this, once?

What region are you in?

If you are using ST’s smart locks and in a region where smart lock guest access in the new app is not available… that could be one of the error messages.

At least IFTTT and Ecobee are missing. How am I supposed to have it working without IFTTT?

Look in menu > settings > linked services

1 Like

Thank you. I guess it’s some other apps that are missing. The problem is I can’t find out which (my custom apps are here…) Was that message about 5 non-migrated apps just an error?