SmartThings Community

[UPDATED 3/27/18] GCal Search

Ok… thanks for the clarification next issue. This is my new screen which is possibly related to the type of credentials I requested from Google.

You probably have me on this one. I remember having an issue knowing which type of thing to set up on google. It’s been a while since I set it up and I don’t remember. I think you have to pick web or something like that.

I like to go in and have a look and try to make up a new app so I can see the options. But I just go this working again after having apps I could not delete and then my reinstall didn’t work the first couple times.

I would look in the Google portion. Might have to delete and set up a new Google project.

Might want to wait for @infofiend or @mnestor to reply with a more specific answer

Did you try it with just the standard URI instead of the graph-na02 one?

UPDATE - 3/6/17

  • Scheduling updated
  • Fixed Event Trigger with no search string.
  • Added AskAlexa Message Queue compatibility: Get Event Notfications from your AskAlexa message queue

Please make sure to upgrade both smartapps and both DTHs!

4 Likes

Updated the app this morning… same result

https://graph.api.smartthings.com/oauth/callback used as the callback instead of the one related to my IDE

Will this address the issues I was having? Just curious if you found anything before I toss it in?

https://graph.api.smartthings.com/oauth/callback used as the callback instead of the one related to my IDE

Ok, I’m guessing that the callback address is different depending on what shard you are on. I can probably make it change programmically. If not, I can certainly make a different version for you guys.

That would be great. I went through you code and changed out the call back to agree with my IDE (as you can see from my posted pic from before), but I still got the Google error.

but I still got the Google error.

Those of you who are experiencing this error - are you on iOS or Android?

I am on the same shard but mine is failing with invalid_client. I must be doing something wrong…But not sure what…

Justin -

Check/Try the following:

  1. Did you enable the correct Google API? Make sure its the Google Calendar API
  2. If that’s correct, try deleting the credentials you set up and making new ones – Using the correct callback url .
  3. If that doesn’t solve the issue, then enable a second API - the Google+ API.

Google Calendar API

Credentials

I’ve also enabled the Google+ API

Same error message…

Ok. I think I see what is wrong. It looks like you didn’t set up the right type of credentials. You need the to set up Credentials for a web application. Click “Create Credentials” --> OAuth Client ID --> Web Application --> Fill in the name & redirect url --> Create

If you click on the credentials you created, it should look like this:

My screen appears exactly as yours. I tried shard1 and shard2 oath callbacks and I get the same exact message.

Someone mentioned earlier being on iOS or Android.

I am iOS

It looks like it just takes a while for the servers to talk to each other ?!..I am all set up now…

Use the same path you use for EchoSistant in Lambda…And you do need to change it in ST app too. Once you do that, refresh your oauth in ST, update credentials in Google then wait couple of minutes …

1 Like

ooops…wrong thread …

1 Like

Not sure what I’m doing wrong… but I’m getting the “Error: disallowed_useragent” screen when I go into the app

If you refreshed your Oauth in ST, have you updated google project with new token?

I don’t see where to do that?