SmartThings Community

Core Piston: Run this every day between these hours, but "NOT on these dates"?

webcore

(Sidney) #1

How do I tell a Piston not to run on certain dates. I tried setting Global Variables with the dates, but that didn’t work.

I’m missing something, but I don’t know what it is.

The Piston is basically doing the following:

If any of these doors open
Open this simulated contact sensor
Only between these hours
Only Monday through Friday

Everything above works perfect.

I want to add “Not on these dates”

Any help would be greatly appreciated
Thank you


#2

This is probably what you’re looking for…


(Sidney) #3

I will try this, but it doesn’t look like what I’m trying to do.

For example, I would like the simulated contact sensor to turn on On These Days, Between These Times, but not on these Dates.

So, if it’s 11/22/2018 (Thanksgiving), don’t do it. If it’s 12/25/2018 (Christmas), don’t do it. There are other dates, not just holidays. It would be days that I would not be at work, the kids not at school…etc.

Is there a way to give it a list of dates NOT to run?

I may be asking too much of it.


#4

Ah, you’re going to want to check out GCal for that. Many people use it with webcore, I do not use it so I can only point you to the path :slight_smile:


(Sidney) #5

I came up with a very unique way to handle this.

If any of these doors open
-Only between the hours of 7:15 AM and 3:05 PM
-Only Monday through Friday
-Wait 30 seconds
-Open this simulated contact sensor
-Wait 5 minutes
-Close this simulated contact sensor

The simulated contact sensor triggers Alexa to say, “An unauthorized entry has been detected, you have 30 seconds to identify yourself, otherwise the authorities will be alerted”

She doesn’t actually alert the authorities, it’s just a scare tactic.

So, the issue was, when someone is off of work/school, she will say this almost every time an outside door is opened.

So, the solution:

Created a simulated switch called ‘Someone is Home’.

Added the following to the above ‘If’ statement before the first Wait

 -Switch 'Someone is Home' is OFF

Created an Alexa routine: “Alexa, it’s Neal”

The routine triggers Alexa to say, “Voiceprint authorization accepted. Welcome home Neal. Standing down red alert” (I know, I’m a geek).

The routine also changes the switch ‘Someone is Home’ to ON

Later in the day, another routine (that turns a light on), also turns the switch ‘Someone is Home’ back to OFF

So, now, when someone is off of work/school, they just say “Alexa, it’s …” and the unauthorized announcements are turned off for the day.

I’ve added a routine, “Alexa, it’s …” for each member of the house.

I’ve also added a routine, “Alexa, it’s me” and she will respond saying “Voiceprint authorization not recognized. Me is not on file.”