Timed routine not triggered

I have a very simple timer routine to trigger a switch. It looks like it runs locally.

It works most of the time, but it sometimes skips for no reason.

Nothing is in the logs either about routine being triggered.

It feels like this is the simplest routine but it has inconsistencies.

Is there any way to debug this?

I’m sure that’s very frustrating. :disappointed_relieved:

I know you probably can’t post a screenshot yet, but can you give us a few more details?

In particular, when you say “timer routine”, do you mean one that runs at a specific time, like 6 pm?

Or one that runs after a delay, like turn off after 20 minutes?

Both of these can glitch occasionally, but for different reasons. :thinking:

It’s as simple as this. Last night for. Some reason, it didnt run. On the other days, i can see it running the routine without any issues

Normally, i see this every night

The scene is simple as well.

Sorry for multiple posts. It is due to the forum limitation of one image per post.

Ok, the most common reason for a routine set at a specified time not to run is that the hub was off-line sometime during that day. It doesn’t have to be exactly that time, sometimes if the hub was off-line earlier in the day it can cause later routines to be delayed or in a few cases missed all together.

Did you check to see if the hub itself had been off-line at any point during that day?

1 Like

One option to try as an alternative to Routines: SharpTools Rules Engine


It shoudlnt be offline but maybe it was. I guess i will just wait and see if it happens again.

Thank you

1 Like

How about this one? All seems conditions are true. I can see the temperature sensor is reporting every minute as i configured, but for some reason the routine didnt’t trigger.

I was expecting it to trigger at 7:30 this morning.

Remove the location mode from the routine and test it.

I just tried turning off the switch manually from the physical button. The routine triggered immediately and turned back on. So i guess that part is expected.

At 7:30 the location mode was home. Nothing changed there since.

I can see why, but you’ll probably find the temperature condition only triggers the routine when it changes from false to true and it is already true at 7:30am.

You’ll need an extra routine to run at 7:30am to handle that border condition.

You mean just create a routine with

home location mode
At 7:30

So that it runs regardless of temprature at 7:30 when i am at home

No I mean create a routine to run at 7:30am that checks the temperature, mode and radiator state conditions and turns the radiator on if required.

this all makes sense. thank you

Not sure this is the correct thread to post, but here goes.
Running ST v3 with 46.8 as version.
I updated my Zooz switches to use the “new” Zooz edge drivers.
I created a routine to register when a door was open (samsung door sensor) and turn a light on in the room. I selected a custom time on the routine to turn the light off. I tried several custome times and none seem to turn off the light. I selected the predefined times of 1 and 10 minutes. Both of these turn the light off at the appropriate time.
Any one else experiencing this? Any ideas of what may be going on? Thanks!