Tamper alarms not being received


(John Watkins) #1

I’m not seeing any tamper (cover removed), from my AEOTEC, or ecoLink. I can see the alarmReports in the device Types, but I never see them come in.

is there something I’m missing?


Mydlink™ Home Door/Window Sensor DCH-Z110
(Kevin Tierney) #2

In ST, device types currently don’t have the ability to generate an alert directly. You’ll need a smart app to monitor the device and create an alert or text

Here are some threads where this type of issue is discussed


(John Watkins) #3

Thanks @kevintierney. I’ll review the previous postings. however, when I’m looking at logging for the device I’m not even seeing a Zwave event (shouldn’t I?). regardless of an actual push, or txt, or something…


(Kevin Tierney) #4

Yeah, it should at least be showing in the log, if the device supports it and the device handler has the code to log that event. Are your devices using device specific device types, or generic ones?


(John Watkins) #5

My test devices are the generic zwave motion/contact, at the moment. I wander if I need to add the catch-all to the parser, I didn’t see when I look earlier?


(John Watkins) #6

I got my not seeing events in the device handler figured out…

I added alarmv1, alarmv2 to the device handler and I get a change in value in my tile, and I see the events under activity feed.

I still haven’t been able to figure out how to subscribe to these events. i’ve tried the following subscribe settings, but I don’t see any events in my Smart App. I do see motion events, so I know that’s working…

    subscribe(motion,"motion", onMotion)
    subscribe(motion,"alarmReport", onMotion)
    subscribe(motion,"AlarmReport", onMotion)
    subscribe(motion,"alarmV2", onMotion)
    subscribe(motion,"alarmv2", onMotion)
    subscribe(motion,"sensor", onMotion)
    subscribe(motion,"alarm", onMotion)
    subscribe(motion,"notification", onMotion)

(Kevin Tierney) #7

What does your alarm create event look like? The subscription should look similar


(John Watkins) #8

def zwaveEvent(physicalgraph.zwave.commands.alarmv2.AlarmReport cmd)
{
def map = [:]
map.name = "tamper"
map.value = cmd.alarmLevel == 255 ? “tampered” : "secured"
if (map.value == “tampered”) {
map.value = "tampered"
map.descriptionText = "$device.displayName has been tampered with"
map.isStateChange = "true"
map.display = "true"
log.debug “tampered: $map”
}
else {
map.value = "secured"
map.descriptionText = "$device.displayName is secured"
map.isStateChange = "true"
map.display = "true"
log.debug “secure: $map”

   	}
createEvent(map)

(Kevin Tierney) #9

Try

subscribe(motion,“tamper”, onMotion)


(John Watkins) #10

You are the man @kevintierney! thanks for the help!

I got the Smart Things hub about 2 weeks ago, So I’m still learning the correlation between all the functions…


(Kevin Tierney) #11

Glad I could help. I still have much to learn and it’s much trial and error. In this case you had to subscribe based on the event name