[ST Edge] •• Tasmota Edge •• for Sonoff, Tuya & many other ESP WiFi & HTTP devices - over 2000 Tasmota supported devices

Any comments on this hongtat or do I need to find a work around ?

I figured this out - Error code ID10T - ( Self inflicted )

This was all caused by doing things out of sequence. That’s why I call myself a NOOB.

When you add the device to SmartThings using TASMOTA edge, it writes a massive rule to the device for reporting state changes to ST using WebQuery.

If you hork around with the TASMOTA configuration after that, the rule can get clobbered any number of ways

So the correct sequence is.

  1. Get the device completely configured.
  2. Add the device to SmartThings

I resolved the situation by deleting the device from ST and re-adding it.

No change. It’s probably a glitch on the ST app or platform.

I’ll take a look.

I think it could be on the Tasmota driver issue for the treatlife fan. Let me take a closer look first.

I don’t have a solution for it yet. I have to try adding a queue system for send, but it may not work for send & receive multiple code at the same time.

OK thanks for letting me know. As mentioned I do have a workaround. I’ll put it here just in case someone finds it useful.

At the moment I have a button for each blind but as mentioned that doesn’t work when you’ve got a routine calling 3 blinds to close at once as it tries to send 3 seperate close commands at the same time to the RF gateway. So I have to create a 4th blind which runs 3 commands one after the other.

So a single blind command looks like this rfraw AA B0 4C 04 08 1374 0262 010E 1388 38192A192A1A1A19292A1A19292929292A1A19292929292929292A1A19292A1A192A1A1A1A1A1A1A1A1A1A1A1A1A1A1A192A1A1A1A192A19292A19292A1A1A192A19 55

So instead I make a blind using this command (with Backlog in front and semicolon in between) … this allows you to run commands back to back. I use rfraw 0 2 or 3 times in a row between the main commands to act like a delay and it seems to work, so the new command to close all blinds together looks like this.

Backlog rfraw AA B0 4C 04 08 1374 0258 0118 137E 38192A192A1A1A19292A1A19292929292A1A19292929292929292A1A19292A1A192A192A1A1A1A1A1A1A1A1A1A1A1A1A1A1A1A1A1A192A1929292A192A1A1A1A1929 55; rfraw 0; rfraw 0; rfraw 0; rfraw AA B0 4C 04 08 1374 026C 0118 139C 38192A192A1A1A19292A1A19292929292A1A19292929292929292A1A19292A1A19292A1A1A1A1A1A1A1A1A1A1A1A1A1A1A1A1A1A1A192A19292929292A1A1A1A1929 55; rfraw 0; rfraw 0; rfraw 0; rfraw AA B0 4C 04 08 1374 0262 010E 1388 38192A192A1A1A19292A1A19292929292A1A19292929292929292A1A19292A1A192A1A1A1A1A1A1A1A1A1A1A1A1A1A1A192A1A1A1A192A19292A19292A1A1A192A19 55; rfraw 0;

Hope that’s helpful for someone. One thing to note is that about large commands is about all you can do before it gets too long.

Hi Tyler, I installed the Tasmota firmware on my Konnected Add-on board with ESP8266 Module on top. The Konneced board has 6 zones and an out). However in the Module Parameters Configuration (Generic (18)), there is only GPIO1, GPIO2, GPIO3, GPIO4, GPIO14. Is this correct?

Go into the template and change the GPIO to user and make them available .

This is what my template ended up looking like. I use a few more pins than a typical Konnected board owner.

Are you seeing all 18 GPIO options? If you see all 18 then you’ll want to set up your pins based on the the pins are used on your board. I found this map of board pin to GPIO numbers for your reference:

Hi. can you please add the dry mode to the virtual air conditioner.


All my Tasmota devices stopped working in Smartthings. They are still working through TasmoAdmin, and all other devices are working except Tasmota. Any problem with Tasmota Edge integration?


Please reboot your ST hub.

I’ll check.

Rebooted no success. But switched the driver to Zigbee then put back AwFullySmart Drivers and everything came back to normal.


OK so just in case it’s handy to another user again… I think I’ve found a better way work around needing a delay for each device if you’re using an RF gateway. With the new interface you can select a custom delay time, so I just set the second device for 2 second delay and third device for 4 second delay.

Would be nice still if there was some kind of built in delay when passing the commands to the gateway, but this seems to work well so far since it’s only trying to do one blind at a time now instead of all 3 together.

Thanks - that worked for me :slight_smile:
What settings are the best option to use on each GPIO for:
a) A Relay (for Sprinklers)
b) Door Sensor (open/closed)
c) Motion Sensor (motion detected/no motion)
d) Panic Button (momentary push)
e) Siren

Tasmota Edge Update!

  • Added support for WLED

Includes potential fix for Treatlife DS03 fan issue with Amazon Alexa and Google Home. @maranhao @Scapegoat - Please let me know whether it works for you.

Update will automatically be pushed and installed to your hub. Version: 2023.2.4


Thanks for looking into this! Looks like I’m still seeing the issue. I even tried adding a new fan:


I’m seeing the same issue. I don’t know if I need to delete the fan from my SmartThings application/hub and recreate it or not.



Quick quesiton for you.

You are using Rule1 in the Tasmota Device to configure event triggers.

Is it safe to use Rule2 and Rule3?


What app is that?
Does the default (sonoff ifan) show up correctly for you?

It’s better to use Rule3.

1 Like

The screenshot is from the Google Home App. Just did a quick test, looks like for the Treat life and for the iSonoff fan it only gives the “On”/“Off” switch without speed control in Google Home

Android Google Home App has only on/off, while iOS has on/off and wheel 0-100% for speed.

I believe you should be able to say “set living room fan to 100%”, 4 speed 25%, 50%, 75% & 100%.