[ST EDGE] SmartThings Edge Driver for Leviton VRCS4-M0Z and VRCS4-MRZ (Beta)

Hi harobinson

I am back, sorry for be absent these days.

It worked fine, now I am able to include correctly both vrcs4 using your driver and the internal load using defaults configurations. I think now you can edit the first post and include vrcs4-MRz as compatible. =D


Now I am trying to set up to sync with my switch and I thinkl I am doing something wrong.


I seted up to control this

But it is not working neither syncing with the led status of “Entrada Suite Master”. It just works if I add routine in automations , but the internal VRCS4 led never sync correctly.

Could you help ?

Thanks again

Maybe it’s just that I need to improve my documentation.

  1. The Synchronize switch button allows you to keep 2 or more VCRS4 switches synchronized. If selected, then turning on a button on unit 1 will automatically turn on the same button on unit 2. LEDs stay in sync.

  2. The Switch1, Switch2, … Switch4 devices are ONLY used to configure the ZWAVE association so that the dimming (button 5) can work on a device. Be careful because the Smartthings App Settings uses decimal values which the IDE uses hex values. And so, in your example, you would input 16 to correspond with the 0x10 of the the device. But again, this would only configure the dimming function.

  3. To connect the VRCS4 to the switches, I use automation to connect the buttons to the switches you want to control. If you have Sync on, then you only need to set up automations for VRCS4 unit 1 and it will be mirrored to any other VRCS4 that also have Sync selected.

I would love to somehow connect the Settings feature with Automation, but that is not possible with the Edge Driver. I am planning to investigate having a SmartApp/Routine to do so at the configuration step but have not had time to take this on.

Any suggestions as to improving the UI is very welcome. But you and I may be the only people who have staying with the VRCS4 as a device. It has served me well and I don’t plan to replace it until we have a better technology solution.

I hope this makes sense.

1 Like

Hi harobinson thanks again.

Is there some way to make led on VRCS4 turn on, when I press on my regular switch?

For example, If I set including in Automation VRCS4 button 1 to turn on/off the switch “Living Room”. It works fine if I press button 1 in VRCS4, the led on VRCS4 and lights turns on and off correctly. But if I press the “Living Room” Switch the light come on, but the led on my VRCS4 button1 doens´t.

I don´t know if I make myself understandable , any doubts let me know.

Let me investigate in next few days.


First thing to try:

Use SmartApps (under Automation Tab) Smartlighting. If you haven’t enabled Smartlighting, press the Compass on the upper right and scroll to find SmartLighting.

You can add a Routine to control the button with the switch using the action “Sync with Switch”. Right now I see that Smartlighting uses button names rather than labels, so select xxx button for the top button, and xxx switch2, xxx switch3, and xxx switch4 with the corresponding switch that you want to control.

I did a quick check but need to try this some more.

But tell me how it goes.



Just to see if I am going in the right place over UI:


My Smarthings UI is in portuguese and I am not able to change that. But tranlstion “Iluminação mais inteligente” is Ilumintaion more smart. I think should be that, there I am able to add routines

Now, the problems that I got with these routines:

Routine 1 - If I press the switch 2 in my VRCS4, then the lights “Living Room” tuns on/off. It is working fine , but only with this routine if I press the switch"Living Room" the led 2 in my VRCS4 doens´t turn on/off. As said before.

Then I add Routine 2 to make leds turn ON/Off - if I press the switch “Living Room”, to turn on/off the led in my VRCS4. It works, the led comes on, but my lights in “Living Room” get crazy, the problem is it is going in a looping then my “Living Room” lights is going to turn on and off no pressing anything. lol

If I exclued routine 1 and keep routine 2, the led 2 in my VRCS4 work fine pressing switch"Living Room", but without routine 1 the buttom 2 In my VRCS4 doens´t work if I press.

Then I concluded that this way is not possible to sync led in my VRCS4. I haven´t found any way to make it works correctly using Routines.

I seem to have a better approach.

Try adding the following, In Automations:

Assume that your controller is called VRCS4:

a) Add an automation,
VRCS4, Switch 1 …
Your switch (SWITCH)

b) If VRCS4 Switch 1 (ON), and SWITCH (ON)
THEN VRCS4 Switch 1 (ON), and SWTICH (ON)

c) Select “When any condition below is met”

a) Add an automation,
VRCS4, Switch 1 …
Your switch (SWITCH)

b) If VRCS4 Switch 1 (OFF), and SWITCH (OFF)
THEN VRCS4 Switch 1 (OFF), and SWTICH (OFF)

c) Select “When any condition below is met”

This seems to work for me.


The Smart lighting plug in has the ability to synchronize devices. Unfortunately and for reasons never explained, it is not available in all regions.

What you tried is not Smart lighting. In the English UI, it would look like this

Here is what I found about Smart Lighting. It seems to be designed around a Master switch and a slave device. Things work great if you simply want the slave switch to mirror the state of the Master switch. However, it doesn’t seem to work if you want both switches to be master (i.e. turning on on either device affects the other device).

That’s why I proposed the Automations in the subsequent message.

“Mirror” in the original smartlighting was originally designed specifically for two-way setups (called “three ways” in the US) so that they would stay in sync. To be honest, I don’t remember if that required two Automations or not. It may have changed over the years. But definitely you were supposed to be able to physically change either switch at the wall and have the other change its status (and its LED status light) to match.

That doesn’t mean that’s what it does now, of course. :thinking:

Here’s what I found during a quick test.

  1. Set up 2 automations. a) When any condition is met, if turn off switch 1 and switch 2, then turn off switch 1 and switch 2; b) When any condition is met, if turn on switch 1 and switch 2, then turn on switch 1 and switch 2. This seems to work well.

  2. Use SmartLighting actions: a) Device to Control (Switch 1), Action is Sync with switch, Select devices (Switch2); b) Device to control (Switch 2), Action is Sync with switch, Select devices (Switch 1). This seems to work.

  3. For either case 1 or case 2, use “On or off” to see if we can simply have 1 automation. Disaster: Switches flip between on/off repeatedly.

Case 1 seems to be the best option as labels are used instead of IDs and no need to add a plug-in.

1 Like

Thanks Haid, then I do not have this smartapp in my UI. =(

I would suggest that you try solution #1 that I suggested in previous message.

  1. Set up 2 automations. a) When any condition is met, if turn off switch 1 and switch 2, then turn off switch 1 and switch 2; b) When any condition is met, if turn on switch 1 and switch 2, then turn on switch 1 and switch 2. This seems to work well.

This doesn’t require a plug-in.


It works the same way as doing two Routines. You create two automations in Smart lighting, one with each switch as “master”.

Something Smart lighting can do which is not possible with Routines is to sync dimmers.

Would be nice if SmartThings staff would explain why access to Smart lighting is restricted.

1 Like

I like your approach using “any condition met” to do two-way sync. I have been using Smart lighting for this with two automations. But I’ve been striving to reduce the number of routines I have in Smart lighting since they don’t get listed on the Routines page of device details.

I also just discovered you can kind of do one-way mirroring/syncing with a single Routine using the “Turn on or off” condition and action.

As long as both switches start out in the same state, this causes the switch in the then clause to mirror the switch in the if clause.

I will retry turn on and off. My first experiment was flickering lights as the switches fought for control.

1 Like

Someone, maybe you, reported having the same issue trying to use Smart lighting for bi-directional syncing.

I only had that happen once or twice when one of the switches was turned on then quickly off. That got them in a loop. Repeatedly hitting off broke it out fairly quickly.

Not sure I’ll keep the on-or-off automation. This is for an odd case where I want one-way sync. Getting the two switches in opposite states seems liable to cause confusion.

Good Morning Guys

I made it work correctly, but I had to add 4 routines:

Routine 1: If button 2 in my VRCS4 activate then “Liviving Room” Switch is activate.

Routine 2: If button 2 in my VRCS4 desactivate then “Liviving Room” Switch is desactivate.

Routine 3: If “Liviving Room” Switch activate then button 2 in my VRCS4 is activate.

Routine 4: If “Liviving Room” Switch desactivate then button 2 in my VRCS4 is desactivate.

Now it is working correctly finally.

Just the dimming function in button 5 in my vrcs4 not works. I changed for 16 as said but not happening.

@harobinson thanks again by your Edge Driver.

1 Like

Great that you are making progress. Thank you for your patience.

For dimming, the function should work based on the last button you pressed before using dimming. Ie press button 2 and then dimming will be targeted on the switch that you configured with button 2.

Can you send me the logs that show the button press and the dimming activation?



Yes, I attempt for it but no works. I will send to you logs earlier. Do you want from smarthings-cli correct?