ST bonked my GoControl window "hard wired" sensors. Suggestions for new sensor?

My GoControl (Ecolink) window sensors now only report “open” as of 1 month ago…must have been a Hub update to a Edge driver or something. I use them in “hard wired” mode for my old legacy window sensor wiring. Since the problem is now one month old, I’m not sure a fix is in the works. And yes, I’ve chimed in on other topics related to this problem…I’m not alone.
Any suggestions for an inexpensive new sensor that can do “hard wiring”? Pretty miffed about this since I use 6 of these sensors. Buying 6 new ones wasn’t in my plan.

Can you define what you mean by “hardwired“ in this context? Were you using dry contacts on the go control sensors?

And is there a reason that (which does have a version that works with the new architecture and was specifically designed to bring legacy sensors into smartthings) doesn’t meet your needs?

Yes, dry contacts. And I have not looked into…I’ll take a look. But I’m curious why ST decided in the past month (or two) to not support this device.

Edit: ok, so would replace all my GoControl sensors…BUT, I have to buy it. Guess it’s cheaper than buying 6 new “supported” sensors, but doesn’t make me happy. I wish ST would just fix the driver.

Edit#2: thanks for the reply. You’ve always been a great resource to the ST community and I appreciate it. I’ve been around a long time (early V1 buyer), but my setup is pretty simple so I don’t usually check in very often.

1 Like

@philh30 and @csstup have drivers for Ecolink devices to that might work.

Another possible source for a driver would be @Mariano_Colmenarejo.

1 Like

Yes, I’ve read other posts about those drivers…but from what I can gather, it seems that all of them still have problems. I haven’t read of a driver that “works” consistently. Correct me if I’m wrong.

I am using a Driver from @philh30 and @csstup for my Ecolink tilt sensor and it works great. I am using the external contacts on that device. So I would give it a try. They may need to add your fingerprints.

Sigh…I’ve been gone too long from the community. I’ll need to look up what my “fingerprint” is and figure it out. But I’ve seen other folks with these same GoControl/Ecolink window/door sensors…seems like it may have been already added.

Does the sensor work just as a basic open/close sensor but fails when used for dry contacts? Or does it fail for both? And what DTH were you using before?

This device has two different ways of sending a closed message, and which it uses, depends on both the parameter settings and the association groups.

It would help to know the current values for parameter one and two as well as the association groups. You can find that out by using Mariano’s Z wave configuration driver. You will have to wake it up in order to get it accept reconfiguration. See the user manual available from the following page:

Here’s the configuration Driver:

The solution may be as simple as adding the hub to both association group one and two. There have been some problems with other stock Z wave edge drivers which were resetting values and not setting the association groups correctly. But I don’t know whether that’s what’s going on here, it just that it might be. :thinking:


Haven’t tried it with a magnet…I’ll give it a try tomorrow. I do have one that is stuck in “tamper” mode (I pulled the battery to test it. Replacing the battery left it in “tamper” mode).
Previously I used whatever default DTH was available…they just “worked”. Never had to fiddle with them.

Install both the Z-Wave Sensor Ph and Z-Wave Masquerade drivers from the following link and see if they work.

1 Like

Thanks. Ok, I tried both drivers, and both immediately made the sensor say “closed” (which is correct). I noticed the Sensor PH driver presents additional info (greyed out…“Illuminance and Temp/Humidity”). Although when I open a window, it still says “closed”, but I get a message that says “this device hasn’t updated all of it’s status information yet…check again later”. Don’t know if that’s a problem or not.
When I switched to the Masquerade driver, it behaves properly with state, but I don’t see a “tamper” section. Although, to be honest, I don’t care about tamper…the sensors are in a closet where no one would tamper with them.

1 Like

The error message “this device hasn’t updated all of it’s status information yet…check again later” can take several hours to resolve itself. So give it until morning.

Ok, I’ll try it. The Masquerade driver stopped working on all my sensors…they all show “open” again and don’t respond to physical state changes.

Sometimes after a bunch of driver changes you need to reboot your hub.

1 Like