Smartthings+Echo+Harmony Hub = Voice Controlled TV! (2016 version)

Turn on and Turn off works fine on activities for me. Just that sometimes alexa throws a “hmm smartthings is not responding right now” sometimes.

Its not consistent ATM

The integration seems to be fine after I did re-authentication via the smartphone app. Did you try that ?

thanks for the update. This must have changed at some point. This was not the case when the Echo / Smart Things integration was first introduced.

Alexa seemed to be ignoring me earlier, I was able to turn the activity on but turning off was a different store. I gave the turn off command, she was listening and then the light turned off. No confirmation, error, or problem with ST.

Got my Echo Dot last week and set it up to work with SmartThings and Harmony pretty seamlessly.

A few days ago, the Echo started acting up and no longer responded to certain commands. Things like “Turn on Netflix” or “Turn on Hulu” (which both tuned to the FireTV and then used the search function to pull up the specific app) were met with just a dull tone from Alexa (no “OKAY” or “ST is Not Responding Right Now” response). Additionally, no commands are passed over. Some of my network TV commands like “Turn on NBC” or “Turn on ABC” also fail in the same way.

However, commands like “Turn on the Receiver” or “Turn on the AppleTV” continue to work correctly - passing the command through ST to the Harmony Hub, with proper inputs, channels, etc.

What’s more, I can create a group that contains the “discovered” Netflix SmartThings Device within the Smart Home settings in Alexa, and the command is passed correctly.

So, essentially, I can get the commands work - but no longer with certain device names (although these device names did originally work as expected). I can also use the devices/commands in question within the ST app on my phone (i.e. Selected “Netflix [Harmony Activity]” and turning it on, runs the Harmony activity correctly) - so it definitely seems like this issue is with Alexa not passing the commands on, or at least Alexa and ST not communicating correctly.

Has anyone had a similar issue? Is there a workaround that would allow me to use the actual ST device/harmony activity names as the Alexa command? Does anyone know if Amazon instituted a set of “banned” words like Netflix/HULU since last Friday, that preclude them from being used in commands (perhaps they’re working on integrating those services as new skills…)?

FWIW, the Echo and ST hub were both installed/activated last Friday. ST is running 000.014.00032 and Echo is on 3202.

I know it’s really annoying. :rage:

Other people have reported the issue, but it’s not clear whether it’s the ST or Amazon side. For now, put the device into a new Echo group (using the Amazon app, not ST) and experiment to find a name Alexa will accept.

For me, at least, “Netflix” is not working and putting it in a group named Flix doesn’t work, but putting it in a group named “Flicks” does work. I didn’t change the activity name in harmony, just the group name in Echo.

People are posting more workarounds in the following thread:

1 Like

Is it possible to have ST execute a single button from the Harmony Hub? For example, I want to be able to say “Alexa, turn on Mute” and have ST turn on a switch that simply executes the Mute button on my receiver via Harmony Hub. I’ve been able to set up series of commands like turning on my receiver, DVR and TV this way, but not single buttons.

You have to first create a Harmony activity that does exactly what you want, in this case probably as a “step.” The exact method will depend on your home theater set up, whether the sound comes from a sound bar or the television or whatever.

Then once you have the activity, you can start it with the usual method using Echo.

So it’s clunky, but doable.

Here’s mine. The sound on mine comes from the television, so I select that as a device and assign the Mute command for the step.

.

i’m having the exact same issue. when i tell alexa to turn on “watch tv,” she just makes a ‘bing bong’ type sound and nothing happens. but turning the activity OFF through alexa works… i don’t get it.

ok after a few hours i was able to fix things. basically what i did was unlink smartthings from alexa, forget the ‘watch TV’ device from alexa, remove then re-add harmony to smartthings, and remove/readd smarthings to harmony…

then i changed the ‘watch tv’ name in smartthings to a new name just called ‘tv’ … added it back to alexa, and voila, alexa turns it on/off again.

i think maybe for some reason the previous ‘watch tv’ device name in alexa was screwing it up for some reason. so try renaming your harmony devices in smartthings then add them back to alexa and see if that helps.

1 Like

Not sure if this has been discussed before or if anyone else is having this issue. I followed all of the instructions in setting up the harmony hub. I then added the hub successfully in ST. However, I already had ST setup in Alexa, and when I went to ‘discover new devices’ the harmony hub nor any of it’s activities showed up. Additionally, when I unlinked ST from Alexa and readded it, none of the harmony activities still showed up. Any advice?

Seriously, check out Yonomi. It’s integration with Echo and Harmony is far superior from a performance and configuration perspective.

1 Like

Speaking from personal experience :sob:, did you add the harmony activities to the Amazon Echo smartapp? ‘marketplace / smartapps / Amazon Echo’ add harmony activities to switches group then have Alexa discover devices. I wasted a couple of hours before i remembered that step i the process.

Hi Jack:

Can you explain your anymote setup? I assumed you had to have an anymote blaster for this to work unless you have a phone that has IR correct? Otherwise how can you connect to harmony and or Alexa?

All of my home theater equipment are connected to my wifi, so I don’t need to use a blaster. Anymote can send signals through wifi and/or IR. If you need to IR blast you can either use your phone (if it has one) or Anymote sells a blaster.To connect Alexa to Anymote you go to the skills tab on your alexa web page. Search for Anymote and check the box. You then go to your anymote app and it will give you a password to say to Alexa. Then they are connected.

thanks for that detailed explanation. I already have 2 harmony hubs that I’m not very pleased with due to the fact that you can’t enter individual channel numbers through alexa, and do simple things like changing inputs

I wish the anymote app could connect directly through a harmony hub to control my tvs and cable boxes…there’s an option to connect directly with an ip but couldn’t get it working

I have both the Harmony Hub as well as the Harmony Smart Control, which also contains a Harmony hub although they do appear to be different part numbers (they look identical). Based on as much research as I can find, it looks like I can integrate the first but not the second with ST.

Is this correct? I don’t want to be spinning my wheel trying to get the Smart Control Hub to work with ST if it can’t.

I have the same scenario, my question is will smartthings use two hubs?

I would ask support. It’s an official integration, but I just don’t know what the current status is regarding multiple hubs.

Poltergeist situation with my goodnight routine, I have it set to turn off all devices yet turn on master bedroom tv. It was working for a while, and now as I run it now, it turns the tv on, and then before I get upstairs I hear it turning off. Anyone know what is going on?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.