Smartthings+Echo+Harmony Hub = Voice Controlled TV! (2016 version)

This thread is a few months old, hope you’re still out there, had dome something similar except I have a basic startup activity to get the tv on and then separate activities for each channel change with just the STB as the device, not including the tv. Do you see any advantages to including the tv in each activity, and if so what and what are the power settings for the tv so it doesn’t turn off between each channel change?


Try Anymote for android or ios. The app is free . Just enable it on the Alexa web page. It can use either IR blast from your phone or connect to any device on your LAN. The commands are little wordy. But it works. Control TV , DVR etc. Changing channels you can’t say 2.4.5 or 2.45, you have to say two hundred and forty five. So it goes like this: Alexa, tell anymote to channel two hundred and fouty five on my dvr. That’s a lot of words. But for on/of pause play guide. it works well I’ don’t use the IR from my phone . All my devices are connected to my LAN.

I had the same setup working till 2 weeks ago, Now telling alexa to turn on the TV does not do anything. Do I need to delete and re-add the activities?

Any one else facing this issue after the last system wide blowout of smarththings?

1 Like

I have the same problem. Alexa says “ok” and smartthings app show as on but nothing happens. I have to use the Harmony remote to turn TV on or off. I also tried setting up an IFTT between alexa and harmony and still nothing.

I’m having issues too. I have activities set up so I can tell Alexa to turn on HGTV or some other channels… Now I either get ok, or Smartthings isn’t responding. The inputs set correctly but the channel changes aren’t sent. - grrrrr

So it seems like a widespread issue after the scheduler change and all this week. Anyone from smartthings care to comment on this ? @thegilbertchan ??

This fixed it

Had the same issue. I removed then re added Smartthings to Alexa which didn’t fix the issue. Then I realized that Smartthings was not communicating with my Harmony. The fix was removing the re adding Smartthings to my Harmony, then reauthorizing Smartthings to communicate with the Harmony through the Harmony app. Once that was done I removed and reauthorized Smartthings hub and the associated devices in the Alexa app. Everything worked after that.

Thanks , the re-authentication fixed it. Anyone having issues probably needs to open harmony connect and re-authenticate the credentials

Question: Can you turn off the activities by using the same command as turning the TV on? For instance, can i say, “Alexa, turn on the TV” and then say, “Alexa, turn off the TV”. ? I was under the impression that the ECHO wasn’t able to turn off the Harmony activity once it was on using the same name? If saying, “turn on the TV”, starts the harmony activity, then saying turn off the TV would try to turn ON the same activity. Am I wrong here?

When the integration is working properly, you can tell her to turn activities on and off.

Turn on and Turn off works fine on activities for me. Just that sometimes alexa throws a “hmm smartthings is not responding right now” sometimes.

Its not consistent ATM

The integration seems to be fine after I did re-authentication via the smartphone app. Did you try that ?

thanks for the update. This must have changed at some point. This was not the case when the Echo / Smart Things integration was first introduced.

Alexa seemed to be ignoring me earlier, I was able to turn the activity on but turning off was a different store. I gave the turn off command, she was listening and then the light turned off. No confirmation, error, or problem with ST.

Got my Echo Dot last week and set it up to work with SmartThings and Harmony pretty seamlessly.

A few days ago, the Echo started acting up and no longer responded to certain commands. Things like “Turn on Netflix” or “Turn on Hulu” (which both tuned to the FireTV and then used the search function to pull up the specific app) were met with just a dull tone from Alexa (no “OKAY” or “ST is Not Responding Right Now” response). Additionally, no commands are passed over. Some of my network TV commands like “Turn on NBC” or “Turn on ABC” also fail in the same way.

However, commands like “Turn on the Receiver” or “Turn on the AppleTV” continue to work correctly - passing the command through ST to the Harmony Hub, with proper inputs, channels, etc.

What’s more, I can create a group that contains the “discovered” Netflix SmartThings Device within the Smart Home settings in Alexa, and the command is passed correctly.

So, essentially, I can get the commands work - but no longer with certain device names (although these device names did originally work as expected). I can also use the devices/commands in question within the ST app on my phone (i.e. Selected “Netflix [Harmony Activity]” and turning it on, runs the Harmony activity correctly) - so it definitely seems like this issue is with Alexa not passing the commands on, or at least Alexa and ST not communicating correctly.

Has anyone had a similar issue? Is there a workaround that would allow me to use the actual ST device/harmony activity names as the Alexa command? Does anyone know if Amazon instituted a set of “banned” words like Netflix/HULU since last Friday, that preclude them from being used in commands (perhaps they’re working on integrating those services as new skills…)?

FWIW, the Echo and ST hub were both installed/activated last Friday. ST is running 000.014.00032 and Echo is on 3202.

I know it’s really annoying. :rage:

Other people have reported the issue, but it’s not clear whether it’s the ST or Amazon side. For now, put the device into a new Echo group (using the Amazon app, not ST) and experiment to find a name Alexa will accept.

For me, at least, “Netflix” is not working and putting it in a group named Flix doesn’t work, but putting it in a group named “Flicks” does work. I didn’t change the activity name in harmony, just the group name in Echo.

People are posting more workarounds in the following thread:

1 Like

Is it possible to have ST execute a single button from the Harmony Hub? For example, I want to be able to say “Alexa, turn on Mute” and have ST turn on a switch that simply executes the Mute button on my receiver via Harmony Hub. I’ve been able to set up series of commands like turning on my receiver, DVR and TV this way, but not single buttons.

You have to first create a Harmony activity that does exactly what you want, in this case probably as a “step.” The exact method will depend on your home theater set up, whether the sound comes from a sound bar or the television or whatever.

Then once you have the activity, you can start it with the usual method using Echo.

So it’s clunky, but doable.

Here’s mine. The sound on mine comes from the television, so I select that as a device and assign the Mute command for the step.


i’m having the exact same issue. when i tell alexa to turn on “watch tv,” she just makes a ‘bing bong’ type sound and nothing happens. but turning the activity OFF through alexa works… i don’t get it.

ok after a few hours i was able to fix things. basically what i did was unlink smartthings from alexa, forget the ‘watch TV’ device from alexa, remove then re-add harmony to smartthings, and remove/readd smarthings to harmony…

then i changed the ‘watch tv’ name in smartthings to a new name just called ‘tv’ … added it back to alexa, and voila, alexa turns it on/off again.

i think maybe for some reason the previous ‘watch tv’ device name in alexa was screwing it up for some reason. so try renaming your harmony devices in smartthings then add them back to alexa and see if that helps.

1 Like