Smart Outlets not connecting

Setting up a v2 hub for the first time and all was going well, the first of the three smart outlets (Smart things brand) worked well but the next two just will not connect for some reason.

Have run the “connect new device” wizard a dozen times with no joy
Tried searching for the specific device with the same results.

Just power cycled my phone and still seeing the same “looking for new things” message.

Any ideas? Hard to believe two of the three outlets would be defective out of the box.

Power cycling your phone won’t help, power cycling the hub and the device you just paired might help. I’m not sure how far away your are trying to pair the outlets but try to do it in the same room, if that works then move them to where you want them. If all else fails support@smartthings.com

Just tried that and now the device that was working is no longer working :frowning:

Are these the v.2 outlets?

If so, try resetting them using this procedure:

  • Unplug the unit
  • How down the button
  • While holding down the button, plug in the unit
  • Release the button about 1 second after plugging in

After doing this try pairing again. My v.2 smart outlet wouldn’t pair after first but after resetting it paired fine.

2 Likes

@chrisb Thank You! That seemed to fix the problem!

Nice! This solved my problem too! Thanks

Thanks so much. Same problem same fix!