Setting the Geolocation in the SmartThings App for Samsung Smart Tumble Dryer

I was having the same difficulty as many others in setting my Geolocation (address) in order to use the functions of my new SAMSUNG Series 6 OptimalDry DV80T5220AW/S1 Wi-Fi-enabled 8 kg Heat Pump Tumble Dryer – White. (S/N: 0VG65AEW600081D), & I was growing increasingly frustrated every time I tried to set it.

I initially looked on the boards & whilst I read that many others were having the same issue, nobody had found a fix at that time. So I contacted Leslie via Chat Support at Samsung online when registering my dryer for warranty purposes.

I explained to Leslie that I recently bought a SAMSUNG Series 6 OptimalDry DV80T5220AW/S1 Wi-Fi-enabled 8 kg Heat Pump Tumble Dryer – White. (S/N: 0VG65AEW600081D) & that I had linked my new appliance with the SmartThings App on my mobile phone. The SmartThings App came pre-installed on my phone & is already linked to my Samsung Smart TV with no issues. However, I could not set up my ‘Geolocation’ as required in order to avail of certain tumble dryer functions. I outlined the problem to Leslie as follows:

Under the tab: Tumble Dryer/Remaining Laundry/Going Out Mode:

When I toggled the button for ‘Going Out Mode’ to the on position, a pop-up appeared on-screen telling me to set the location of my dryer to use ‘Going Out Mode’.

When I clicked on ‘set’ it brought me to the page which shows a map, radius area & the option to cancel or save. (I attached a screenshot). Despite the fact that the location marker/arrow was directly pointing to the location of my house, the app told me: ‘Unable to save. Address empty’. (Again, I attached a screenshot). Obviously, the address is not empty but no matter what I did it would not recognise my geolocation & save my address.

I tried to manually search for my address using my Eircode which is the most accurate means of locating an address in Ireland, & every possible connotation of my address that I could think of – no joy. The app still wouldn’t recognise my address, despite the fact that the map clearly showed the name of the area I live in & other buildings/businesses in the area. (I attached another screenshot).

Having paid €829.98 for a smart dryer expecting to be able to use all the functions available I was most disappointed & felt it really was not good enough, that the SmartThings app, used to control Samsung smart tumble dryers, did not work effectively so that ALL functions of the dryer could be activated by the user.

Unfortunately, Leslie was unable to provide a solution, but she did give me the email address to contact customer support specifically for the SmartThings App.

I sent an email outlining the above with several screenshots to & opened a ticket to find a solution to the problem.

Next, I received an email from Customer Service at SmartThings which stated that they had received my query & aimed to respond to me within 3 working days. Depending on the query, the support team required access to my SmartThings account in order to provide a resolution. You have the option to allow or deny access to your account to help resolve your query – however if you deny access, they can only provide you with limited support.

I allowed the support team access to my SmartThings account by giving them the registered email account of the Samsung Account I use with the SmartThings App & I followed these steps to grant the SmartThings Support Team with access to my account for the period of 1 week in order to give them time to resolve my query:

Go to SmartThings Web online:

  • Log in to your Samsung Account.
  • Select the Menu (⋮) & choose Settings.
  • Toggle on Account Data Access.
  • Select the time period & choose Confirm.

If the support team are unable to investigate your request during the time period that you have selected for account access, they may need to ask you to extend it so that they can resolve your issue.

Over the course of the last 8 days, Alex from SmartThings Support has helped to find a ‘fix’ for the problem. He initially contacted me requesting the following information, as first & foremost, you will need to ensure that your phone works with the SmartThings App & appliance:

  • Phone make & model.
  • Phone operating system version.
  • SmartThings App version.

Obviously, you will need to ensure that the latest version of the app is installed on your device; you can do this within the SmartThings app by:

Tap the 3 lines at the bottom > tap the gear icon in the top right corner > tap about SmartThings.

Here it will state if the latest version of the app is installed on your device; if not you will need to install an update from your app store.

I provided Alex with the information he requested & in this instance, all was in order. My phone, the SmartThings App & my appliance were all compatible & the latest version of the app was already installed on my device.

Alex contacted me again stating that he was going to escalate this issue for it to be looked into & that as soon as he had an update to share, he would get back to me.

He came back to me with the following information:

  • Check that all location data service settings are enabled on your phone.

  • Also, make sure that location services are enabled for the SmartThings App as well (Tap the 3 lines at the bottom of the app > Tap the gear icon in the top right corner > Tap Get your location from this phone).

  • If all of the settings are enabled, scroll around the map to check if the app can find other addresses.

  • If the app still cannot identify the correct address, please generate & send us dumpstate logs straight after trying this by following the below steps:

  • Open the Phone app > Enter *#9900#

  • Run Dumstate/Logcat > (Wait until the dump result pop up)

  • Copy to device storage (Include cp ramdump) > (Wait until the copy is successful)

  • Send that log file to SmartThings Support in your email response

… they will keep an eye out for your response.

I am now able to set the Geolocation in the SmartThings App.

All location settings were enabled on my phone/device; however, location services were NOT enabled in the SmartThings App itself. Please note that the app did NOT request permission to access my location or request that I enable location permission when I was trying to set my geolocation. It did not request that I enable any app permissions in order to use the functions available or to set the geolocation.

That is probably where the issue lies for the majority of users that are experiencing the same problem I imagine. Like me, I expect the majority of users that were having this issue thought that connecting to Wi-Fi, pairing to their appliance & enabling location settings on their device should allow them to set their geolocation. However, this will NOT work unless the SmartThings App itself has been allowed access to your location settings. Perhaps the app seeks permissions immediately after downloading & installing on a device (I don’t know as it was preinstalled on my phone - without permissions enabled) & if not set at that point they have to be enabled later by the user but they may not be alerted to the fact that this is required.

The SmartThings app itself did not request permission to access my location in order to set my address or geolocation, it just kept saying ‘unable to save. address empty’, instead of requesting that I give the SmartThings app permission to access my location all the time. Also the fact that the address/geolocation has to be set under two separate headings on the App adds to the confusion, i.e. ‘Get your location from this phone’ & under ‘Going Out Mode’ under ‘Remaining Laundry’.

If the user clicks on the ‘Remaining Laundry’ tab before ‘Get your location from this phone’ it says ‘set the location of my dryer’ to use going out mode, Then when you click on ‘set’ it brings the user to the page which shows a map, radius area & the option to cancel or save. Then despite the fact that the location marker/arrow may be directly pointing to the location of the users house, the app will display a message reading ‘unable to save. address empty’. Searching for an address will also be pointless - further frustrating the user. This presumably occurs because the SmartThings App location permissions have not been enabled on the users device, as the user is not made aware that it is required because there is nothing to alert them to that fact.

I contacted SmartThings Support to advise them that their ‘fix’ had worked & I received a further email with more advice from Keith at SmartThings Support.

He gave me the following link which he said may be helpful as it explains some of the things, I’ll be able to use SmartThings for:

IMPORTANT: Whilst it doesn’t mention it in the link above, the ‘Smart Control’ feature needs to be turned on each time you turn on & load the machine. Further information regarding the ‘Smart Control’ functions is available on page 38 of the appliance manual.

‘Smart Control’ is enabled by pressing the same button you use to initially connect the appliance to Wi-Fi, but this time you won’t have to hold it down for so long – just until the icon appears on the digital display of your tumble dryer. ‘Smart Control’ turns off automatically when a cycle finishes; or, if you have ‘Stay Connect’ enabled in the app, when the door is open. Apparently, this is a safety feature to stop the possibility of a child, for example, entering the drum before a cycle is started remotely. Without the ‘Smart Control’ being enabled, you’ll have limited control via the app.

Also, on a different issue, depending on where you purchased your dryer from, it may qualify for a free five-year warranty if it’s listed as a qualifying device – search fiveyearwarranty on the Samsung website.

This page is from the UK website, however, it does state in the terms & conditions that purchases can be made in the ROI, & there’s a number for ROI claimants as well (0818 717 100). Please make sure that if you have purchased from a participating store, that you claim within 90 days of the purchase.

So, I hope that this may be of benefit to any reader who encountered the same difficulty as I did in setting the ‘Geolocation’ in the ‘SmartThings App’.

However, if you’re still experiencing difficulties contact the guys at SmartThings Support for further information – they provide an excellent service & are quick to respond to any queries in a clear, concise & timely manner. Just follow the links above or email the address noted above.