Rule Machine - Get peer assistance here with setting up rules

Jason helped me create a virtual switch called party disable for my doors and push notification. So I turn on that VS and I do not get all the alerts of people running in and out. Works like a charm.

This is how I would do it…

Create a virtual switch called party mode.

Create this rule in rule machine -

Conditions - virtual switch on
Rule - virtual switch on
Actions for true - set mode: party mode, adjust thermostat, more people means house is warmer), turn on deck lights, turn on party lights, pretty much whatever I want to happen in this mode.
Conditions for false - set mode: party clean up mode, turn on all of my lights, turn off music, stuff like that to help with clean up.

Depending on how you have the system change modes, I use rule machine, I would have this virtual switch disable all other mode changes when on. You don’t want an unexpected mode change to occur in the middle of the party. Disable rules that turn lights off/on in common areas of the pastry.

Authorize Alexa control of the virtual switch and just tell her to turn on party mode.

I use a trigger rule to change my modes. I have a momentary virtual switch as a manual option as well.

So, earlier this week I posted about us moving into a new place and how tired and dumb I was…with your help I got my hall working…but…today husband has a hissy fit. We have a very long dark hall. I installed a GE dimmer wall switch. I set up a rule that if any of 3 motion detectors have motion the hall light comes on for 1 minute at 20%. Working great…till…husband is working in the utlity closet in that hall. 20% is not enough light to work…he keeps turning on the switch on the wall and upping the brightness, but rule machine kept turning it either off or dimming it. So how do you temporarily deactivate a Rule? I ended up deleating the rule. Thanks

For this, the best way would be going into the Rule and going to the bottom of it. There is a spot for “Switch to Disable Rule”.

Set up a Virtual Switch and assign it to this. Then whenever you need to bypass this rule, you can just turn that Virtual Switch on and Rule Machine will leave you alone.

If you have an Amazon Echo, you can voice control this and make it easier. Otherwise, you can just pull out your phone or tablet and turn it on real quick.

Oh dear, looks like I now need to learn to do a virtual switch… will HAVE to be Echo or husband will never “get it” … have sticky notes all over the house right now with Echo prompts for hubby. Anyone know a good set of virtual switch directions? Thanks

Here you go.

1 Like

I had almost this exact same situation with a GE dimmer.

I found the non neutral dimmer to be very slow at refreshing the hub when it is physically pressed.

This is how I fixed it…

Step one -
In rule machine, under the custom commands section, I went in and created the custom command refresh().

Step two -
Create this rule (trigger)
Trigger activity - any (I used all) motion sensors active.
Actions - run custom command: refresh() on GE dimmer switch

Step three -
Create this rule scenario -
Conditions - physical press on: GE dimmer switch
Rule - physical press of GE dimmer switch
Actions for true - set private Boolean of (choose your hallway lights rule) to false.
Actions for false - set private Boolean of (choose your hallway lights rule) to true

Step four -
In your hallway lights rule, turn on the “disable with rule Boolean false” option under restrictions.

Using this above when you physically turn on the light it will disable the hallway lights rule. Once one of the motion sensors is activated (I use every one in my house) the refresh rule is run, the hub is updated, and the private Boolean is changed. Just physically turn off the light switch when done to reactivate your rule.

Or, you can do it this way…

Put a contact sensor on the highway door and create this rule…

Condition - door contact opens
Rule - door contact opens
Actions for true - set private Boolean: hallway lights rule to false, dim hallway lights to 100%.
Actions for false - set private Boolean: hallway lights rule to true.

Do not set a dimmer level for false. Once the private Boolean goes back to true and a motion sensor in that rule goes active, the lights will dim.

Can’t you just put a contact sensor on the utility closet door with a seperate Rule in Rule Machine that sets the dimmer @ 100%?..or a motion sensor in the utility closet with the same dimmer logic?

I do this for my hallway closets.

Wow!!! You guys are great…I am learning so much.

1 Like

All of this assuming you’re using Rule Machine…

Not sure which route you want to go but if adding a contact sensor or motion sensor to the closet than be sure to use either method as the override to your motion rules for the hallway…so that if in closet it cancels out the motion off command in the hallway.

Hope that made sense…if not feel free to PM me or reply here.

I think I will use a switch on the door. I am using Rule Machine… not sure exactly what you meant by over ride… and I actually need to go look up the word Boolean to be sure I remember exactly what it means… getting old… sigh!

I’m not “getting” old…“I AM…” lol.

…at least that’s what my bum knee tells me.

I am sorry, my verbiage may have confused you. Disable…

Put your closet door contact sensor in the field where I have the “Harmony - Virtual Switch”

Here’s an example:

I have 3 R.M. rules setup for a Aeon minimote. 3 of the 4 buttons have a unique rule setup. Recently when I press any or the 3 buttons with rules setup, all three actions fire ie: push button 1 it acts like I pushed buttons 1,2 and 3 at the same time. Any suggestions?

OK, here’s my goal. I have a rule that will disable my alarm when I unlock my front door.
I am trying to add an action that if the lock is opened during lunchtime M-F, to set the boolean true,
and then a second rule that if the boolean was true and the lock is locked, to arm the alarm again.
It seems like the action is the part that isn’t working correctly because the boolean stayed false.

https://imgur.com/Vq0DX1V

https://imgur.com/dKFzlpL

https://imgur.com/gONcmEF

Hi All,

I need a little help with Rule Machine.
I have 2 rules that set the color and dim level of 2 Hue lights. One sets them to Red 20% and runs when the “Good Night” routine executes and the other sets them to Warm White 80% when “Good Morning” runs. My problem is that after these rules execute the lights stay ON and I want them OFF.

First I tried creating “Turn off after color change” rule that has “Good Night” or “Good Morning” as a trigger and delay, with action to turn off the lights. This approach kind of worked, but not very reliably. It seems like the delay didn’t work and the “Turn off” rule some times was getting executed before the “Color change” one.

Next I tried creating a “Turn off” rule that executes on “Rule truth” condition, putting the “Color change” rule as the condition. My idea was that this will chain the rules and “Turn off” will always execute after “Color change”. That didn’t work. I don’t see the “Turn off” executing at all.

Now, there may be another issue - originally when I created the “Color change” rules I was using older version of Rule Machine. Now I updated to the latest version and I don’t see the “Routing run” as an option in the triggers. I’m not sure what happened and why it was removed, but for my case mode change is not equivalent and I can’t use it. For example “Good morning” routine changes the mode to Home, but so does “I’m back”. I don’t want the “Color change to Warm White” rule to run when mode changes to Home, I only want it when “Good morning” runs.

I still have my “Color change” rules created with the old version and they work on routine run, but I deleted my “Turn off after color change” rule that was depending on the same trigger and can’t re-create it because the routine run is missing from the available triggers.

I am looking for ideas how to switch off the bulbs after color change, or how to change the color and dim level without turning them on.

If somebody is wondering why I’m doing this color change twice a day - it is because if I put it with the motion activation of the lamps, the first time when they have to switch between white and red (the first time there is motion after “Good Night”) the bulbs turn on white and then change to red, there is a brief white flash before the red and I find that very annoying.

I have been searching and I’m having trouble figuring this out and hoping it can be done easily. I have a group of GE Link bulbs that I want to group together and dim them using a virtual dimmer. What is the simplest way to do this with Rule Machine?

Last night I set up similar rules in Routines, Rule Machine, and SmartRules to try and see how they compare for execution and reliability. The Routine one executed fine, but Rule Machine and SmartRules did not. Is this due to some misconfiguration by myself, or performance/reliability issues with ST? For now I’ve just configured the latter to for a push notification action.

Note that I did have the 15 minute delay set for all three, and I’ve heard that there is a limit to the number of delayed actions, so maybe that messed it up?

Here is how it is configured now:

[quote=“Ducky, post:864, topic:29577, full:true”]What is the simplest way to do this with Rule Machine?
[/quote]

The screenshots posted in the thread I’ve linked below show a compact and efficient approach to that. I have a bunch of these rules. They’ve been working well for me. To the extent that the platform is working, of course.

Hi all,

Would love to get some assistance. I have a rule specified that sets my Lynx alarm, turns off lights, etc. when I leave the house. I’ve noticed that the Smart Home Monitor keeps (somehow?) getting reset back to “Disarm,” which changes the presence for my mobile phone to “present” even though I’m not in the geo fence. It’s causing the rule to run about every 2 hours, which isn’t a huge issue except that it just seems really redundant.









Has anybody else experienced this? I thought I read that the SHM thing was kind of glitchy, so that could very well be the culprit, but starting my debug here.

Thanks!

I have what I think is a basic issue but can’t seem to think it through.

1 rule monitors all doors/windows when in Night or Away mode and if any open, send a “Security Breach” text to me
Another rule checks all doors/windows so when the mode is changed to away, send a “A Door or Window is open” text to me, so when we are leaving, it will remind us that we left something open

Issue: Physically verify all doors/windows are closed, mode changed to away via a Routine, no texts, good so far
If a door or window is open when in the away mode, I get a text from both rules.

Seems like I need the first rule to run only once when the mode is changed to away and have it reset once the second rule changes from away to home

What am I missing?

Rick