Rule machine - as per the app developer, this app is no longer available for new installs, distribution, or support

you can do that with the top option in actions. Set a delay there then configure your custom command

So if I want the lights to come on at exactly 6:00am would the end time be 6:00am also?

First of all, don’t use 6:00 am if you want it to actually work; try something a few minutes off the top of the hour. This is due to ST scheduling problems.

If you just want something to happen at a certain time, use a Trigger, and the Certain time trigger event.

I was thinking setting the delay at the command level and not globally for the Action, just like the switches have an option to delay the on/of of the switch.

That must have been it! I was defining it as a Rule where I should have been thinking / using a Trigger. No strange error messages and the rule is working and not disappearing. So far so good - I will do several more tonight and see if everything holds. Thanks again for the great product!

Need some help constructing a basic virtual 3-way switch recipe (based on a simple trigger) with a pair of commonly used devices recommended on these forums. This would be to essentially replace the functionality of the basic ST Smart Lighting App. I have been struggling for a couple of hours with inconsistent results on my own so I turned to this forum. Once I get this working (assuming its possible & works) I will post the results over in the Show Your Rule Machine Automation Thread.

Actual switch that toggles the load = 2gig WD500Z-1 Z-Wave Wall Dimmer

“3-way” switch (no load, just a dimmer switch that acts as a trigger) = Linear Z-Wave 3-Way Wall Accessory Switch - WT00Z-1

So basically I am trying to figure out how to create an optimal Rule that uses the WT00Z-1 Wall Accessory as a true on/off and dim up/down “remote switch” for the actual WD500Z-1 dimmer switch replicating the functionality of the Smart Lighting app but with the additional power & capabilities of Rule Machine.

Unless I’m missing something about your setup, it isn’t possible to get separate events from the accessory switch. Only the main z-wave switch is visible to ST, and reports events to ST. Usually, the accessory switch tells the main switch that something has happened, and then the main switch reports an event to ST. But, there is no distinction as to whether the event came from the accessory switch or the main switch.

The WT00Z-1 “Accessory Switch” is a fully independent z-wave device that is discovered and functional as a trigger. It’s basically an up/down trigger that has no inherent relationship to the “parent” WD500Z-1 dimmer. Here is a picture from the Rule Machine Capability Test - “Kitchen Desk 3W” is one of my WT00Z-1 accessory switches. It is instantly discovered as a dimmer switch by ST.


Ironically it was easy to integrate this ZWN-SC7 Enerwave 7 Button Scene Controller into Rule Machine which requires a custom device handler. The thread for setting it up is here. It was very easy to assign one of the 7-buttons on this device as a simple on / off toggle using a rule. The WT00Z-1 is essentially a single button (up/down dimmer actually) z-wave trigger.

Lately I’ve had issues with lots of rules not firing, even when based off motion triggers. Going in and re-saving the rule causes the action to fire off immediately and work fine for a free hours or maybe a day.

I have created a rule to update a few rules, but it seems weird that I’d need to target these non-scheduled rules. I haven’t updated my RM version in a few weeks, so my gut tells me it’s the infrastructure like usual.

Yes, a rule is evaluated when you hit Done (but not a trigger). ST’s system failures and shortcomings impact is hard to fathom, hard to diagnose, and generally a PITA.

There is no reason you should have to update a rule that has no scheduled events. Look at your rule in the IDE / My Locations / List SmartApps / click on the rule. You can see it’s device subscriptions there. You can also use Live Logging in the IDE to watch the events from one of your motion sensors, and to watch the rule report those events (or not).

it happens to me. my rules are not firing or it is firing after long time. i am always checking every time if the rules are fired if not i am doing it manually.

May this is issue with ST servers…

Is anyone having a problem creating new commands in “create custom commands”?

I have created several custom commands already and use them in rules. At this point when i select the capability, and then the device, and then click “new custom command” i get the spinner and then it goes away and nothing happens. Ideas? I tried selecting different capabilities (thermostat, switch, etc) and get the same result.

Live logging shows this error when I select the new custom command button…

4:14:23 AM MST: error java.lang.NumberFormatException: For input string: “Water Detected. Please Check For A Leak.” @ line 587

This string was used by an old custom command thst I created and have since deleted weeks ago. Im running 1.8.2/1.8.4.

That’s unfortunate. It looks like the old parameter is hanging around. Is it possible for you to go into the previous Custom Command that had that string, and remove (deselect) the parameter information? I think if you do that, this error should go away. There is a problem with old inputs hanging around. Please try that and report back.

It is not possible as far as I know. I deleted that custom command. Unless there is some way to resurrect a deleted custom command. I’m assuming that is not possible. Is it?

Just go through the same steps as before, the parameters are still there. Get far enough into creating it to get to the parameters page. Then remove the parameters in backwards order of entering them. Remove the string first, then the parameter. Then you don’t need to save that command. Just want to clear out the parameter fields from before.

I can’t get past this menu to even get to the parameters page. Or am I misunderstanding something?

Was it a command for the Nest that had the string? Does it throw that error when you hit “New Custom command” on that screen you showed?

Tagging @Mike_Maxwell

It wasn’t for the Nest. Is was one of the play commands for the Sonos. I realized I didn’t need that command and could use the direct speech commands from rule machine. I’m trying to add the away() command for nest now which is why I am testing with that capability. I get the same failure now under other capabilities though (switch, etc).

I have rebooted the hub which doesn’t make any difference.

I understand. I just pushed a tweak to Rule Machine that may get you out of this. Please get that and see if you can get beyond this error with that version. If not, there are some other things we can do to get you unstuck.

Rule Machine version 1.8.2a

Rule Machine github: https://github.com/bravenel/Rule-Trigger/blob/master/smartapps/bravenel/rule-machine.src/rule-machine.groovy. Save and Publish for me.

Please let me know if that gets you unstuck!!

EDITED TO ADD: Look now in Github for that 1.8.2a