[RELEASE] Zooz Double Plug

This worked perfectly. my vote would be make less event list entries the default, or even standard and someone could un-comment it if desired.

woo hoo, wrote my first dth.

Fine… I added an “l” to faiure. :slight_smile:


I changed the Power Reporting Frequency to every 5 seconds but it’s not working. It takes 30 seconds for the power to be reflected. I realize that polling zwave every 5 seconds is not a great idea but just trying something…

Thanks again for writing this, much appreciated!!!

I just tested every built-in driver I could find that supports child devices and none of the children work with the new mobile app.

As far as I can tell this is a platform bug and not something that can be fixed in the handler, but if anyone knows of a multi endpoint parent/child DTH that works in the new mobile app let me know.

In the new mobile app you can still view the details of the parent device, control both outlets together, and control all devices using SmartApps, but you won’t be able to open the individual outlets and see their details.

This should be fixed in the version I just posted.

Fixed in latest version. (I used my power strip handler as a template for this handler which is why the typo was in both handlers…)

The lowest supported value for all the reporting intervals is 30 seconds so I’ve removed the lower options in the version I just posted.

Ouch… was hoping to use the double plug to let me know once an HVAC pump turns on (so that I know it’s regularly working). Unfortunately these Little Giant pumps turn on for about 5-10 seconds.

@TheSmartestHouse is there ability or future enhancements with you products to do proactive notification (push from device to the hub) when a plug goes from zero watts (or some set-able minimum) to anything above? Another workaround is to push the values upon any power changes. It would be an awesome feature for notifications but I’m not sure how feasible my proposal is. Appreciate any consideration!

If you set the Power Reporting Threshold setting to 1A it should report power every time it changes by 1A or more.

I believe the frequency setting is independent of the threshold setting and is used to report the power at regular intervals.


The problem is that the equipment is low in energy consumption. Let’s say it eats 7 watts times 120v lands us at 840mA and shy of the full amp. I’ll still give it a shot, thanks for the suggestion!

Hopefully, @TheSmartestHouse will consider my point for future enhancements. Any change in energy should hopefully be reported ASAP back to the hub.

Apparently, the new Z-Wave requirements are that any automatic reports can’t be sent in lower intervals than 30 seconds, so the first change should be reported immediately but the device won’t be able to send another report sooner than in 30 seconds. So if we implemented more frequent reports the devices wouldn’t pass certification.

@krlaframboise and @TheSmartestHouse thank you both for the prompt responses! I guess I’m back to wifi plugs (still considering a few) rather than zwave — the problem is that it gets up to 120 in the attic in SoCal while most devices rate up to 104 degrees. I can always go back to my ESP8266 attempt with AC monitoring and MQTT as comm which I wish was more reliable but the heat probably doesn’t help.

I am guessing this is to curb mesh network traffic. I have issues with too much traffic and even though I have set the reports to long intervals I can’t seem to quiet it down enough. Some DTHs that have these settings tend to default to frequent reports that may then cause issues on the network unbeknownst to the user. I think defaults should be “less chatty” and that there could be a warning to the user about making them more chatty. Obviously, on a network with 15 devices the chattiness might not be an issue but with a couple hundred devices chatting away it definitely is.

Yeah, that’s how it looks. These are all issues that weren’t really surfacing a couple of years ago with early adoption but they’re quite visible to some of the folks that have been integrating Z-Wave for a while and have accumulated a number devices linked with rules, notifications, and scenes which all build up traffic on top of the default reports. We’ll be sure to talk more about it on the Zooz support page and in the printed documentation of the Zooz devices.


Just added - I really like the design! Anyhow I’m using Smartthings classic app - installed both DTHs . It discovers 4 devices, but the USB one disappears. I end off with Zooz Double Plug, Zooz Double Plug - LEFT, Zooz Double Plug - RIGHT, but the Zoos Double Plug - USB which showed up in Add a Thing, disappears once I save. I know it’s not able to control yet - but it’s permanently ON and gives zero additional information in the Zoos Double Plug device .

(And yes, I’ve excluded and re-added from scratch - four devices show up in Add a thing (pretty cool!) - but only three remain once I do “save”)

I think that’s by design since the USB can’t actually be controlled.

That’s by design. You’ll be able to see the USB in SmartApps and you can see the status on the device details screen, but it won’t appear in the Things list.

If it’s stuck showing ON, tap refresh.

Got it - you can see where it might be confusing, though, to see all 4 devices being created and then having one disappear.

Also - at
https://www.thesmartesthouse.com/products/zooz-z-wave-plus-s2-double-plug-zen25-with-usb-port it says
"Whether you include it automatically or manually, you’ll see 4 new on/off devices in your app:

2 channels for on/off control
1 channel for on/off monitoring (the USB port reporting charging / charged status, no control)
1 master node to control both outlets at the same time and to access and adjust advanced settings in (if your hub supports parameter input)"

which made me think something was missing. Maybe they should update their text for SmartThings.

All good - thanks for the reply.

Is it normal for the USB to show ON when there is nothing plugged into it?

That’s what I’m getting too. I’ve tried refresh, reset, sync - the USB status is always ON whether or not I have something plugged in or not to the USB outlet. I’ve let it charge up my iPhone - and even then it stays ON. (I thought it would go off once I’d reached full charge? )

Actually - as mentioned below, the USB seems permanently stuck on ‘ON’ whatever I do (I’ve done reset, refresh, sync, plugged in devices, removed, fully charged devices, etc. )

Mine did go to off when I had an iPad plugged into it and it reached full charge. It flopped back and forth between on and off as it maintained 100% charge.

Open live logging, plug a usb device into it, wait about 30 seconds, remove the device, and then post the logging results. (make sure you filter live logging by device so that only the double plug’s events are shown)

Zooz is aware of this issue…