[Release] Virtual Alexa Switch/Button

I use this to control my diy blinds to and tasmota wall switch, and 2 days ago they stopped working anybody else have probs, did Amazon or ST kill this .

Smartthings released a new version of their Alexa skill which has had several glitches. :disappointed_relieved: reportedly they are working on a fix:

It might not be related to the problem you’re seeing, but the timing sounds the same.

didnt know about new app skill thx. so install it and now alexa sees both my new app devices and my old. can i disable old or uninstall it
----update alexa/echo is calling the new devices a different name "bedroom light " smarthings switch instead of “bedroom light” smarthings so i have double the devices

Having trouble.

I just used this DH to create a device to use with Alexa. I had the Classic skill, but when my routine based on the virtual switch/sensor didn’t work, I disabled the skill, logged out, logged back in, and now I’m stuck with the new skill.

When I change the switch state in ST, I see the switch change state in Alexa. However, even though my Alexa routine is based on the virtual sensor changing state, the routine doesn’t trigger. I also don’t see a separate sensor device in Alexa (should I?).


The device should be seen as the same, that is only one device… In the main device view it will only show as a switch, but will be shown in routines as the sensor.

My guess is the issue is based on the new skill…

If anyone is interested, I created a stateless Capability Alexa Virtual Device:
This is stateless, ie you can turn it on when it is already on and so on; the same goes for the sensors.
It is a switch (which triggers the contact sensor) and a dimmer (which triggers the motion sensor).
I needed it as I had a single device with a high and low mode selector, as well as the on and off… hopefully it can help someone else as well!


Nice addition.

Calling it “4way” is a little confusing - initially thought this related to multiple-switches controlling one output. Now I see this devicehandler is Switch+Level+Contact+Motion, which makes Alexa integration simple.


Very true; what do think would be a more appropriate name?

1 Like

Just suggesting
“Alexa Virtual Switch or Virtual Dimmer”


Personally, I would probably call it a “4 capability Alexa Virtual Device (Contact Sensor/Switch; Motion Sensor/Dimmer)”, but that might be too technical for most people. :sunglasses:


Thank you @ero4444, @dotan_shai, & @JDRoberts for your naming suggestions!
I have renamed it to Stateless 4 Capability Alexa Virtual Device



Were you able to make the routine work? I have the same issue here. I am located on Mexico. I wonder if there is an issue based on the locale. Are you also outside US or UK?


Just tried setting this up and having an issue where I can select the “contact sensor” as a trigger in Alexa routines and the state switching is working (when I turn the switch on in smartthings, it shows as on in Alexa) but routines are not getting triggered.

Anyone have a solution? Using the new skill.

Edit: Just checked, my contact sensor is displaying as a switch in the Alexa app. However, I can also select it for use as a contact sensor in the “when” section in routines but the routine doesn’t trigger when the contact sensor is opened.

I’m going to try these newer device handlers in this thread, but here’s an old one (below) that I’ve been using. Too bad the built-in SmartThings ‘Simulated Contact or Motion Sensor’ doesn’t do what we need, because I can manually trigger them in the old SmartThings app.

I’ve been using the Mike Maxwell uDTH for a long time which still works. However, it has a visual glitch when viewing its device page in the new SmartThings app, and it doesn’t allow manually toggling it in the new SmartThings app device page even though Automations can toggle it so it does basically work. I can manually toggle it using the old SmartThings app so that I can test the Alexa Routines using it.

(link removed)

UPDATE: I just tried the Simulated Alexa Switch DTH in this thread and it works fine in the new SmartThings app. It visually looks good and I can manually toggle it and use Automations to toggle it too. Nice!

Sounds like you are having the same issue as many others of us… we’re still waiting on feedback.

I’m now using this ‘Simulated Alexa Switch’ and so far it’s triggering my Alexa Routines just fine.

In my case, I’m using the new Alexa skill, but when I first started using it a few months ago, I wiped everything in Alexa in the web and started the new Alexa skill fresh since I wasn’t using any Alexa Routines in the old skill anyway. And these new Alexa Switches are freshly created too since I just started using this device handler the other day. So far two Simulated Alexa Switches that I have created are triggering the three Alexa Routines I have configured using them which are being initially triggered from SmartThings Automations.

UPDATE: I had the STHM false trigger today since I was including all sensors. These Alexa Switches appear to the STHM as open/close sensors so I have now excluded them in the STHM.

Super DH but now when I migrate to the new Smarthings App, the created virtual devices do not show up. Pretty annoying. Anybody else have this problem?

Hi, im new on here but have been using the simulated switch for a while now, only problem is as of tuesday just gone none of the triggers for motion, contact or simulated operate anymore, from the testing ive done im convinced its a problem with the smartthings skill on Alexa, do you guys in the know agree with this, Ive found i can see the trigger from smartthings open and close in the elexa app but since tuesday no longer operates it, Ive also been on to tec support on amazon but they seem to think its the device, i have a dot and show and both stopped working at the same time, ive even tried setting up a temp alexa account to see if that cured it, intersted in your comments cheers Dave

Hi @uncledaveghr. Welcome to the group!
SmartThings engineers are aware of the problem, and as far as I know, working on a solution. It doesn’t seem to be affecting everyone, but there are a few threads with folks talking about it.

1 Like

I added a new device of this device type today. It shows up in the new app fine. But once it was used, the contact sensor part and the switch part no longer remained in sync.

Here you can see the switch is off, but the contact sensor remains open.