SmartThings Community

[RELEASE] Motion Sensor Thermostat with Remote temperature sensors, Presence detection and Schedules

motionsensor
thermostat
temperature
smartapp_hvac
rboyapps

(www.rboyapps.com - Make your home your butler!) #36

How are you controlling the mini split? With a Z-Wave thermostat? If so
then configure the idle temperatures so that the A/C will turn off (i.e.
set heat to 50 and cool to 90).


#37

Hey RBoy, I installed 2 instances of this app this weekend. One was for a weekday schedule and the other was for the weekend. I selected the option to run only during a certain time period and only during the correct days for each instance but even this the restrictions, my thermostat was being set by both. So my weekday instance was running yesterday, Sunday, and then they both ran overnight even though the time restrictions did not include any time frame at night. Any idea why this happened?


(www.rboyapps.com - Make your home your butler!) #38

Are you sure it’s coming from the apps? It’s likely a configuration issue. Double check the AM / PM, that’s the most common issue. If you want you can PM your settings for both apps and We can try to replicate it. I’ve use two instances of the app for a single thermostat in a similar fashion and it’s been working okay, hence my guess it’s a configuration issue.


#39

I dont think it was a pm/am issue since I also had day restrictions so even if it was am/pm issues, one of the instances shouldn’t have been running. I have since removed the instances but I can set it up again this weekend and PM my settings if it starts to happen again.


#40

RBoy, I tried this again and still had the same results. This first picture shows both instances running at the same time.


This is my weekday settings

And my weekend settings

I also use your 5-2 day thermostat schedule. No sure if having that installed as well is causing the problem.


(www.rboyapps.com - Make your home your butler!) #41

Thanks for that, okay I see what’s happening. This was a safety protocol built into the app to prevent a run away HVAC system setting (especially when using remote sensors). When an idle situation is detected the app ALWAYS sends the idle temperatures back to the thermostat and it does it irrespective of the configured weekday/time as a safety measure. So in your case because you have concurrently running smartapps you’re seeing two commands being sent for IDLE mode (this does not impact operating/motion detected temperatures as they will adhere to configured days/times).
If you have the same temperatures defined for IDLE mode in both SmartApps it will not impact the operation is any way. However we will look it and address this in the next release.

Thanks for bring this to our notice.


(www.rboyapps.com - Make your home your butler!) #42

Motion Sensor Based Thermostat - Version 02.02.00

  • Support for multiple concurrent instances of the SmartApp

#43

Thanks for the quick update. The way I am planning on using this is for my bedroom. During the day, I use your 5-2 day scheduler to set the temp high or low so that my unit doesn’t turn on since no one is home. My partner has odd hours though and that sometimes does not fit into the set schedule. So I liked this because now once motion was detected, we could automatically adjust the temperature. But since the thermostat is in the bedroom, I realized that due to the safety built in, it would send the idle temperature overnight while we are sleeping if the motion sensor doesn’t detect our movements while we sleep.

Would the last update help address that?


(www.rboyapps.com - Make your home your butler!) #44

Yes that was one of the primary use cases for this SmartApp, infrequent/unknown hours of access during specific times.

EDIT: If you want to be energy efficient, you can also use this SmartApp in your bedroom at night. For the night schedule set the SmartApp inactivity timeout to 2 hours. So everytime you move it has a 2 hour window to maintain the temperature and then it sets it back to Idle if there’s no movement for 2 hours. This way it tends to follow sleep patterns, during deep sleep when there’s no movement it keeps the AC on IDLE and when you start coming out of deep sleep it switches it back on.

This has now been patched up and should work fine now. Safety has not been compromised but it won’t interfere with other SmartApps outside operating hours now and supports multiple concurrently installed instances.

You can use the 5-2 days and this SmartApp together, just make sure that they don’t have overlapping schedules. E.g. if the Motion Detection SmartApp stops at 5pm then the 5-2 Day thermostat should kick in after 5:10pm and you’re good. I would leave a 5-10 minute gap between the two SmartApp schedules to avoid overlaps due to ST timers accuracy and motion sensors quirks.


#45

Thanks for the tip. I hadn’t thought of that.


(www.rboyapps.com - Make your home your butler!) #46

Better yet, just released an update to improve the accuracy of the safety Idle to avoid the scheduled gap I spoke of earlier. With this patch, the SmartApp will check if an Idle is required at the end of the schedule and set it and if not it will skip it so you can avoid the “gap” between schedule. Do note that after updating to this patch you will need to open and click Done to reinitialize the SmartApp.


(www.rboyapps.com - Make your home your butler!) #47

Motion Sensor Based Thermostat - Version 02.02.01

  • Improved support for multiple concurrent instances of the SmartApp

As soon as the operating schedule ends of one SmartApp ends you schedule another instance of the SmartApp to start the next operating schedule. You can add as many SmartApps instance as you like now without any operating schedule gaps.

NOTE: After updating to this version of the code you will need to Open the SmartApp and click Done


(www.rboyapps.com - Make your home your butler!) #48

Motion Sensor Based Thermostat - Version 02.03.00

  • Updated app to support ST’s new Thermostat device handler with ‘Deadzones’
  • Improves support for end time going past midnight into next day

SmartThings new thermostat defines deadzones which would interfere with the operation of this SmartApp when using remote sensors. Update to this version if you’re using Remote Sensors.


(G) #49

@RBoy
Does the app include possibility to add presence sensor (phone) as well or only motion sensors? Don’t see it in the code from the original old version.

Thanks


(www.rboyapps.com - Make your home your butler!) #50

The premium app has mode based conditions (i.e. run only in certain modes) with a remote sensor option.

Not quite sure what you mean by presence based. i.e. you want the thermostat to work only when certain people are present? If so have you considered linking the modes to presence through a routine. E.g. when X arrives, change mode to “Home”.


(G) #51

Yes, that’s what I mean, I thought adding presence sensor same way like you select the motion sensors, but you’re right with your suggestion how to solve that.
Thanks


(G) #52

@RBoy
I have one more question RBoy, what happens if someone overrides the temperature on the thermostat or change the mode manually?

Thanks


(www.rboyapps.com - Make your home your butler!) #53

It’ll stay that way until the next motion sensor activity is reported and then the SmartApp will kick in and do it’s thing.
The app will only run in the mode you’ve configured it to run, so if you change it to a mode that isn’t in the configured list it’ll ignore the motion detection events (the app doesn’t modify the modes).


(G) #54

Got it
Thanks


(Head of Support (rboyapps.com)) #55

Motion Sensor Based Thermostat - Version 02.03.02

  • Added advanced settings option to enable battery saver mode (reduces verification communications, only enable if you have a strong mesh with repeaters especially while using remote temperature sensors)

© RBoy Apps