RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)

dth_speakers
dth_voice
dth_alerts

#909

I need a little help with my speakers. I have 2 jam symphony speakers. I installed the media renderer and player. The speakers are acknowledged and are connected to smartthings, but I cant get anything out of them as needed. They are working with some notifications but others they don’t. Please help.


(Joel W) #910

@ule I am getting the following message, not sure what it means, logs say Media renderer problem.


#911

@LeeC77, Squeezebox works 50/50…I ended up creating virtual buttons that are assigned to my favorite webstream radios.


(Ule) #912

Hi, I think your MediRenderer Device is sending a wrong MetaData xml , or the xml is bigger than SmartThings supports, you can share your Speaker Model to see if others users have that problem


(Joel W) #913

My speaker is rhe Fabriq original model. Fabriq info on Amazon


(Dana ) #914

Just want to say thanks…Fabriq speaker arrived today, I already had the DTH and smart apps in place, so it was just a few minutes until I was adding audio broadcasts to several of my webCore pistons where audio was appropriate. Very nice.


#915

@ule thanks for all of this! Is there any word when multiple Chromecast/google Home devices might be supported? For awhile, using bubbleupnp to create a virtual DLNA of a CC group worked, but it was hit and miss.


#916

I got a Fabriq from Amazon yesterday and have it setup. Playing sounds or pre-recorded voice messages from my local router are nearly instant but using webcore speak has a 3 or 4 second delay.

Is this normal? I suspect it is, but asking in case I’m missing something that could improve the performance. Thanks!


#917

I’m having the same problem. Did you ever get it resolved? If so, how?


#918

Sorry to say I never got it resolved. I’ll keep you posted if I do and please do the same.


#919

Will do thanks!


(Dana ) #920

I’m not having a consistent delay issue w/TTS from webCore pistons on my Frabiq speaker. Much of the the time the entire phrase plays, worst case is usually just that the fist word in the phase gets cut off partially. I’ve taken the approach to start TTS statements with "Hey - " so that if it gets cut off it doesn’t matter. :slight_smile:

@gst - I haven’t tried any pre-recorded statements or sounds yet. Would appreciate a pointer to where I can read up on using pre-recorded voice or sound files in webCore with the Fabriq speaker.


(Cesar Vasquez) #921

Is there any video tutorial for newbies to get working this?


#922

Is there any chance someone here can help me set up a music player/text to speech. I basically have everything setup as far as the Generic Media Renderer and Connect. Smarrthings recognizes it and everything. Somethings work on it, but others don’t. I just feel like I am missing a piece somewhere. Just an example using Webcore, I am using a piston for a takeout the trash reminder. The piston basically flashes lights (which works) and is supposed to say “Take out the trash” on my Jam wifi speaker, but nothing comes out of the speaker. Is there a way to test if my speaker is truly connected? I think what I am missing is some sort of “player”…something to actually make things play such as music tracks because the speakers work and are connected. I think another way of looking at it is when I set up some notifications, it allows to play a certain track after a trigger but I don’t have a player that contains the tracks.


#923

I’m using “Play Track” and then specify the URL to the mp3, i loaded them on a flash drive which is plugged into my WiFi router. I also have the Aeon Labs Doorbell which can play mp3’s but doesn’t have TTS.


(Dana ) #924

A simple webCore piston using TTS for garage door opening is below…you need to enable your speaker in webCore in the webCore SmartApp on you phone, and then you can use the “speak” command w/your speaker to send a text string to your speaker. It should work if everything is set up properly.

The “music player” device below is where your speaker name will appear when you select it for the task.

Dialog in webCore:


#925

I do have it set up that way. I have my speakers setup in Webcore. Is there anything special I should see when I go to my Smatthings “things” I see my 2 speakers in there with a current status of “STOPPED”. I noticed in one of my speaker settings that I have a place to set a TTS KEY. I don’t know what that “key” is, but maybe if I get it set, then my speaker would speak. I’m just guessing at this point. More than likely, I am waayyy off base.


(Dana ) #926

Those questions are above my pay grade…my speaker does show up as “Stopped” but plays TTS fine - so I think Stopped is just the current status when you look at it in the ST app.


#927

Lol…with my pay grade, I probably shouldn’t even be on this forum. Let me ask you this…what do you use to play tracks or send TTS messages to your speakers.


(Dana ) #928

I’ve only used webCore to play TTS on my Fabriq speaker. That’s my primary tool for automations so I did it there.

I looked at my speaker details and it has a TTS Key field that is empty as well, so I don’t think that’s your issue…sorry I can’t help.

My screen for the speaker in SmartThings (from the Things list) looks like this…each time I tap the speaker w/the “MSG Enabled” option it cycles through to another setting (DIsabled, OnStopped, OnPlaying) and then back to Enabled again.

As you can see