RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)

I’ve tried this now and I can confirm that “/MediaRenderer/RenderingControl/Control” solves the issue if I replace all rccurl occurance with it.

if you want to use that until a new version is released that is upto you. There is a more eloquent way of doing this via the discovery section of the smartapp of hardcoding this when a sonos is is discovered but not when a sonos is device is discovered.

Hi , I have release a method to speech to alexa , I use an android phone, try it

I could use some assistance. I have enabled upnp on my router Cisco E3000. I am using a Jongo S3 speaker. I have followed the instructions and created the App and the Device type Handler. I am also using the Smart Alarm app and have enabled custom notifications on the Jongo S3 but the text to speach is not coming through, I can see in the recent events of the Jongo that somethings is trying to fire but nothing comes through. Any Ideas, did I do something wrong?

I am having some issues with my Kodi on a tablet setup (using Network Audio Remote for Android as CP). It was working fine over the last couple of days. As of this morning, any time I open up the Things portion on my ST app and try to open the speaker/renderer, ST app crashes every time. I know ST is having issues galore over the past several weeks and they are in the process of resolving them now. None of my other 30+ things do this when I open up the thing in detail in the app (lights, switches, sensors, etc.). I have uninstalled and reinstalled several times this morning. I have tried using BubbleUPnP and others on my tablet to no avail and they’re not even discovered. Kodi is discovered quickly, as it always has been, and try to re-setup the speaker, but just keeps crashing. The funny this is that I can manually play a song on my tablet and view the list of things on the ST app and it will show my Kodi speaker thing as “playing”. But as soon as I touch it to open up the player it shows a white screen and crashes. Any ideas or should we chalk it up to the ST issues?

On another note, anyone else have a good DLNA software-on-a-tablet setup for music and notifications? Kodi and NAR seem to be okay, but just curious if there was something better. Thanks in advance!

Hi @CodyWillner,

  1. Have you te last release of generic MR?
  2. Could you send me the logs when the app crash
  3. is there a list with the soft players in
    Working Speakers (44 Devices Confirmed , 29 waiting Confirmation) last addition: Klipsch Stadium, Help Us to increase the list

Could you possibly help me out with my issue above.

Hi @GunGeek

  1. Could you test with the smartapp media renderer events

  2. the speaker can play some sound (from mediarenderer events apps)?

  3. the text to speech is working ?


Text to speech functions which are using Ivona TTS stopped working.
Did you make any change that could affect this ?

the URL formed from the app is as below:


note that I’ve changed the key in it because this is public.



I think I have a clue on what happened.
According to my Ivona usage statistics, I could not use Ivona after 27th (sunday) midnight.
That’s when DST starts in my country (Turkey)
So it might be an issue of signing POST and GET requests with correct date.
What do you think ?

What is the tts.php doing in this transaction ? Does it use an hardcoded timezone / DST setting ?


Hi @mrmrmrmr, update to last release. it’s working fine

Have you included Ivona TTS in your device handler ?
Because that’s how I’m using it. I don’t use the DLNA events.
Can you tell me what you’ve changed in the Ivona part ?

I must be doing something wrong I cant get it to play either way. I cant even get it to play a sound. and when I go into smartthings app to see the jongo s3 the app crashes. Its only this device that does it.

Hey @ule. I am on the latest release of MR connect, MR events, and MR player. I am unfamiliar on how to get the logs, especially of those apps/processes I have deleted and re-installed. I am trying to re-setup my Kodi (localhost on Android) but now I can’t discover it via ST. I have not changed anything with ST or my Android/Kodi setup, but now it just won’t discover it at all. I’ve waited 10 minutes on the discovery part of the app and it’s not finding it as a renderer anymore. Very strange as it was just working a few days ago, then when it started to freeze it was still at least discoverable, but now it’s just not being found at all. I’m thinking it had something to do with all of the changes ST is doing. I will reset everything and try again and let you know if I can at least discover the renderer and get some logs. Thanks @ule!

HI @CodyWillner,

  1. Verify your router settings and check upnp its enabled
  2. Try to use some upnp finder to check your kodi it´s visible on your network ex Browse UPnP
  3. If you can find the device in your network but no ST.
    3a) Disconnect and reconnect your ST hub (some times works)
    3b) Try to change the ip of your mediarenderer

Hi @GunGeek, In Thing sections on ST app (IOS or Android) you must see your jongo speaker and the status, if the status is “NOT PRESENT” your jongo can not be reached, try to use some upnp app to check if your jongo its in your network.

It is present, shows playing. I can play audio from my network share on the Jongo through the jongo app on android. I can see the jongo on my PC for streaming and stream audio from network to jongo on pc as well. Again as soon as I click on the jongo in smartthings the app crashes. I got into see it in smart things one out of 10 times. I viewed the history and see both smartapps trying to either play a message or sound but nothing comes through the jongo. I have tried TTS and just a simple sound nothing so far.

Hi, I have update the speech to alexa connect app, now you can control switch devices with it. and you can add other languages to control.

Its really good option, just to take your android phone click the mic in firefox and ask , “turn on the kitchen light at 75%”

you can be anywhere, no need to be in house to control the switches, for me its better that to open the smartthings app and find the thing

and like google have several languages you can add other languages commands, I have added spanish , but its easy to add others.

I can say “enciende la luz de la cocina al 50%” or “apaga la bocina de la sala”

you can try it.

Is it possible for this to work with the Fire TV at all? Maybe using the AirPlay/DLNA Receiver (PRO) app? The goal is to have SmartThings driven sound notification coming through the Fire TV (assuing it is turned on) when ANY app is being used.

Hi @Automated_House, Sorry I dont understand your question, do you want to use the fire tv like ST speaker? the answer : maybe is possible, Fire TV have the DLNA app, but I dont known if is compatible , the software mediarenderer change the id each time is turned on, or maybe do not send all information, if the app have all DLNA settings it must work, but no one has confirmed it works
sorry if I misunderstand your question