RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)


Thank you!

I had been searching and could not find a good link…

1 Like


I will be trying this sometime today…

HI @vitamincm, I have post an article to allow airplay and bluetooth speakers.

This worked for me with old version of ST app. Yay.

1 Like

I am getting this same error. I tried to follow the thread but couldn’t see it – did you guys figure that out?


I am also getting the “Error - bad state. Unable to complete page configuration” error. As suggested in this link, I tried clearing app cache and data. Didn’t solve the problem. I am on Android 5.02.

Some users have reported the newest version on android have some problems, no just this app, other apps too, @Navat604 have provided a download link to use the smartthings android app v 1.6.9, you can try his recommendation, With iphone I have not problems.
A known problem is with schedule functions, smartthings have problems and this function crash some times. but if you try some times the devices can be added.

@rog - how did you set up your Rocki to get this working properly? All my does is play “deh” sound.

This is a fantastic idea! I can’t afford Sonos speakers and thought that I was out of luck! I was able to find my Linksys Wireless AC1200 repeater that has DLNA capability but it says “No Connect” on the things page. Any idea what might be the problem?

Hi @camdenkrupala, Great news, Could you get me more info?
In wich step from the instalation are you?
Have you readed the first post?

I read the first post, I added and published the device type and app and was able to load it onto my phone and use it to find the extender and add it. It shows up in the things menu but it is greyed out and has “No connect” under the picture of the speaker.

Hi @camdenkrupala, I dont remember to have a state call “No connect” maybe “No Present” , are you sure is “No Connect”, please confirm

My mistake, it is in fact “no present”.

I’ve never actually tried to stream anything to it before, I’ll troubleshoot the repeater and see if it even works.

Hi @camdenkrupala, “No present” state is displayed when is not response from the unit, maybe tuned off, or not in network, each 5 minutes the connect app, search for new changes, if no change is detected maybe the device is not in network. try to use some control point to confirm the device is working in network, if you have not a media server , you can try the technics app, it can send music from your phone.
In github there are 2 versions , the newest and old, please confirm you have installed both newest (smartapp and device)
Thanks for share yours experiences

Hi @ule, I confirmed that the unit is connected. I was able to stream an MP3 to it from Windows Media Player. I tried refreshing the status of the app as well as letting it refresh, it doesn’t seem to be loosing connection or anything. I will try deleting, recopy/pasting the device and app code, and finally re-adding the device to make sure I did everything right. Thanks for all of your help!

Update: I deleted everything and re-copy/pasted the code. I’m still able to find the Extender with the Connect app, but it still shows “No Present”

Has anyone tried this with Amazon Echo? Is it even DLNA capable?

[quote=“bgadam, post:158, topic:11176, full:true”]
Has anyone tried this with Amazon Echo? Is it even DLNA capable?
[/quote]It’s not. But that was one of my first suggestions when I got it. Support AirPlay and DLNA. So far, nope.

1 Like

Finally got this installed after reverting the ST app back to v1.6.9 on Android as recommended!

I’m connecting my to Kodi running on a QNAP behind my TV, so far it’s working great with only a small delay. Now I’m off to find a way to dim the lights when we start watching stuff…

Thanks for the install tips guys!

Hi @ule, I added a pull request to your repository to fix a tiny issue I found when playing with the Striim Light. An ‘&’ in a URI would cause an error with XML parsing, so it needed to be changed to “&”.

Let us know when you get this working. There is a callback script for xbmc to interact with endpoint but it’s way above my none coder skill.