[RELEASE] Amcrest IPM-721 & IP2M-841 LIVE Video/PTZ/Night Vision/Motion/Video Record/+More IP Camera DTH

Did you not upgrade to v3? What did you have to change to make it work in your environment?
If I’m missing something in v3 that could make it work for more people, that’s what I’m all about!

@thom, it’s been a while so hopefully you’ve found something that works for you, but that send trigger to blue iris app, as well as profile/mode syncing and a ton of other features are all rolled into the BI Fusion app I wrote and @Belgarion recommended. It’s goal is to only have to enter an input once, and streamline setup when you have multiple cameras. So you only need one app and type your password and IP once, etc. Hop over to the forum to see if your interested and feel free to message me for help.

@JMZ, I just upgrade to V3 last week and got rid of all of the hacks that I added to the old version.

Nice work on V3… good stuff! Using V3 for the camera motion sensors and the mode switching, coupled with the native BI viewing app, my DTH is no longer a “missing piece” of my setup. All 8 Amcrest cameras are happy again. :+1:

Hey cool!!! I just pushed an update in the last hour or so, I had a handful of lingering medium sized bugs in PTZ and polling. It seems to be fixed now though.

Glad they’re humming along well!! You might have the biggest collection I’ve heard of, definitely a test of your network, Blue Iris, SmartThings, and BI Fusion! Super :sunglasses:

Hi folks. Has there been a workaround to use Amcrest cameras with ST. Or do you need to run it through iris app.

Blue Iris. No other stable workaround that I have found.

Thanks David. Is iris the program that you have to have running 24/7 on a pc?

It’s blue iris, as @Belgarion mentioned. And yes it will need to be running on an always-on PC.

Assuming you want your IP camera system to be available for viewing/recording 24/7.

Iris is the name of the home automation system sold exclusively at Lowe’s, FYI.

Is it possible to downgrade the Amcrest firmware if needed in order for this DTH to work? I’ve had a lot of stability issues using BI and thought it would be something worth trying, but I don’t want to brick a camera in the process.

Hi @Belgarion arion, I have an Amcrest camera and initially installed your app then I tried blue iris from @JMZ but I must be missing something. I’m very new to ST so sorry for the noob questions. Is it possible for you to guide me on how to setup amcrest camera using BI on ST? TIA

First set up your Amcrest camera as usual in Blue Iris. Then follow the FAQ in the BI Fusion thread and the detailed instructions it links to on github. The instruction set it really detailed, but let me know if you are having trouble.

Thanks for replying. Had the worst luck. My hard drive on my cpu died on me so need to order a new one. Will update once I get my “BI server” up.


Prehaps this document can help with digest authentication

Look here

Hello :slight_smile:

I need to integrate my Amcrest Camera with my smartthings system.
I have followed the directions on the site: link
But I have not succeeded :frowning:; or am I doing something wrong?

Camera Information:

  • Software version: V2.420.AC00.18.R, Build Date: 2020-02-17
  • WEB version: 3.2.1.619604
  • ONVIF version: 16.12(V2.4.1.513183)
  • Model: IP2M-841

Can you help me and/or find out if there is any update to the procedure or another way to achieve this integration between Amcrest and SmartThings?

Cordially
mm

Check this out since you have an onvif camera.

2 Likes

Hi,
Thank you, I think that in this other way I will advance much more :blush:.

I followed all the instructions and managed to detect the two (2) cameras that I have and also generate the Group with them later. I think I’m very close to it

But now it happens that they don’t display video image yet…


What can I check in the camera settings?
mm

1 Like

Tagging @TAustin & @fido

1 Like

A couple questions:

  1. If you look at your info table at the bottom, do you see a resolution value, and what is it?

  2. Are there any unusual characters in your username or password? That can trip up SmartThings since the username and pw get sent along with the video streaming URL. If you do have any, can you try creating credentials with just standard alphanumeric characters?

Hello
Sorry, I couldn’t answer earlier…
Checking the two points:

  1. I confirm that the credentials theme is correct, using only standard alphanumeric characters
  2. I have captured the information in the image:

That looks good. Is your camera and hub on the same subnet?

Hi,
Something strange happens to me: When I made the configurations (initially), I did not have the correct result (did not work). But then (the next day), I checked the app again (without doing anything!!!) and found that it worked Ok. But when I close and reopen the App (immediately) it stops working. I have noticed that after a while it “apparently” seems to work as I indicated before, but then it stops working and doesn’t work anymore :frowning: (leaving the image of the last video capture).

Fail:

Ok:

I suppose that and since there are moments that it works well, it leads me to think that all the parameters are correct: users, password, resolution, subnet, etc., although it is very strange that it only happens for a few moments until I finish the app, then when reopening it, it fails again…, despite closing/terminating the App and/or restarting it again or even restarting the entire cell phone… I’m not sure if it’s a time or under what conditions the app works again video on cameras, but happen sometimes

To the question, if I confirm that indeed all my Devices in my house are in the same subnet and in my case it is: 192.168.50.##

• Camera #1 in the Lounge: 192.168.50.45
• Camera #2 in the Living Room: 192.168.50.53
• SmartThings hub: 192.168.50.50/51