SmartThings Community

[RELEASE] Alexa Helper

echo
smartapp_voice
(Micheal ) #606

Ok…Something changed on the SmartThings processing side. The new error “com.netflix.hystrix.exception.HystrixRuntimeException: C*-IsaState-Get timed-out and fallback disabled” seems to be something on the back end.

However, I was able to compensate for the issue at 725 (which worked until last night). Give 2.9.9d a try.

0 Likes

#607

Still getting that same generic error message on my phone. But there doesn’t appear anything in the log, same stuff as before:

Would resetting the hub be worthwhile? I’ve done a reboot on it this morning and tried again, but that didn’t seem to help either.

0 Likes

#608

I added 2 scenarios with 2.9.9d, “Goodnight” and “Goodmorning” both have this in the log if it’s worth anything.

0 Likes

(Micheal ) #609

No…I think something is going on at SmartThings…that error is some back end server. I am wiping out my scenarios and logging which have issues…but I am starting to get that error in other apps too, so I am almost sure the back end is causing them.

Thanks for pointing out the issue with 725…that was unrelated to what is happening now, but seems to be indicative of a larger issue on the back end. That line was not an issue until just this morning.

0 Likes

(Micheal ) #610

Ok…I deleted my whole config and brought it back in from scratch. I am no longer getting any of the errors…I am using 2.9.9d for the scenario app. Can you confirm you are having the same issue?

Ironically, I needed to set up less scenarios with my new Ask Alexa app coming along nicely (Shameless plug).

0 Likes

(Micheal ) #611

All,

With the documentation a good portion started I a new thread on Ask Alexa. Let’s talk about that app there : [RELEASE] Ask Alexa

0 Likes

(Micheal ) #612

Did your situation get any better? Are you still having issues creating scenarios? Still the same kind (baseboard and Control scenarios)? I know it is no consolation, but I tried and tried to reproduce what you were seeing and I can’t get it to fault.

Let me know if it is any better.

0 Likes

#613

Hey Mike, I saw you last post and removed all my devices and readied them along with the app and now everything is working again. Not sure what happened, but I couldn’t respond because I was limited to only 5 replies the first day or something on the site.

Thanks KS for all your help. Is there a place I could go to donate some money for the app and the help?

0 Likes

(Micheal ) #614

I am pretty sure it was a ST issue today…other folks mentioned random issues and then they went away…anyway, so glad it is working for you now! For what it is worth I did update the app to 2.9.9e…just a small interface tweak…not required, but thought I would let you know.

0 Likes

(Cosmo) #615

Hello @MichaelS , I just started to try and use Alexa Helper for the first time today. I too am having the same “unexpected error” issue that Nick_F is talking about. I verified that the version I downloaded today is 2.9.9e. I have reviewed the Alexa-Helper wiki and I am confident that I haven’t done anything obviously wrong. Any guidance is much appreciated.

0 Likes

(Micheal ) #616

Ok…are you seeing anything in the live logging that indicates a line number issue? That would probably tell you there was a copy/paste error.

Also, there is a small ST ‘quirk’ that you may be running into…when you first add the SmartApp parent, don’t immediately add a scenario…hit Done, then go to your SmartApps list, then try to add a scenario…I keep seeing this bug in the mobile app pop up.

0 Likes

(Cosmo) #617

No errors at all. I tried what you suggested and I still get the “Unexpected Error.”

0 Likes

(Micheal ) #618

Hmmm…ok…starting from the beginning…(sorry if this is redundant):

Make sure you copy the RAW code from the GitHub
Ensure you do NOT publish the scenario code

Questions:

Does the main interface come up. Can you make a screen shot of the about page (and version numbers)?
When you get the error, is it when you add a specific scenario, or ANY scenario?

0 Likes

(Cosmo) #619

Hello. I appreciate you getting back to me. I did copy the RAW code for both. I did not publish the scenario code.

The main interface does come up and I am able to create a new scenario. It is when I try to Control Scenario Settings for “Modes/Routines…” that teh next page gives an unexpected error and displays blank.




0 Likes

(Micheal ) #620

How comfortable are you with editing the code…I just tried on my devices (same code) and could not reproduce.

Also, forgot to ask…did you create any virtual switches from the app?

0 Likes

(Cosmo) #621

I am comfortable editing code. I had created the switches earlier but deleted the switches, uninstalled the SmartApps, uninstalled/re-installed the ST app. Upon re-publishing the SmartApps I am now not able to create the Alexa Switch. It too fails with an unexpected error and blank page. After trying a couple of times it finally created it.

0 Likes

(Cosmo) #622

Here is the log for the error I was seeing when trying to create the switch.

0 Likes

(Micheal ) #623

ok…it won’t fix your problem but it will isolate the issue…I am looking for the proper code bits, but to be clear, if you choose a speaker or voice reporting does it do the same thing?

0 Likes

(Cosmo) #624

Creating a scenario for Voice Reporting completed just fine.

0 Likes

(Micheal ) #625

Ok…that helps…can you try each one? I am betting it is just the control one…

0 Likes